Turn signal only works when hazard button is pressed; hazards do not work - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-08-2016
Member
Thread Starter
 
Join Date: Jul 2016
Location: Texas
Posts: 1
Turn signal only works when hazard button is pressed; hazards do not work

I have a 2006 Ranger. The hazards do not work. The turn signals only work when the hazard button is pressed. Fuses are fine. Wipers, high beams work. Is it the multifunction switch?
Reply With Quote
  #2  
Old 07-10-2016
TheArcticWolf1911's Avatar
Member
 
Join Date: Nov 2015
Location: Evansville, Indiana
Posts: 1,667
It could be the multi function switch, yes; but those are quite pricey. If all the fuses are fine, and all the bulbs are fine, the usual culprit of turn signal malfunctions is the turn signal relay, the little box which makes the iconic 'tick, tick - tick, tick'.

These do go bad from time to time, and they're much cheaper than a multi function switch. These can be found on rockauto and should be available at your local auto parts store.

The turn signal relay is going to be in one of two likely places. Things started changing in 04 so, I can't say for sure. One, it's up under the dash, towards the radio in a black box with other relays. It's likely a colored relay of sorts, like blue or yellow.

If it's not there, then it could also be on the passenger side in the SJB (Smart Junction Box), located in the passenger footwell where other fuses are found and possibly other relays.

Or, instead of hunting around for it, you could turn the turn signal on (engine off) and use your ear to look for it.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1997 turn signals don't work but hazards do [email protected] General Technical & Electrical 5 12-10-2015 11:22 PM
Only one horn button works..anybody else have this problem ? surfrat1 General Technical & Electrical 0 06-23-2015 08:48 PM
Turn Signal and Hazard issue ihranger94 General Technical & Electrical 12 05-10-2015 04:15 AM
Turn Signal and Hazard Relay 01DangerRanger General Technical & Electrical 8 04-19-2012 02:57 PM
Can someone please help me get my turn signals/hazards to work? DSMissed General Ford Ranger Discussion 14 12-26-2009 02:54 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 10:32 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.