Very Strange Light Picture - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-04-2005
0RangerEdge2's Avatar
Member
Thread Starter
iTrader: (2)
 
Join Date: Jun 2005
Location: Ohio
Posts: 2,593
Very Strange Light Picture

I was inspecting my trucks bulbs the other day because my 3rd Brake Light was out and I came across these in my front turnsignals. It seems the lights covering was flaking.
Name:  LightBulb.jpg
Views: 2
Size:  13.8 KBSorry about the pictue quality, bad digital camera.

Last edited by 0RangerEdge2; 07-04-2005 at 01:44 PM.
Reply With Quote
  #2  
Old 07-04-2005
V8 Level II's Avatar
RF Veteran
iTrader: (4)
 
Join Date: Nov 2004
Location: Michigan
Posts: 7,831
Quote:
Originally Posted by 0RangerEdge2
I was inspecting my trucks bulbs the other day because my 3rd Brake Light was out and I came across these in my front turnsignals. It seems the lights covering was flaking.
Sorry about the pictue quality, bad digital camera.
Same thing is happening in the front turn signals of my wife's 2000 Villager.
Reply With Quote
  #3  
Old 07-04-2005
Wowak's Avatar
Member
 
Join Date: Jun 2004
Location: Merritt Island, FL
Posts: 2,223
Same thing is happening on my truck (and was before i did the headlight mod.) I was wanting a silver bulb that lights up amber, but the "chrome" bulbs light up blue, and the silverstar bulbs are blue when they're off, not silver!
Reply With Quote
  #4  
Old 07-04-2005
0RangerEdge2's Avatar
Member
Thread Starter
iTrader: (2)
 
Join Date: Jun 2005
Location: Ohio
Posts: 2,593
This is very strange, are the lights Sylvania?
Reply With Quote
  #5  
Old 07-04-2005
ScottG's Avatar
Member
 
Join Date: May 2004
Location: Lewiston, Maine
Posts: 4,926
Quote:
Originally Posted by Wowak
Same thing is happening on my truck (and was before i did the headlight mod.) I was wanting a silver bulb that lights up amber, but the "chrome" bulbs light up blue, and the silverstar bulbs are blue when they're off, not silver!

i have "chrome" that light up amber...

used them in my stock headlights, and now in my brazilians
Reply With Quote
  #6  
Old 07-04-2005
Member
 
Join Date: Nov 2004
Location: Danville, VA
Posts: 2,664
i love my silverstars....except mine look more purple than blue when they're off....
Reply With Quote
  #7  
Old 07-04-2005
Wowak's Avatar
Member
 
Join Date: Jun 2004
Location: Merritt Island, FL
Posts: 2,223
Quote:
Originally Posted by Gay-briel
i have "chrome" that light up amber...

used them in my stock headlights, and now in my brazilians
What brand are they and where did you get them?

The "chrome" ones at Autozone say amber on the packaging but def. lit up blue.. I took them back.
Reply With Quote
  #8  
Old 07-04-2005
FireRanger's Avatar  
Join Date: May 2004
Location: CT
Posts: 0
That happens sometimes. I've seen it plenty of times but I've also seen them last for years and years.
Reply With Quote
  #9  
Old 07-04-2005
Member
 
Join Date: May 2004
Location: Fuquay Varina, NC
Posts: 3,048
wowak there are a couple of sellers on ebay, also moss motors sell them, F150store.com
Reply With Quote
  #10  
Old 07-04-2005
Wowak's Avatar
Member
 
Join Date: Jun 2004
Location: Merritt Island, FL
Posts: 2,223
$25 from Moss? No thanks! Looks like I'm sticking with amber.
Reply With Quote
  #11  
Old 07-04-2005
Member
 
Join Date: May 2004
Location: Fuquay Varina, NC
Posts: 3,048
yeah moss is extremely overpriced, but even on ebay, youll spend between 15-22 shipped for a set. thats just the going price
Reply With Quote
  #12  
Old 07-05-2005
0RangerEdge2's Avatar
Member
Thread Starter
iTrader: (2)
 
Join Date: Jun 2005
Location: Ohio
Posts: 2,593
for chrome lights, I would go to Autozone. Although I didn't buy them I noticed that there were some turn signal bulbs that were chrome, but I don't know if they lit up amber or not. I think they were #3057, can't remember if that's the right bulb.
Reply With Quote
  #13  
Old 07-05-2005
Level III Supporter
iTrader: (2)
 
Join Date: Jun 2004
Location: usa
Posts: 24,936
I have those blue/amber/rainbow looking silverstars when there off and AMBER when there on. really neet but they were $15 for a set
Reply With Quote
  #14  
Old 07-05-2005
Member
 
Join Date: Aug 2004
Location: Wesley Chapel, FL
Posts: 1,072
The happens when the glass is just "colored", not true "colored glass". That's why some colored bulbs cost twice as much as others. They figure the bulb will blow long before the color melts.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Very strange loss of low end power... paganwars 4.0L OHV & SOHC V6 Tech 1 06-26-2012 06:55 PM
Fuel Gauge Cutout Problem, Very strange.... Jp7 General Technical & Electrical 11 02-01-2008 02:13 PM
Having some very strange reving issues?? Letha 2.3L & 2.5L I4 Tech 8 05-16-2007 10:08 AM
Very very angry!!!! Werty Interior Semi-Tech 34 04-08-2007 08:08 AM
HELP - tranny problems! Strange rattling and very HOT to touch aweiss2k Drivetrain Tech 13 04-21-2006 09:28 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 07:22 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.