What the &^#$!@ happened to my turn signals??? - Page 2 - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #26  
Old 06-13-2006
l2en's Avatar
Member
Thread Starter
 
Join Date: Dec 2005
Location: The Keystone State
Posts: 4,521
My old fords use to nickel and dime me. I thought if I got a new one it'd at least wait to do that til it was paid off. I still have 18 more payments on this ****. 28k dollar truck and this is what I get. A royal pos.
Reply With Quote
  #27  
Old 06-13-2006
Kanoeking's Avatar
Member
 
Join Date: Nov 2005
Location: Murderapolis
Posts: 748
Yeah Ive had my fair share of disapointments too, but such is life.
Reply With Quote
  #28  
Old 06-16-2006
l2en's Avatar
Member
Thread Starter
 
Join Date: Dec 2005
Location: The Keystone State
Posts: 4,521
Ugh, so I just got my truck back after two days and a $100 deductable. My turn signal "multi function switch" was broken. I get my truck back and now my a/c doesn't kick on ahhhhhhhhh! Stupid, stupid truck.
Reply With Quote
  #29  
Old 06-16-2006
Kanoeking's Avatar
Member
 
Join Date: Nov 2005
Location: Murderapolis
Posts: 748
I had to rebuild my multi switch....well clean it cause i go the "phantom wiper"....I should have suggested taking it apart and checking it out... as for your a/c....check the purple wire for volts....and check fuses!
Reply With Quote
  #30  
Old 06-16-2006
l2en's Avatar
Member
Thread Starter
 
Join Date: Dec 2005
Location: The Keystone State
Posts: 4,521
I have an a/c disable switch. When I turn it "on" the switch lights up, so I'm guessing it has power and is sending the signal to engage the ac clutch. Ugh, haven't checked fuses though. I'm about to put my new differential cover on the rear and swap fluids. So I guess I can check the fuses while I'm at it. My damn fuse panel cover is about shot from opening it up all the damn time. UGH!
Reply With Quote
  #31  
Old 06-16-2006
Kanoeking's Avatar
Member
 
Join Date: Nov 2005
Location: Murderapolis
Posts: 748
LOL...check your switch. those switches will light up solely on the fact that *they* have a completed circut of power and ground yet they dont have to be sending it any where if its a switch that you spliced in to the purple wire and then added a power and a ground to for the switch to light up that is...and if its an inline switch...well then i guess check your pump and see if it is getting volts or not...
Reply With Quote
  #32  
Old 06-16-2006
l2en's Avatar
Member
Thread Starter
 
Join Date: Dec 2005
Location: The Keystone State
Posts: 4,521
Yeah I just got my new diff cover on and didn't feel like f*in with it. I was thinking the same thing earlier that maybe the lead out of the switch was being interupted somewhere.
Reply With Quote
  #33  
Old 06-22-2006
03RangerInROC's Avatar
Member
 
Join Date: Feb 2006
Location: rochester, ny
Posts: 530
look in the stearin colum.. there is the harness tht holds all the wires turn signals inclueded.. there is 2 plaqstic clips tht hold the harness in... push it back in.
i have the issure where the clamps are broke and the harness slides out and in the end the the turn signals dont work beucase there is no connection...

hope tht wrks...
shawna
Reply With Quote
  #34  
Old 09-29-2006
Member
 
Join Date: Sep 2006
Location: Haverhill MA
Posts: 9
The same thing is happing to mine right now. I replaced the flasher and they still dont work. All the lights work they just dont flash. Anybody Know what else it could be?
Reply With Quote
  #35  
Old 09-29-2006
Joe DeCline's Avatar
Member
 
Join Date: Feb 2006
Location: Whittier, CA
Posts: 92
It sounds like its the turn signal switch, all you would have to do is take off the steering wheel and get down to the part your turn signals are connected to, get the new one from any parts store and put it in. I did it in an hour on a 96 monte carlo that had the same problem. Just buy the Haines or Chiltons manual, they help..

To test it have someone stand behind the truck and turn on the turn signal and slowly move the switch around, if the lights flash at all I would bet the switch is the problem.
Reply With Quote
  #36  
Old 09-29-2006
l2en's Avatar
Member
Thread Starter
 
Join Date: Dec 2005
Location: The Keystone State
Posts: 4,521
^^^Yup, mine was the multi-function switch. Luckily I was under warranty at the time.
Reply With Quote
  #37  
Old 09-29-2006
Joe DeCline's Avatar
Member
 
Join Date: Feb 2006
Location: Whittier, CA
Posts: 92
^^ For free is always good, but its not too hard of a repair, all you need is good instructions.. Just be careful around airbag systems.. if you do it yourself.
Reply With Quote
  #38  
Old 09-29-2006
Member
 
Join Date: Sep 2006
Location: Haverhill MA
Posts: 9
ok thank alot. I will go give it a try.
Reply With Quote
  #39  
Old 09-29-2006
Member
 
Join Date: Sep 2006
Location: Haverhill MA
Posts: 9
I forgot to mention that the blinkers worked fine and then i did that alternate blinker mod and thats when they stopped working so I dont know if I did something wrong there but then i put everything back to normal and they still didnt work. So before I go and replace the multifunction switch I just wanna make sure that its not an other problem caused by the blinker mod. So what do you think?
Reply With Quote
  #40  
Old 09-29-2006
l2en's Avatar
Member
Thread Starter
 
Join Date: Dec 2005
Location: The Keystone State
Posts: 4,521
Check your fuse panel!
Reply With Quote
  #41  
Old 09-29-2006
Rolldogg's Avatar
Member
 
Join Date: Jan 2006
Location: Ottawa, Ontario
Posts: 3,424
While we're on the topic of signal relays.......

Anyone ever find out the part # for the heavy duty upgraded relay???
My trailer has the regular tail lights and side marker lights...but my signals always go crazy when I plug my trailer harness in. No ground faults on the trailer side, and the Ranger side is clean and tested...just a real pain when the signals blink a mile a minute when the trailers on.

I checked at UAP/NAPA and Canadian Tire, but they onlt carry the generic hazzard/signal relays.......the Ranger relays have differnt fins on them and not as many.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
turn signals & flasher clifpayne General Technical & Electrical 0 09-26-2010 02:40 PM
Checking Interest: OEM Headlights & Turn Signals '96 Era, KY buggman Interior, Exterior, Electrical, & Misc. 0 06-29-2010 11:51 PM
turn signals are really really fast quicksilver2001 General Technical & Electrical 18 01-29-2006 02:23 PM
Slowing down LED bulbs in the turn signals Mnemonic General Technical & Electrical 5 06-12-2004 08:12 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 07:31 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.