Ranger-Forums - The Ultimate Ford Ranger Resource

Ranger-Forums - The Ultimate Ford Ranger Resource (https://www.ranger-forums.com/)
-   Interior Semi-Tech (https://www.ranger-forums.com/interior-semi-tech-40/)
-   -   Door Locks Won't Work (https://www.ranger-forums.com/interior-semi-tech-40/door-locks-wont-work-52880/)

pastfinder 11-06-2007 01:22 PM

Door Locks Won't Work
 
I've used my remote so often that when I tried using the key today to unlock the door the tumbler will not turn or budge. I'm going to squirt some WD-40 inside the lock to see if that accomplishes anything, but the locks are both frozen up.

I have the LED lock mod, so the lock rods have been gone...although the locks worked fine before. Anyone else encounter this difficulty?

jtslmn720 11-06-2007 02:35 PM

it happened to my passenger side and wd40 took care of it... hopefully that will work for you

04blackedge 11-06-2007 03:14 PM

God i'd be screwed if it happened to me.

03XLT 11-09-2007 07:36 PM

Mine has gotten sticky before too. Liquid Wrench cures it right away.

pastfinder 11-09-2007 07:37 PM

Squirted WD-40 in them and they are as smooth as silk. Weird...buy hey, they work now!

malydeen 11-09-2007 09:17 PM

whats the LED lock mod?

pastfinder 11-09-2007 09:52 PM

https://www.ranger-forums.com/forum2...ad.php?t=24880

BILLZFX4 11-10-2007 06:04 AM

This is actually a good reminder. I should probably spray my door locks, seeing as I've never actually used the key in them.

Rockledge 11-10-2007 08:20 AM

I would suggest using a "dry lube" type of spray in the lock cylinders to help prevent dirt and dust buildup inside.

A few years ago I had the same problem with my driver's side door lock cylinder and a few shots of PB Blaster's penetrating teflon dry lube cured it for good.

Victory 11-13-2007 07:15 AM

Both of my locks do it. I do not have a remote. The dealer checked it out and can't find anything. It's worse in cold weather then warm. WD-40 and the Ford lock spray work for a while but then stop. Fusions and 500 had a problem that came from a weather seal. They checked that and nothing. The dealer is waiting for a reply from Ford.
While they were checking that I told them to listen to the clutch. Much to their surprise I need a new slave cylinder, again. They replaced it early this year. Now what is important here is the truck has only 7800 miles on it. This will be the second slave cylinder and the clutch and driveshaft have been replaced???? It will be interesting to find out what's going on.
I will post any findings.

I will


All times are GMT -6. The time now is 08:55 AM.