Instrument Cluster Swap Question - Page 2 - Ranger-Forums - The Ultimate Ford Ranger Resource


Interior Semi-Tech General discussion of interior for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #26  
Old 08-02-2008
robert99ranger's Avatar
RF Veteran
Thread Starter
iTrader: (4)
 
Join Date: Aug 2007
Location: Indiana/Mississippi
Posts: 5,807
Ya, that is the only thing. How hard is that gonna be? Could I do the battery thing like they did for the speedo?
Reply With Quote
  #27  
Old 08-02-2008
Silver's Avatar
Member
 
Join Date: Jun 2006
Location: edenton,nc
Posts: 2,708
you can turn it by hand or use a drill,its what i did

Name:  gauges015.jpg
Views: 275
Size:  34.3 KB

Name:  gauges011.jpg
Views: 275
Size:  49.2 KB

but you must remove the motor and worm gear asimibly(spelling?) 1st but be careful not to break the plastic holding it in

mark the needle and use spoons to remove it

Name:  gauges008.jpg
Views: 277
Size:  50.9 KB

Name:  gauges012.jpg
Views: 274
Size:  33.9 KB

not hard just take your time
Reply With Quote
  #28  
Old 08-02-2008
robert99ranger's Avatar
RF Veteran
Thread Starter
iTrader: (4)
 
Join Date: Aug 2007
Location: Indiana/Mississippi
Posts: 5,807
I will put the explorer gauge set in with the tach and mark it at idle. What I am gonna do is get the truck warm and mark all of the gauges. Fuel, temp, batt, &oil. I will do the battery thing with the speedo to mark it. Then, I will move all of the motors over to the sport frame. Also move the numbers from my truck over to the explorer motor. I think it will be fine. I got the explorer one today for $20. I will go tomorrow to the junkyard since they are open everyday and get the sport cluster. Hopefully he won't charge my $20 for it since it was under water. We will see what happens.

For fun, I put the AAA battery on the explorer speedo and it goes right to 70 so really easy.
Reply With Quote
  #29  
Old 08-02-2008
robert99ranger's Avatar
RF Veteran
Thread Starter
iTrader: (4)
 
Join Date: Aug 2007
Location: Indiana/Mississippi
Posts: 5,807
Ya, I am gonna move the assembly from my ranger to the explorer one.
Reply With Quote
  #30  
Old 08-02-2008
Silver's Avatar
Member
 
Join Date: Jun 2006
Location: edenton,nc
Posts: 2,708
the only needle you need to play with is the speedo thats only because of mileage

the expo gauges are a direct swap to the ranger and have the same part # on them too

you also dont need power to mark the gauge
Reply With Quote
  #31  
Old 08-02-2008
Silver's Avatar
Member
 
Join Date: Jun 2006
Location: edenton,nc
Posts: 2,708
Quote:
Originally Posted by cghstrojan08 View Post
Ya, I am gonna move the assembly from my ranger to the explorer one.
ok i see why your going to mark them now

but test them out 1st just for kicks lol
Reply With Quote
  #32  
Old 08-03-2008
robert99ranger's Avatar
RF Veteran
Thread Starter
iTrader: (4)
 
Join Date: Aug 2007
Location: Indiana/Mississippi
Posts: 5,807
I got the white one today.
Reply With Quote
  #33  
Old 08-03-2008
robert99ranger's Avatar
RF Veteran
Thread Starter
iTrader: (4)
 
Join Date: Aug 2007
Location: Indiana/Mississippi
Posts: 5,807
I finished up the swap this evening and got it all put together. Not to bad. I thank you guys so much for all the help and especially Fx4wannabe01. Here it is

Name:  IMG_3108.jpg
Views: 274
Size:  42.6 KB
Name:  IMG_3111.jpg
Views: 276
Size:  17.1 KB
Name:  IMG_3112.jpg
Views: 273
Size:  15.1 KB
Reply With Quote
  #34  
Old 08-04-2008
Fx4wannabe01's Avatar
RF Veteran
iTrader: (23)
 
Join Date: May 2005
Location: Boring, Oregon
Posts: 21,721
VERY GOOD! i forgot to do the battery to the speedo when i did mine....so i drove down the road, cruise control set to 55mph via gps, and set the neetle. yea i know, dangerous. but it got the job done! Looks great man. Everything work properly?
Reply With Quote
  #35  
Old 08-04-2008
PlasticHero's Avatar
Member
iTrader: (3)
 
Join Date: Jun 2005
Location: Ottawa, IL
Posts: 701
did you hook up the tach? If so how hard was it?
Reply With Quote
  #36  
Old 08-04-2008
Silver's Avatar
Member
 
Join Date: Jun 2006
Location: edenton,nc
Posts: 2,708
came out nice


Quote:
Originally Posted by PlasticHero View Post
did you hook up the tach? If so how hard was it?

its a plug and play deal the hardest part is getting the old one out and swaped to the new and thats not that hard
Reply With Quote
  #37  
Old 08-04-2008
PlasticHero's Avatar
Member
iTrader: (3)
 
Join Date: Jun 2005
Location: Ottawa, IL
Posts: 701
Well you just convinced me to do it I might tackle the L.E.D. mod though while swappn em. As for the tach do I just gotta get a cable or anything since my ranger does not have the tach in the cluster?
Reply With Quote
  #38  
Old 08-04-2008
Silver's Avatar
Member
 
Join Date: Jun 2006
Location: edenton,nc
Posts: 2,708
Quote:
Originally Posted by PlasticHero View Post
As for the tach do I just gotta get a cable or anything since my ranger does not have the tach in the cluster?
nope plug and play

your truck us already set up for the tach from the factory
Reply With Quote
  #39  
Old 08-04-2008
PlasticHero's Avatar
Member
iTrader: (3)
 
Join Date: Jun 2005
Location: Ottawa, IL
Posts: 701
DANGIT I forgot to ask/check... will a 02 Explorer cluster work with the 98+ Isnt there a year they changed em or sumthing?
Reply With Quote
  #40  
Old 08-04-2008
Silver's Avatar
Member
 
Join Date: Jun 2006
Location: edenton,nc
Posts: 2,708
I dont think so

did you already buy it and if so shot up the link and we can tell ya
Reply With Quote
  #41  
Old 08-04-2008
Fx4wannabe01's Avatar
RF Veteran
iTrader: (23)
 
Join Date: May 2005
Location: Boring, Oregon
Posts: 21,721
NOPE! 02 Explorer won't work. BUT...02 Explorer Sport and Explorer Sport Trac will work.
Reply With Quote
  #42  
Old 08-04-2008
PlasticHero's Avatar
Member
iTrader: (3)
 
Join Date: Jun 2005
Location: Ottawa, IL
Posts: 701
No I didnt buy it yet... almost though. I like the white faces thats why I asked and that one caught my eye,

Was looking at that one,
linky

Might end up with this one,linky


I looked at this one cause its silver/gray (i think) but doubt it would work...
linky

Last edited by PlasticHero; 08-04-2008 at 05:06 PM. Reason: changed link so no competition :)
Reply With Quote
  #43  
Old 08-04-2008
Fx4wannabe01's Avatar
RF Veteran
iTrader: (23)
 
Join Date: May 2005
Location: Boring, Oregon
Posts: 21,721
^^ALL three will work! The first one is an Expo cluster. Second looks like a ranger one or older explo. Last one is a 03 only silver one. it'll work on all 03 and older trucks though.

Just remember to get the right drivetrain one....meaning like 4x4 if your a 4x4....
Reply With Quote
  #44  
Old 08-04-2008
PlasticHero's Avatar
Member
iTrader: (3)
 
Join Date: Jun 2005
Location: Ottawa, IL
Posts: 701
Guess Im stuck with the 3rd one then its the only 2wd one on there
Reply With Quote
  #45  
Old 08-04-2008
Fx4wannabe01's Avatar
RF Veteran
iTrader: (23)
 
Join Date: May 2005
Location: Boring, Oregon
Posts: 21,721
the silver cluster and the white cluster are both 2wd. The black one is hard to tell.
Reply With Quote
  #46  
Old 08-04-2008
robert99ranger's Avatar
RF Veteran
Thread Starter
iTrader: (4)
 
Join Date: Aug 2007
Location: Indiana/Mississippi
Posts: 5,807
Nope, I had no problems at all. I ended up buying the two clusters and making one good one. I pretty much just moved the white face and needles to the black explorer one.

I love it! The white one looks so much better. It looks awesome in the dash compared to the black one. I was surprised that I found the white one at the junkyard.
Reply With Quote
  #47  
Old 08-04-2008
robert99ranger's Avatar
RF Veteran
Thread Starter
iTrader: (4)
 
Join Date: Aug 2007
Location: Indiana/Mississippi
Posts: 5,807
Oh ya, I got the white one for $14.00
Reply With Quote
  #48  
Old 08-04-2008
robert99ranger's Avatar
RF Veteran
Thread Starter
iTrader: (4)
 
Join Date: Aug 2007
Location: Indiana/Mississippi
Posts: 5,807
My cluster is 4 wheel drive and it works fine on my truck (mine is 2wd). You just see where it says "4wd high" and "4wd Low".
Reply With Quote
  #49  
Old 08-04-2008
PlasticHero's Avatar
Member
iTrader: (3)
 
Join Date: Jun 2005
Location: Ottawa, IL
Posts: 701
rub it in, rub it in....

haha yea I'd go treasure hunting but I work 8-5 mon-fri, and guess what that happens to be the same exact same hours as the junkyards....imagine that.
Reply With Quote
  #50  
Old 08-04-2008
Fx4wannabe01's Avatar
RF Veteran
iTrader: (23)
 
Join Date: May 2005
Location: Boring, Oregon
Posts: 21,721
i hate working dayshift for that one reason....6a-6p. you can't go anywhere because everywhere is closed. lol.


imo....if you don't have cruise, i think it's a no biggie in my book seeing the "cruise" idiot light. just like the 4x4 showing....it's all up to you.

$14! daum man.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2000 Ranger Instrument Cluster Swap Mmaust005 General Technical & Electrical 6 05-09-2013 06:52 PM
1997 Ranger Instrument dash Cluster Swap Question pdigiacinto Interior Semi-Tech 16 05-06-2009 12:10 AM
Instrument Cluster Swap ChaosFromAbove General Ford Ranger Discussion 8 02-22-2009 12:35 PM
instrument cluster question 99ranger4X4OFFROAD Interior Semi-Tech 5 02-17-2008 12:19 AM
Instrument cluster swap problems ShadowRanger General Technical & Electrical 15 07-13-2006 11:13 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 05:04 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.