ohc problems - Ranger-Forums - The Ultimate Ford Ranger Resource


Interior Semi-Tech General discussion of interior for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 01-05-2012
dbking321's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Mar 2007
Location: Shippensburg/York PA
Posts: 636
ohc problems

so I decided to instal my ohc and for the most part it went smooth... well i thought so.
The console has power and the screen lights up and dims when i turn the headlights on. however it says the temp is 140 and on my run to the bank id didnt change at all and it only said i was going south or southwest there and back.....
Also none of the lights work not when I open the door or push the buttons.(bulbs are fine )any idea on what I did or I can check
My trucks an 04 and the way I have the lights to the dome light might be the problem but it worked for my cargo lights so I included a picture.
SAM_0198.jpg?t=1325794837
Reply With Quote
  #2  
Old 01-05-2012
mthomp1's Avatar
Member
 
Join Date: Nov 2011
Location: North Louisiana
Posts: 330
Check and re-check your wiring. I drove around for a day or two without my temp. sensor hooked up, and the temperature reading was -40 (ICE). If you ran the wrong wire(s) to the temp. sensor, I would think that it would do the same thing. As far as the lights, I *think* that for the newer model trucks that don't have the extra dome light wire (the orange and green one), you have to run an extra one. And lastly for the compass, did you calibrate it?
Reply With Quote
  #3  
Old 01-05-2012
dbking321's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Mar 2007
Location: Shippensburg/York PA
Posts: 636
I gonna try and calibrate it later i just read about that. i think i may have pinched a wire cause it read 41 for a little then i put the console up and it read 140 so mabey i pinched a wire
Reply With Quote
  #4  
Old 01-06-2012
Member
 
Join Date: Jun 2004
Location: Orange City, FL
Posts: 1,601
the wires for the temp sensor can be reversed and it shouldn't matter.

Def sounds like something is grounding out. Can you uninstall the wiring and see if that fixes it?
Reply With Quote
  #5  
Old 01-06-2012
dbking321's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Mar 2007
Location: Shippensburg/York PA
Posts: 636
for the temp sensor? and any idea about the light
Reply With Quote
  #6  
Old 01-09-2012
dbking321's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Mar 2007
Location: Shippensburg/York PA
Posts: 636
yup new console fixed my problems
Reply With Quote
  #7  
Old 01-10-2012
mthomp1's Avatar
Member
 
Join Date: Nov 2011
Location: North Louisiana
Posts: 330
Quote:
Originally Posted by dbking321 View Post
yup new console fixed my problems
Funny that happened to you as well, because the first overhead console I put in my truck was bad. When I turned on the ignition, every digit in the display would flash on, then it would turn back off. In order to get it to come on again, I had to disconnect the battery and turn the key again. It never actually showed the temperature or compass readings. A couple of days later, I bought another one, and since the housing on the bad console looked better, I swapped the computer from the new console into the housing of the old one. It works wonderfully now. The temperature reading is dead accurate, and I didn't even have to calibrate the compass. I have two extras now haha. Every time I see them in the junkyard, I buy them.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
For Sale: Tan OHC , Gray OHC and Auto Dimming mirror - GA MugenCRX04 Interior, Exterior, Electrical, & Misc. 12 09-29-2009 04:18 PM
OHC wiring problems 98WARanger Interior Semi-Tech 12 10-28-2008 03:30 AM
Dome lights problems... OHC Shaklakan General Technical & Electrical 9 07-28-2008 11:42 PM
OHC problems Brando5105 General Technical & Electrical 2 10-27-2007 06:28 PM
OHC problems...... lifted97ranger General Ford Ranger Discussion 10 02-11-2007 03:02 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 05:25 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.