Overhead Console Problems - Ranger-Forums - The Ultimate Ford Ranger Resource


Interior Semi-Tech General discussion of interior for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 12-11-2011
mthomp1's Avatar
Member
Thread Starter
 
Join Date: Nov 2011
Location: North Louisiana
Posts: 330
Overhead Console Problems

I installed my overhead console yesterday, and I wired it today. The map lights work, however, the display will only come on once after the battery has been disconnected and reconnected. It stays on for about ten seconds (everything lights up), then goes back off. The only way to get it to come back on is to disconnect and reconnect the battery again. I don't have the temperature sensor installed yet (those wires are currently sitting on my dashboard). Would that be the problem? Does it need to be reset or something? I tried holding the mode button for about 15-20 seconds. Thanks for any help :)
Reply With Quote
  #2  
Old 12-11-2011
04RangerDave's Avatar
JDM> RANGER

iTrader: (3)
 
Join Date: Jul 2010
Location: RI
Posts: 5,030
Wirelessly posted (iPhone 3GS)

Dbl post isn't nessicary. It may take some time for your question to be answered.
Reply With Quote
  #3  
Old 12-11-2011
mthomp1's Avatar
Member
Thread Starter
 
Join Date: Nov 2011
Location: North Louisiana
Posts: 330
Quote:
Originally Posted by 04RangerDave View Post
Wirelessly posted (iPhone 3GS)

Dbl post isn't nessicary. It may take some time for your question to be answered.
You didn't notice where that other topic is, did you? I mistakingly posted it in the sales forum, so I deleted the body of that one (go back and read it) and posted it here, which is the correct forum.
Reply With Quote
  #4  
Old 12-12-2011
mthomp1's Avatar
Member
Thread Starter
 
Join Date: Nov 2011
Location: North Louisiana
Posts: 330
In case anyone is wondering, I figured out my problem. My overhead console was D.O.A. I checked and re-checked all of my wires and used my test light last night, so I knew my wiring was correct. I got off from work this morning and went to another yard and bought another console. Since the console I already had looked better on the outside than the new one, I switched the insides of the new console into the body of the old console. I still have to hook up my temp. sensor, but the console and lights do work, and even the dimming feature works. It's kinda weird to see an XL trim level Ranger with an overhead console haha
Reply With Quote
  #5  
Old 12-12-2011
01RangerEdge's Avatar
Scrambles the DeathDealer
iTrader: (11)
 
Join Date: Jul 2009
Location: Jackson, MO
Posts: 7,598
I didn't even bother with dimmer controls since I have LED's in my dash

Where are you going to mount the temp sensor?
Reply With Quote
  #6  
Old 12-12-2011
mthomp1's Avatar
Member
Thread Starter
 
Join Date: Nov 2011
Location: North Louisiana
Posts: 330
Quote:
Originally Posted by 01RangerEdge View Post
I didn't even bother with dimmer controls since I have LED's in my dash

Where are you going to mount the temp sensor?
Somewhere on the radiator core support. I already have a hole in the cab for the LED's in my grille, so I'll run the temp. sensor wires through there. I was looking at other peoples' last night, and some guy mounted his on the frame behind the torsion bar.
Reply With Quote
  #7  
Old 12-12-2011
01RangerEdge's Avatar
Scrambles the DeathDealer
iTrader: (11)
 
Join Date: Jul 2009
Location: Jackson, MO
Posts: 7,598
Don't mount it anywhere behind the engine, the heat will throw the temp off.

I put mine under the radiator support above my front hitch
Reply With Quote
  #8  
Old 12-12-2011
mthomp1's Avatar
Member
Thread Starter
 
Join Date: Nov 2011
Location: North Louisiana
Posts: 330
Gotcha. Thanks for the tip! :)
Reply With Quote
  #9  
Old 12-12-2011
Blhde's Avatar
Member
 
Join Date: Oct 2005
Location: Northern IL
Posts: 2,804
Did you try and press the mode button?
Reply With Quote
  #10  
Old 12-12-2011
01RangerEdge's Avatar
Scrambles the DeathDealer
iTrader: (11)
 
Join Date: Jul 2009
Location: Jackson, MO
Posts: 7,598
Quote:
Originally Posted by Blhde View Post
Did you try and press the mode button?
Quote:
Originally Posted by mthomp1 View Post
I tried holding the mode button for about 15-20 seconds
I imagine he also tried just pressing it
Reply With Quote
  #11  
Old 12-12-2011
mthomp1's Avatar
Member
Thread Starter
 
Join Date: Nov 2011
Location: North Louisiana
Posts: 330
Quote:
Originally Posted by Blhde View Post
Did you try and press the mode button?
Quote:
Originally Posted by 01RangerEdge View Post
I imagine he also tried just pressing it
Yep. I tried both. The computer in that console was just dead.

On another note, I told myself that I wouldn't bother with hooking the temp. sensor up today, but you know how that goes. I got the temp. sensor installed (behind the grille and next to the driver's side head light), and it works great! I had my phone to check the temperature as I went. The compass also didn't need to be calibrated, which made me happy because I didn't feel like driving around in circles in my back yard haha. I was kinda worried about heat coming from the headlight, but I figure that wind coming through the grille will even things out. If it does prove to be a problem, I'll re-locate it.
Reply With Quote
  #12  
Old 12-12-2011
01RangerEdge's Avatar
Scrambles the DeathDealer
iTrader: (11)
 
Join Date: Jul 2009
Location: Jackson, MO
Posts: 7,598
The headlight won't bother it.
Reply With Quote
  #13  
Old 12-12-2011
mthomp1's Avatar
Member
Thread Starter
 
Join Date: Nov 2011
Location: North Louisiana
Posts: 330
That's good to know. Thanks for all your help, man! I'll have pictures of it hopefully tomorrow. :)
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
For Sale: Full length console, overhead console, hitch for sale in ontario ranger4.0 Interior, Exterior, Electrical, & Misc. 10 02-16-2011 12:25 AM
Overhead Overhead console and hood adjusters (AR) TheBearJeweler Interior, Exterior, Electrical, & Misc. 19 06-12-2009 08:26 PM
Overhead Console DustinS Interior Semi-Tech 2 04-27-2005 03:06 PM
Overhead Console Quinnin Interior Semi-Tech 16 03-15-2005 05:38 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 10:45 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.