Project Bronco2 !! - Page 6 - Ranger-Forums - The Ultimate Ford Ranger Resource


Project Logs For detailed builds specific to the Ford Ranger, one thread per vehicle please.

Reply
 
LinkBack Thread Tools Search this Thread
  #126  
Old 01-12-2011
INT3RC3PTOR's Avatar
Veteran Status Achieved
iTrader: (4)
 
Join Date: Jul 2005
Location: Minnesooooota
Posts: 8,203
ooo nice progress brian! gonna be a mean b2
Reply With Quote
  #127  
Old 01-15-2011
deathbypsi's Avatar
Member
Thread Starter
 
Join Date: Feb 2007
Location: Temperance Mi
Posts: 676
I just got back from seeing my buddy over at Mytee and he made me some header flanges to weld up to my original y-pipe. Looking good so far! Should be warming it up late today and doing a once over of all the fluids.

Vid to come later.
Reply With Quote
  #128  
Old 01-15-2011
INT3RC3PTOR's Avatar
Veteran Status Achieved
iTrader: (4)
 
Join Date: Jul 2005
Location: Minnesooooota
Posts: 8,203
nice! good luck Brian!
Reply With Quote
  #129  
Old 01-16-2011
deathbypsi's Avatar
Member
Thread Starter
 
Join Date: Feb 2007
Location: Temperance Mi
Posts: 676
99% done now.

Fired up today and let it warm up. All fluids are good,charging system works,tach works,gauges work,65psi oil pressure idling,electric fan works and even the powersteering pump is quiet{thats a shocker for a Ford}.
Motor starts right up but has a slight miss to it which Im thinking is from a dead plug from all the dam fuel I was pumping thru it while firguring out the computer issues. Roller rockers might need a once over if fresh oil doesnt quiet them down a hair more. Or it could be from not having the O sensors plugged in and Im using a 5.0 t-bird ecm right now which is calibrated for 14lb injectors instead of the 19lb injectors Im using with the Mustang ecm.Basicly is pig rich.

I cut up the factory 2.9 y-pipe and Brad over at Mytee made me some pipes to weld to it.Not pretty but worked perfect,nice and quiet.

STill need to clean up and loom a few wires over on drivers side,I was excited to just hear it run for a while.
Name:  2011_0116011420110010.jpg
Views: 1
Size:  206.0 KB
Name:  2011_0116011420110012.jpg
Views: 1
Size:  197.4 KB
B2 build :: 2011_0116011420110011.mp4 video by deathbypsi - Photobucket
Reply With Quote
  #130  
Old 01-16-2011
INT3RC3PTOR's Avatar
Veteran Status Achieved
iTrader: (4)
 
Join Date: Jul 2005
Location: Minnesooooota
Posts: 8,203
major progress!
Reply With Quote
  #131  
Old 01-17-2011
deathbypsi's Avatar
Member
Thread Starter
 
Join Date: Feb 2007
Location: Temperance Mi
Posts: 676
Got the rear shaft done lastnite and found my miss. I had two plug wires backwards.Purs like a kitten now. Its nice and quiet and man does it rev NOW!

Just finishing up stuff like vent hoses for trans/t-case,making adjustments to shifter,cleaning up interior,oil change and then its time to take it out for its first road miles!
Reply With Quote
  #132  
Old 01-17-2011
winks's Avatar
Member
iTrader: (5)
 
Join Date: May 2005
Location: Jackson, New Jersey
Posts: 4,872
Awesome, enjoy that first trip.
Reply With Quote
  #133  
Old 01-17-2011
dixie_boysles's Avatar
Member
iTrader: (1)
 
Join Date: Jul 2006
Location: NC
Posts: 3,778
hell to the yes
Reply With Quote
  #134  
Old 01-17-2011
INT3RC3PTOR's Avatar
Veteran Status Achieved
iTrader: (4)
 
Join Date: Jul 2005
Location: Minnesooooota
Posts: 8,203
Haha at least it was an easy fix!
Reply With Quote
  #135  
Old 01-17-2011
morris's Avatar
RF Veteran
iTrader: (5)
 
Join Date: Feb 2008
Location: South Detroit.
Posts: 7,833
nice, good job brian.
Reply With Quote
  #136  
Old 01-17-2011
seed60's Avatar
RF Veteran
iTrader: (15)
 
Join Date: Jun 2008
Location: Mooresville, NC
Posts: 5,584
Hell yeah!!
Reply With Quote
  #137  
Old 01-17-2011
deathbypsi's Avatar
Member
Thread Starter
 
Join Date: Feb 2007
Location: Temperance Mi
Posts: 676
Holy four wheel roostertails!!!! Its a beast!!!

Took it out in the backyard and the power is sick in 4wd. My backyard has about 4-5 inches of untouched snow and this thing was drifting sideways just layin into it. Then took it around the block for some stop and go driving and put about 5 miles on it. Still rides just like it use to which I love. No crazy vibrations or anything weird.I still have the 3.73 gears and even with the 35's it will roll the F out! Got me rethinking the 4.56's.

So far I had to fix one leaky oil line and engine temp is bouncing between 190 and 240.Im thinking I need to move my rad cap to a higher spot to get all the air out. It goes into 4HI no problem but the dash button flashes when I try 4LOW and wont engage.Most likely its looking for the VSS signal since Im not using it{ Speed density and the C4 dont require it} I will have to go into the 4wd module and trick it somehow. Sounds like passenger side header collector didnt seal up all the way cuz I have a small leak when you lay into it. Also the C4 shifts a little late and hard for my taste so I need to adjust the modulator to calm that down a touch. Cruising around 45-50 mph is just under 2000 rpm in 3rd gear...perfect.
Name:  2011_0117011620110001.jpg
Views: 1
Size:  176.6 KB
Name:  2011_0117011620110004.jpg
Views: 1
Size:  161.9 KB
I guess this wraps up this project for now...time to put some miles on it and enjoy!
Reply With Quote
  #138  
Old 01-17-2011
BILTRITE BULLIES's Avatar
Member
iTrader: (4)
 
Join Date: Jun 2009
Location: NM
Posts: 557
bad ***, congrats
Reply With Quote
  #139  
Old 01-17-2011
INT3RC3PTOR's Avatar
Veteran Status Achieved
iTrader: (4)
 
Join Date: Jul 2005
Location: Minnesooooota
Posts: 8,203
haha yeah I bet it feels miles different than the stocker with yer setup. I know it was with replacing my 3.0
Reply With Quote
  #140  
Old 01-17-2011
Downey's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Oct 2007
Location: Muncy, PA
Posts: 8,470
sweet man i want to build a bII like this
Reply With Quote
  #141  
Old 01-18-2011
deathbypsi's Avatar
Member
Thread Starter
 
Join Date: Feb 2007
Location: Temperance Mi
Posts: 676
Now Im faced with the big question.

How long do I enjoy it as it sits {TTB d35 and welded 7.5 with 3.73's} and when do I start my SAS/coilovers/4.56's/lockers/D44/8.8 swap.....
Reply With Quote
  #142  
Old 01-18-2011
winks's Avatar
Member
iTrader: (5)
 
Join Date: May 2005
Location: Jackson, New Jersey
Posts: 4,872
Drive it till it breaks.
Reply With Quote
  #143  
Old 01-18-2011
Member
 
Join Date: Jun 2005
Posts: 148
You can solve your t-case problem by swapping in a manual. I'm sure it wouldn't be too hard to find.
Reply With Quote
  #144  
Old 01-18-2011
zabeard's Avatar
who?
iTrader: (8)
 
Join Date: Nov 2004
Location: IN
Posts: 26,045
Looks great Brian! I guess you beat me out of the garage. lol
Reply With Quote
  #145  
Old 01-18-2011
seed60's Avatar
RF Veteran
iTrader: (15)
 
Join Date: Jun 2008
Location: Mooresville, NC
Posts: 5,584
Quote:
Originally Posted by winks View Post
Drive it till it breaks.
Hell yeah!

Looking forward to some good vids!
Reply With Quote
  #146  
Old 01-18-2011
deathbypsi's Avatar
Member
Thread Starter
 
Join Date: Feb 2007
Location: Temperance Mi
Posts: 676
I worked on some of the bugs today and put some more mills on it. Moved my radiator hose fill cap to right on top of the alt. and I got all the air out,now it wont go over 170. Adjusted the vac modulator on trans and got it to shift much easier. Thinking about converting it to a factory floor shifter since things aint working quite right with the column shifter. The spacing for the detents in the shifter compaired to the ones in the valvebody just dont match up right so I wouldnt feel safe turning anyones else loose behind the wheel.

ZainyD,yeah swapping to a manual would be easy but one of my goals was to keep the electric shift t-case. I have two others layin around for backups so it just made sence to keep what I had.
Reply With Quote
  #147  
Old 01-22-2011
deathbypsi's Avatar
Member
Thread Starter
 
Join Date: Feb 2007
Location: Temperance Mi
Posts: 676
Well I have been driving it everyday so far. Even drove it to work on Friday which is 40 miles one way from Temperance to Saline. About 150 miles of trouble free driving so far......except for one problem. I drove it to work and back on friday which was 80 miles and when I got home I parked it in driveway,as I walked to my back door I heard "pop and gush" sound. As I turned back I seen antifreeze pouring out under truck. Well it turns out I never put a dam hose clamp on one of the heater hoses! Talk about getting lucky!

I am also tired of the welded rear axle and junk rear drum brakes so starting tomorrow Im rebuilding my disc brake 8.8 and throwing in my Lock-Rite. Im also removing the front fender liners and cutting up the wheel openings more for more tire clearance .
Reply With Quote
  #148  
Old 11-03-2011
deathbypsi's Avatar
Member
Thread Starter
 
Join Date: Feb 2007
Location: Temperance Mi
Posts: 676
Truck has been a blast all summer.I had stopped using it daily due to some recent body mods from a couple trips to BundyHill and Rocks&Valleys.




Oh yeah...the 8.8 swap turned out great also...





ON the hunt for a clean Ranger cab now so I can do a body swap and turn this into a mini truggy.....but in the mean time......

Back in service for daily duty if I want now!



Took the truck out to Sew Your Boat in Toledo a few days ago and they turned these out for me. Really nice people to deal with there and couldnt be happier with what I got for the price! Now I can feel my heat again!
Attached Thumbnails
Project Bronco2 !!-ohsnap.jpg   Project Bronco2 !!-6195453799_55ccd123dd_b.jpg   Project Bronco2 !!-6195964756_9d02c655cf_b.jpg   Project Bronco2 !!-2011_0925bundy9-250083.jpg   Project Bronco2 !!-2011_0925bundy9-250124.jpg  

Project Bronco2 !!-2011_0911rocksvalley0029.jpg   Project Bronco2 !!-2011_0911rocksvalley0032.jpg   Project Bronco2 !!-1103111259a.jpg  
Reply With Quote
  #149  
Old 11-03-2011
Member
 
Join Date: Feb 2010
Location: Cocoa, FL
Posts: 555
Definitely one of my favorite BIIs ever.
Reply With Quote
  #150  
Old 11-03-2011
Jason8n's Avatar
Member
 
Join Date: Mar 2011
Location: Roxboro, North Carolina
Posts: 708
Wirelessly posted (Droid2)

Way too much character to swap the cab out...don't do it. Reading this thread makes me kick myself for selling my 86. Awesome build!
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Took Bronco2 on first test deathbypsi Meet & Greet Photos 22 03-24-2011 05:14 PM
90 Bronco2 partout {mi} deathbypsi Ranger Based Vehicles 0 12-05-2009 11:10 AM
My Bronco2 Beater Project deathbypsi Project Logs 223 06-18-2009 06:10 PM
Outside Bronco2 pix deathbypsi Snapshots 10 01-28-2009 07:43 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 09:24 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.