1998 problem - Ranger-Forums - The Ultimate Ford Ranger Resource


SOHC - 2.3L & 2.5L Lima Engines Discussions and Topics specific to the Lima 4 cylinder engines

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-03-2007
Member
Thread Starter
 
Join Date: Sep 2007
Location: belmont,nh
Posts: 2
1998 problem

Hi guys, i have a 1998 ranger with 2.5. I had the plugs and wires done back in march. Thinhg ran perfectly until recently. Now once it warms up,and i down shift into first gear, it wants to stall,and has a few times. Also when there is moisture in the air,it will run rough. Not sure what they used fpr plugs, but know they used the napa wires. Any thoughts on what could cause it to wanna stallwhile downshifting? thnx
Reply With Quote
  #2  
Old 10-04-2007
ranger1998xlt's Avatar
Member
 
Join Date: Jan 2007
Location: Iowa
Posts: 36
Try to clean your IAC Valve and your MAF Sensor. They can get dirty and majorly affect the idle. Does it ping or spark knock. How many miles are on the engine.
Reply With Quote
  #3  
Old 10-05-2007
Member
Thread Starter
 
Join Date: Sep 2007
Location: belmont,nh
Posts: 2
sorry, it has 87,000 miles. There is no ping, or spark knock. what is the best way to clean those?
Reply With Quote
  #4  
Old 10-05-2007
ranger1998xlt's Avatar
Member
 
Join Date: Jan 2007
Location: Iowa
Posts: 36
If you know where your IAC Is, Take it off, there should be two bolts that need to be rmoved. There is a gasket with it so be careful. Take it off and inspect it. Spray Carb Cleaner into it and get it really clean, then let it dry and install. The MAF sensor, it right on the Air Box. This takes a T20 Torque Wrench to remove the two little screws. When you get the screws out, be VERY Careful, there are two little springs on the MAF than can break. Spray Electrial Cleaner on the wires. Don't touch the wires. Then carefully install it. If you need more help, go to google and reserach them. Hope this helps!
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1998 ranger xlt o2sensor problem with check engine light on Mbafordranger 2.9L & 3.0L V6 Tech 13 05-28-2013 03:35 PM
problem with hazard lights 1998 ranger Ranger_Rickster General Technical & Electrical 7 08-11-2011 09:04 PM
1998 2.5 Idle & Power Problem Ray Parrott SOHC - 2.3L & 2.5L Lima Engines 5 05-14-2011 04:51 PM
What part is this? (pic) Blower problem, this the problem? stuck on vent! ChargerOnDavins General Technical & Electrical 4 10-03-2010 06:58 AM
leaking under dashboard 1998 ford ranger UncleRandall General Ford Ranger Discussion 5 08-26-2008 08:12 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 01:55 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.