2.3 running bad!!!! - Ranger-Forums - The Ultimate Ford Ranger Resource


SOHC - 2.3L & 2.5L Lima Engines Discussions and Topics specific to the Lima 4 cylinder engines

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-13-2008
Member
Thread Starter
 
Join Date: Apr 2008
Location: calhoun,mo
Posts: 34
2.3 running bad!!!!

ok so im new here...first post!! anyways i just bought a 91 ranger with a 2.3 manual. my problem is when the motor is cold it runs good...but when it warms up when i give it gas it just sputters bad and bogs down...i know plugs and wires need changed but would that be the cause seeing as how it only does it when warm?? any feedback would be much appreciated
Reply With Quote
  #2  
Old 04-13-2008
Member
 
Join Date: Apr 2005
Location: ft lauderdale, fl
Posts: 105
change the coil packs when you do the plugs and wires, it'll cost a little bit more, but will help narrow down the problem, also look into changin out the pcv valve. is the check engine light on?? if it is get it scanned and give us the codes
Reply With Quote
  #3  
Old 04-14-2008
Member
Thread Starter
 
Join Date: Apr 2008
Location: calhoun,mo
Posts: 34
yea hookin it up to comp tommorrow hope they give me something cheap lol something to get my 2.3 by.......its gutless but so far has gone a to b which is all i want makes my ears ring on the way too
Reply With Quote
  #4  
Old 04-14-2008
Member
Thread Starter
 
Join Date: Apr 2008
Location: calhoun,mo
Posts: 34
check engine light pops on only when it fudges up at least i know its cuming
Reply With Quote
  #5  
Old 04-15-2008
Member
Thread Starter
 
Join Date: Apr 2008
Location: calhoun,mo
Posts: 34
i had gotten two codes for egr
Reply With Quote
  #6  
Old 04-16-2008
Member
Thread Starter
 
Join Date: Apr 2008
Location: calhoun,mo
Posts: 34
did plugs and wires yesterday runs a lil better...not awhole lot though......also this truck has been sitting for awhile i have been driving for about a week
Reply With Quote
  #7  
Old 04-16-2008
02rangermayhem's Avatar
Member
 
Join Date: Jan 2008
Location: C.Springs
Posts: 573
change ur pcv and try seafoam. the seafoam isnt really going to help the problem much but it will get any crap thats in your engine out.

make sure if you do seafoam you do a tune up as well. (fuel filter, oil, oil filter, clean the MAF.......)
Reply With Quote
  #8  
Old 04-16-2008
Downey's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Oct 2007
Location: Muncy, PA
Posts: 8,470
dont do seafoam now because he will need new plugs do everything but seafoam for now do that last so you dont have to buy new plugs.
Reply With Quote
  #9  
Old 04-16-2008
Member
 
Join Date: Apr 2005
Location: ft lauderdale, fl
Posts: 105
also take the egr off the intake and clean the inside of the egr and intake manifold (its easier to clean the inside of the egr if you take it all that way off, and use somecarb cleaner). i have seen this make a world of a difference in an older f150, it went from sluggish to spinning tires. i was amazed

im thinking that or that cat is clogged, but try the egr first. i have seen this happen on a s10. it made a world of a difference
Reply With Quote
  #10  
Old 04-16-2008
bruiser's Avatar
Member
 
Join Date: Apr 2007
Location: lp,Texas
Posts: 482
if your getting a code for egr i would check it to make sure its not stuck open or closed
Reply With Quote
  #11  
Old 04-17-2008
Member
Thread Starter
 
Join Date: Apr 2008
Location: calhoun,mo
Posts: 34
how do i check if its open or closed?
Reply With Quote
  #12  
Old 04-17-2008
02rangermayhem's Avatar
Member
 
Join Date: Jan 2008
Location: C.Springs
Posts: 573
Quote:
Originally Posted by Downey View Post
dont do seafoam now because he will need new plugs do everything but seafoam for now do that last so you dont have to buy new plugs.

this is true. i forgot u said you replaced them


Quote:
Originally Posted by pongorulz View Post
im thinking that or that cat is clogged, but try the egr first. i have seen this happen on a s10. it made a world of a difference

this could also be a problem. my old truck had a clogged cat and blew a whole in the bottem of itself and sounded like s***. plus it had a muffler with busted up baffles.

try unbolting the exhaust from before the cat and run it down the street to see if it helps. it will be LOUD so i dont recommend doin it at night unless u hate ur neighbors.
Reply With Quote
  #13  
Old 04-18-2008
Member
Thread Starter
 
Join Date: Apr 2008
Location: calhoun,mo
Posts: 34
i had to have the exhaust replaced from the cat back to pass inspection a week ago and guy pointed out my cat had a crack all the way across the top of it. when i got the truck the guy said the fuel filter, air filter, and oil was changed....then sat for a couple of months. and he said he put seafoam in it. were u talkin about seafoam in the engine or fuel tank??

i was thinkin about taking fuel tank off and draining.....is it much of a pain??
Reply With Quote
  #14  
Old 04-18-2008
Member
Thread Starter
 
Join Date: Apr 2008
Location: calhoun,mo
Posts: 34
where is the pcv on this motor????
Reply With Quote
  #15  
Old 04-18-2008
Member
Thread Starter
 
Join Date: Apr 2008
Location: calhoun,mo
Posts: 34
yeah it bogs and sputters under 1800 rpm
Reply With Quote
  #16  
Old 04-20-2008
Member
Thread Starter
 
Join Date: Apr 2008
Location: calhoun,mo
Posts: 34
alright so on the way home from a lovely night at work(note sarcasm) i pulled off highway to find my cigarettes(no interior light) the truck dies then to get it started i had to push and pop clutch....turned over strong just wouldnt start. and 2 more times on the way back home i would be goin then it would loose power like the gas pedal wasnt doing nothing just slowly revved down so i would pop clutch again and go. then after doin that twice it died on my street. so i pushed the sonofa***** home.....btw i need to quit smoking and very glad i had just picked up a twelve pack
Reply With Quote
  #17  
Old 04-20-2008
94rangerguy2007's Avatar
Member
 
Join Date: Apr 2007
Location: fort myers,fl
Posts: 31
Have You Checked To See If The Cat Is Clogged? Mine Did This The Cat Was Clogged Soild. If You Drive At Night When You Get Some Miles On It Just Look Under It And If It's Glowing Red It's Clogged
Reply With Quote
  #18  
Old 04-20-2008
Member
 
Join Date: Apr 2005
Location: ft lauderdale, fl
Posts: 105
so now you have another problem.... did you happen to get it running again yet, thats the important part right now. i doubt it shutting off had anything to do with the egr, you might have another code now

yea, you gotta check that cat man, that would have somthing to do with loosing power, but i dont know about it shutting off. did you happen to check the inertia switch, have you had anyone in the passenger seat recently.
Reply With Quote
  #19  
Old 04-20-2008
Member
Thread Starter
 
Join Date: Apr 2008
Location: calhoun,mo
Posts: 34
YEAH IT started up this morning and went to work fine then when i left it did it once and drove 15 miles homes and didnt do it again. i havent had anyone in the passenger seat in past week. inertia switch do you mean like the fuel pump switch?? the guy at autozone was thinking the ignition control module said it sounded electrical he told me next time it does it to pull plug wire and check for spark
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
The_Dealer: Bad Deal Bad Member Bad Sell! LayingFrame89 Ranger Products, Company, & Member Reviews 34 12-01-2007 07:59 AM
Stock Drivesaft with RCD = BAD BAD BAD PICS INSIDE ranger General Ford Ranger Discussion 32 07-31-2007 12:50 PM
Truck running BAD help please. bryanjints 4.0L OHV & SOHC V6 Tech 12 01-20-2007 07:48 AM
Running really bad-Stuttering-Bucking bmxrider379 4.0L OHV & SOHC V6 Tech 4 09-11-2006 07:04 AM
ALL offroaders are BAD BAD BAD! FMD General Ford Ranger Discussion 13 04-25-2006 08:21 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 07:49 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.