97 ford ranger won't start - Ranger-Forums - The Ultimate Ford Ranger Resource


SOHC - 2.3L & 2.5L Lima Engines Discussions and Topics specific to the Lima 4 cylinder engines

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-25-2015
Member
Thread Starter
 
Join Date: Mar 2015
Location: Winter Park
Posts: 18
97 ford ranger won't start

My ranger has been sitting for about 2 years now. When I stored it is was running fine. I didn't think it had much fuel in it but it had about 1/2 tank.

I've pulled the bed off the truck and drained all of the fuel that I can. It only had a tiny bit in the bottom under the pump area. The fuel was bad as part of it was a lighter yellow but as I was moving the hose around I did get parts of dark yellow fuel. I've replaced it with 7 gallons of fresh gas.

I'm trying to get it going again. I was at first getting a single click so I pulled the starter and brought it into AutoZone and they tested it and said it was bad. That is now in and I was having the same problem. I replaced the starter solenoid and it is trying to crank now. Every so often it will try to start but wouldn't keep going. I've replaced the plugs and wires with the same result of it trying to start and occasionally start to run but when I try to give it some gas it will die or if I attempt to let it run it will die after a few seconds.

The engine doesn't smell like it was when I first started to crank it. I had a bad gas smell but now that is gone and is back to a normal smell. I don't know what else to try to get it running and don't want to keep throwing parts at it.
Reply With Quote
  #2  
Old 03-25-2015
RF Veteran
iTrader: (1)
 
Join Date: Jan 2014
Location: Vancouver, BC
Posts: 7,609
I would put some Seafoam injector cleaner in the tank.

If you haven't replaced the fuel filter do that, $10

And put some fresh gas in the intake, start engine and try to keep it running at 1,500-2,000RPMs

Just keep manually adding gas to intake, pain, but injectors will start to work again if the rail isn't clogged.

You know what that gas looked like in the tank, well that is what it looked like in the fuel rail and inside the injectors, it will take a bit of driving and seafoam in the tank each time to clean them out.

When you were first going to get it back up and running I would have vacuumed open the fuel pressure regulator and cycled the new gas up to there, but that is past.
Reply With Quote
  #3  
Old 03-26-2015
Member
Thread Starter
 
Join Date: Mar 2015
Location: Winter Park
Posts: 18
I really didn't crank it before I cleaned the tank out. I did get the single click before but that was about it.

Should I place the entire can of the SeaFoam into the tank even though it is only around 1/2 tank?
Reply With Quote
  #4  
Old 03-26-2015
RF Veteran
iTrader: (1)
 
Join Date: Jan 2014
Location: Vancouver, BC
Posts: 7,609
No, just use as directed on the can for the gallons of gas in tank.

Not sure if you can rent them but there are injector/rail cleaners that can be used without dismantling the system, but these also require engine to at least be running so cleaner can be passed thru the system.

This is a DIY video on how to clean injectors that are out, cheap:
Reply With Quote
  #5  
Old 03-26-2015
Member
Thread Starter
 
Join Date: Mar 2015
Location: Winter Park
Posts: 18
Thanks for the replys so far. I've been searching around and found a video that said to test the relay and to jumper the + and - to see if the fuel pump runs. I attempted that and I didn't hear anything. Is there another way to test the pump to see if it is even pumping fuel?
Reply With Quote
  #6  
Old 03-26-2015
RF Veteran
iTrader: (1)
 
Join Date: Jan 2014
Location: Vancouver, BC
Posts: 7,609
Just turn on the key, Fuel pump will come on for 2 seconds each time key is turned on.
It is loud enough to hear in the cab.

On the fuel rail there is a valve, schrader valve, looks like a tire's air valve, there should be 35-40psi pressure behind that valve, becareful, push in the center pin, like letting air out of a tire, fuel can squirt out 20-30ft.
Reply With Quote
  #7  
Old 03-27-2015
Member
Thread Starter
 
Join Date: Mar 2015
Location: Winter Park
Posts: 18
I guess the fuel pump is the next thing to be replaced. I couldn't hear the pump running so I pulled the connector off the pump and put a meter on it. I can see a spike of 12v for a few moments when I turn the key on and then it drops to 6.4v.
Reply With Quote
  #8  
Old 03-27-2015
RF Veteran
iTrader: (1)
 
Join Date: Jan 2014
Location: Vancouver, BC
Posts: 7,609
yes, reads like fuel pump is out
Reply With Quote
  #9  
Old 03-28-2015
Member
Thread Starter
 
Join Date: Mar 2015
Location: Winter Park
Posts: 18
Well everything is running. I replaced the fuel pump and filter and it started up with no problems. I don't have an RPM gauge so I was guessing the RPM to run it for a while. Need to do a few more things to have it ready for the road. Is there anything else that I should check before I begin to run it?
Reply With Quote
  #10  
Old 03-28-2015
RF Veteran
iTrader: (1)
 
Join Date: Jan 2014
Location: Vancouver, BC
Posts: 7,609
Good work.

No, should be fine now.
Change the oil if you haven't already, maybe run a 1/2 quart of ATF for 40-50 miles before changing
ATF is high detergent oil it can help clean out oil passages that may have residue from sitting.
Reply With Quote
  #11  
Old 03-28-2015
Member
Thread Starter
 
Join Date: Mar 2015
Location: Winter Park
Posts: 18
Ah, I was going to change that tomorrow morning. The only thing that I have to change and part of the reason for storing it was a leaky power steering pump so I'll do that tomorrow and double check on everything else. Updating my list on what I want to do and need to do.

Thanks again for your help and pointers.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1999 FORD RANGER XLT 3.0 5 SPEED WON'T START therumpledone General Technical & Electrical 6 02-04-2014 05:04 PM
Incorrect jump start. Truck won't start now. Pilot General Technical & Electrical 3 10-27-2013 08:07 AM
Very weird! Won't start, won't shut off, flashing exterior lights fletcher969 2.9L & 3.0L V6 Tech 4 01-14-2013 06:26 PM
97 Ford Ranger won't start, no fire. elvinjijo General Ford Ranger Discussion 2 07-05-2012 10:02 AM
Won't start, dome light dies when trying to start. Jerkstore General Technical & Electrical 4 10-02-2011 10:53 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 03:45 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.