A/C problems - Ranger-Forums - The Ultimate Ford Ranger Resource


SOHC - 2.3L & 2.5L Lima Engines Discussions and Topics specific to the Lima 4 cylinder engines

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-17-2008
gr8shot's Avatar
Member
Thread Starter
 
Join Date: Jun 2008
Location: Lincoln, NE
Posts: 34
A/C problems

Okay, second post, another ?

The truck, my gf's 97 mazda B2300 2.3L (obviously) manual tranny 130k miles

The a/c does not work. And the temperature **** does nothing. The heater has been stuck on since she bought it in Jan of this year. The fan works on all speeds, the heat/cool selector **** turns, but does nothing. The selector switch will change the airflow to all the different settings (vent, def., floor etc), but when we select a/c it does nothing. Compressor does not turn on, does not blow cold air, just blows HEAT!!! Also when we try defrost, no compressor either.

My ? is... what would be the steps in troubleshooting this. I've looked and all three ***** are connected in back, but thats about as far as I have gotten, since I'm not very familiar with fords (chevy guy, but I'm here to learn). We're probably going to end up taking it to a shop to get fixed, but I thought it would be best to check with some experts to see if it could be something easy that I could fix and save her (translation--> me) the money.

Thanks for all the help in advance!!!
Reply With Quote
  #2  
Old 06-17-2008
leadfoot's Avatar
Member
 
Join Date: Oct 2007
Location: MA
Posts: 894
One thing to check would be the blend door, it has a history of breaking.

https://www.ranger-forums.com/forum2...blend+door+fix
Reply With Quote
  #3  
Old 06-17-2008
gr8shot's Avatar
Member
Thread Starter
 
Join Date: Jun 2008
Location: Lincoln, NE
Posts: 34
WoW thanks for the info. Hopefully thats what it is. Does it really cost $1000 for a shop to fix it? That article made pretty good sense, except for the part about how to tell if its broken or not, and how exactly to put it back in once you drill and put in the pin. Hopefully it'll make some more sense after I tear into it this weekend. Thanks for the heads up though!!
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Clutch problems or Motor problems? Or both? JGod General Ford Ranger Discussion 3 02-08-2014 07:35 AM
Clutch problems...possibly?!?!? Help?? ZetaOmegaRanger 2.9L & 3.0L V6 Tech 2 01-04-2008 02:47 AM
Door dinger mod... now problems with blinkers? Zero General Technical & Electrical 4 09-28-2004 11:35 AM
Amp problems Skyjacker_44 Audio & Video Tech 3 08-31-2004 09:52 AM
Driver's side seat belt problems... 98blackranger Interior Semi-Tech 6 06-24-2004 02:07 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 01:22 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.