Got a quick question for you guys! - Ranger-Forums - The Ultimate Ford Ranger Resource


SOHC - 2.3L & 2.5L Lima Engines Discussions and Topics specific to the Lima 4 cylinder engines

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 12-18-2009
TrndAssassin's Avatar
Member
Thread Starter
iTrader: (3)
 
Join Date: Mar 2009
Location: Lafayette Indiana
Posts: 375
Got a quick question for you guys!

Ok got a quick question for you guys,
I have a 1995 ford ranger 2.3l 5 speed
Ive used the search function
Im throwing a p1443 Code
Which ive figured is either purge canister....purge flow sensor...vaccum leak
or a clogged cat possibly

What I wanna know
Is will the p1443 Code
Throw the truck into "stock" or Limp mode..and cause it to get ****ty gas mileage?
list of things ive done recently

Brand new plugs wires
NGK o2 sensors
Cleaned maf
new PCV
New air filter
New Temp sensor
Reply With Quote
  #2  
Old 12-18-2009
Bryan22's Avatar
Member
 
Join Date: Nov 2008
Location: Lancaster, ca
Posts: 211
everyone who's had that code reports crappy mileage. you're on the right track with what you're thinking is wrong. now fix it :)
Reply With Quote
  #3  
Old 12-18-2009
fishy2k8's Avatar
Member
iTrader: (-1)
 
Join Date: Jun 2006
Location: Avon, IN
Posts: 457
i had that code once, it was the evap purge valve i believe
Reply With Quote
  #4  
Old 12-18-2009
V8 Level II's Avatar
RF Veteran
iTrader: (4)
 
Join Date: Nov 2004
Location: Michigan
Posts: 7,833
For 95~97, P1443 could possibly be the Canister Purge Solenoid or leaking hoses in the same general area. Often, it's the Purge Flow Sensor gone belly up.
Reply With Quote
  #5  
Old 12-18-2009
TrndAssassin's Avatar
Member
Thread Starter
iTrader: (3)
 
Join Date: Mar 2009
Location: Lafayette Indiana
Posts: 375
anyway to test purge flow sensor..and purge canister..before I just start tossin parts at it lol?

I have a possible vaccum leak I need to fix first though..before I go any further so...while im in alabama and its warm I'll fix that!
Reply With Quote
  #6  
Old 12-18-2009
V8 Level II's Avatar
RF Veteran
iTrader: (4)
 
Join Date: Nov 2004
Location: Michigan
Posts: 7,833
First is a visual check of the hose segments that run between the canister and the engine and also pass through the Canister Purge Solenoid and Purge Flow Sensor on the way. If you have access to a hand vacuum pump, that would be handy too.

You should be able to do a quick test on the Canister Purge Solenoid by simply putting 12v across it and seeing if it opens.

Checking the Purge Flow Sensor isn't as easy.

I think Ford sells the whole assembly of CPS, PFS and hoses as a $100+ assembly. I was able to get the PFS for an Escort separately from RockAuto for about $20.
Reply With Quote
  #7  
Old 12-18-2009
TrndAssassin's Avatar
Member
Thread Starter
iTrader: (3)
 
Join Date: Mar 2009
Location: Lafayette Indiana
Posts: 375
alrighty..as soon as I get some warm..climate I'll tear into this a little more..thank you guys!
Reply With Quote
  #8  
Old 12-18-2009
TheStig88's Avatar
Member
iTrader: (4)
 
Join Date: Aug 2008
Location: Columbia, Missouri
Posts: 2,120
i was throwing the same code....replaced the hoses and gas cap and i turned it off (code reader from work)

it came on again about a month later....i drove off from the gas station and forgot the gas cap
Reply With Quote
  #9  
Old 12-18-2009
TrndAssassin's Avatar
Member
Thread Starter
iTrader: (3)
 
Join Date: Mar 2009
Location: Lafayette Indiana
Posts: 375
I actually think mines a leaky filler neck now that I think about it...because my fill neck has a slight leak..only when you top the tank all the way off..so I guess I'll seal that off first and see what happens!
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
quick question about Brakecleen, need quick answer if possible 93rangerXLT4x4 Auto Detailing 101 15 11-28-2009 10:24 PM
Quick Trans question, need help quick dmathews 2.9L & 3.0L V6 Tech 0 11-15-2009 02:30 PM
quick question real quick dantheman General Ford Ranger Discussion 3 05-16-2009 01:52 AM
Need opinions from you guys quick 99offroadrngr Wheels & Tires Semi-Tech 7 02-06-2009 07:04 PM
You guys with subs...got a question for ya.... crawly1025 Audio & Video Tech 15 07-11-2006 12:48 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 01:30 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.