hard to start - Ranger-Forums - The Ultimate Ford Ranger Resource


SOHC - 2.3L & 2.5L Lima Engines Discussions and Topics specific to the Lima 4 cylinder engines

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 02-11-2013
Cobra GT's Avatar
Member
Thread Starter
 
Join Date: Dec 2008
Location: Metairie, La.
Posts: 5
hard to start

I have a 94 Ranger w/ 2.3L I just bought. Hit it up on a code reader key got back EGR not opening or closing. I took it off and fixed it and am not getting that code but it is still doing the same thing. The codes I am getting now are engine coolant temp sensor (ECT) voltage too high or too, and vehicle speed sensor (VSS) signal too low. I have changed plugs, wires, and fuel filter. What it does is it is hard to start and when it finally starts it stumbles like it is running on 2 or 3 cylinders. It clears up and it runs almost perfect except when I rev it up it will stay at about 1500 rpm’s then the idle will come down to normal. Can anyone help me with some suggestions, thanks.
Reply With Quote
  #2  
Old 02-18-2013
Member
 
Join Date: Feb 2013
Location: California / Texas
Posts: 3
This forum sucks when asking for help. No help on my thread and clearly no help on your thread. Definitely not the ultimate ranger resource.
Reply With Quote
  #3  
Old 02-18-2013
ranger4.0's Avatar
Member
iTrader: (1)
 
Join Date: Jul 2009
Location: cambridge, ontario
Posts: 3,922
Quote:
Originally Posted by tekelley22 View Post
This forum sucks when asking for help. No help on my thread and clearly no help on your thread. Definitely not the ultimate ranger resource.
if you dont like this forum then why dont you take your ever so useful posts else where?



op, i really dont have any insight into the problems you are having. hopefully someone else will chime in here and give you the info you need. every time i have ever posted here for help i have always gotten a lot of great info
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Ranger hard start issue HELP COLD START 1994splash 2.9L & 3.0L V6 Tech 1 06-08-2011 05:27 PM
Hard start in the morning and after driving ramrezz425 4.0L OHV & SOHC V6 Tech 6 04-08-2009 08:22 AM
Hard to start rangerbert 4.0L OHV & SOHC V6 Tech 11 05-09-2008 07:06 AM
Idles rough, and hard to start, Help!! BOxford32 2.9L & 3.0L V6 Tech 2 02-23-2008 07:29 PM
Hard start after cold. Ranger1 General Ford Ranger Discussion 3 12-29-2004 04:14 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 11:36 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.