stupid aftermarket intake - Ranger-Forums - The Ultimate Ford Ranger Resource


SOHC - 2.3L & 2.5L Lima Engines Discussions and Topics specific to the Lima 4 cylinder engines

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-04-2011
Member
Thread Starter
 
Join Date: Dec 2010
Location: salina, Kansas
Posts: 6
stupid aftermarket intake

ever since i got one of these gay spectre cone intakes, nothing but stalling and over heating is happening. and ive been researching like crazy on this stuff and the problem seems to stem from me taking the air box out which contains the bi metal sensor and inlet air. but im not totally sure it seems like i have some kind of vacuum leak or something making my truck run lean and hot. i found cracks in my pcv elbow and heard this can cause problems. i anxiously replaced the elbow and found that it didn't solve my problem. is there a way to bypass these sensors or what. ive cleaned the throttle body, iac, and maf sensor all of that stuff is fine. ive heard that the tps can cause some similar problems but i dont think thats it either. im convinced its these sensors because its supposed to keep temperature at a consistent rate or something like that with some kind of diverter door, am i right? since i dont have this whaaaaaaaaaaaat at all can i do? at this point i just want my stock intake back but even then idk where the hell to get a stock airbox and the whole shebang that does with it. please help me this is hella annoying ive searched google and all kinds of forums. anyhelp would be fan*uckingtastic. (can you swear on this forum)? lol
Reply With Quote
  #2  
Old 07-04-2011
Member
Thread Starter
 
Join Date: Dec 2010
Location: salina, Kansas
Posts: 6
and as far as ignition stuff its all good its got fairly new wires and plugs, and i just replaced the coil packs not even 2 weeks ago thinking it would help solve this stalling problem. sorry for the double post
Reply With Quote
  #3  
Old 07-04-2011
RLong31's Avatar
The Ban Hammer
iTrader: (5)
 
Join Date: Jul 2009
Location: Monrovia, IN
Posts: 2,629
Go to a junk yard and get a stock set up again. If you search around this forum, you will see that cold air intakes are a waste of money for these trucks. All you do is suck in hot engine air... which defeats the purpose. If you didn't have these issues before, hopefully it will fix them.
Reply With Quote
  #4  
Old 07-04-2011
04RangerDave's Avatar
JDM> RANGER

iTrader: (3)
 
Join Date: Jul 2010
Location: RI
Posts: 5,030
Wirelessly posted

What year is your truck? Did u remove the maf?
Reply With Quote
  #5  
Old 07-04-2011
Member
Thread Starter
 
Join Date: Dec 2010
Location: salina, Kansas
Posts: 6
it is 92, and the maf sensor is still on there i had to buy some special adapter for it off of ebay. and the air charge temp is in place too. its a little messed up, like one of the clips is broke off so it wobbles around a bit. yeah ive read up and down so many of these forums and aftermarket intakes are for this thing are worthless. i havent felt the true power of my truck in so long its killing me!
Reply With Quote
  #6  
Old 07-04-2011
04RangerDave's Avatar
JDM> RANGER

iTrader: (3)
 
Join Date: Jul 2010
Location: RI
Posts: 5,030
Wirelessly posted

It is worthless go back to stock with a Kn drop in
Reply With Quote
  #7  
Old 07-04-2011
RLong31's Avatar
The Ban Hammer
iTrader: (5)
 
Join Date: Jul 2009
Location: Monrovia, IN
Posts: 2,629
Quote:
Originally Posted by 04RangerDave View Post
Wirelessly posted

It is worthless go back to stock with a Kn drop in
x2
Reply With Quote
  #8  
Old 07-05-2011
Member
Thread Starter
 
Join Date: Dec 2010
Location: salina, Kansas
Posts: 6
so is there anything at all i could do to help? or is it going to continue to run like pooh no matter what. i plan on getting an airbox back if theres any junkers around here. ive seen some on ebay but i dont wanna get jipped with just an airbox and no attachments or anything because i have just the box. worst mistake ive ever made when it comes to this truck.
Reply With Quote
  #9  
Old 07-30-2011
Member
 
Join Date: Oct 2010
Location: st louis, mo
Posts: 1
i made a home built cold air intake for my 94 mazda 2.3. it made all the difference in the world in low and med range perf. got rid of the orig air cleaner box, intake muffler and exhaust heat tube. bought a spectre filter at auto zone and made up hi temp plastic intake plumbing out of some of the orig pcs . biggest problem was what do with the iaf sensor. final solution was to drill a hole in the end of the filter and put it there. also put the maf sensor as close to the throttle body as possible. the bi-metal sensor is just hanging there and doesnt present problems.the original curved pc of plastic flex tubing i put up to the filter and let it go down next to the radiator. some old metal flex tubing furnishs 'cold air' from under the truck. performance is excellant and sounds great. still havent figured out a simple way to feed hot air to the system in winter. but a little extra warm up time seems to do the job for now.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Stupid leak, stupid question puntadigital 2.9L & 3.0L V6 Tech 8 03-24-2011 09:13 PM
STUPID!STUPID!STUPID! jtfoxman General Ford Ranger Discussion 14 07-30-2009 12:42 AM
Stupid wind. Stupid tree. Sixt9coug General Ford Ranger Discussion 9 01-30-2009 03:16 PM
stupid, stupid truck purekaos26 General Ford Ranger Discussion 10 12-24-2005 10:01 AM
Stupid, stupid man.... aftermarket Suspension Tech 16 07-20-2005 03:41 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 08:49 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.