2wd lift sucks! - Page 2 - Ranger-Forums - The Ultimate Ford Ranger Resource


Suspension Tech General discussion of suspension for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #26  
Old 02-27-2012
2.3L turd's Avatar
Member
Thread Starter
 
Join Date: Jul 2009
Location: Saukville,WI
Posts: 127
Oh i got new shocks before all this was installed. I run the Bilstein 5100 Series which is rated for a 3" lift in the front. I only have the 2.5" coils so I should e good.
Reply With Quote
  #27  
Old 02-27-2012
mhs2013's Avatar
Member
 
Join Date: Jan 2012
Location: Arlington, Texas
Posts: 161
When I lifted mine i replaced the upper control arm (with ball joints) lower ball joints longer shocks and then got it aligned..rides just fine.
Reply With Quote
  #28  
Old 02-27-2012
98liftedranger's Avatar
RF Veteran
iTrader: (5)
 
Join Date: Aug 2008
Location: California
Posts: 12,538
If you posted pics we could probably diagnose your problem right away.
Reply With Quote
  #29  
Old 02-27-2012
2.3L turd's Avatar
Member
Thread Starter
 
Join Date: Jul 2009
Location: Saukville,WI
Posts: 127
I'm getting it realigned today and I talked to Fabtech and he said he has gotten the same complaints before with people that have my same modle truck. Im going to see what the camber alignment does since that was way out.
Reply With Quote
  #30  
Old 02-27-2012
Member
 
Join Date: Jan 2012
Location: ceres
Posts: 4
I jus put on bout 2in spacers that came off a 99 that are metal but my ranger is a 93 it all fit right but the alignment is way off bottom of the tires stuck in pretty bad I took it in to get aligned its better but u can still tell a lil that the bottom of the tires still look like they have a slant is there and bars in the front I should change out or go a different rout to get this tires looking straight
Reply With Quote
  #31  
Old 02-27-2012
<TX>TORKiT's Avatar
Member
iTrader: (1)
 
Join Date: Jun 2010
Location: Dallas, TX
Posts: 1,551
Nice avatar!
Reply With Quote
  #32  
Old 02-28-2012
2.3L turd's Avatar
Member
Thread Starter
 
Join Date: Jul 2009
Location: Saukville,WI
Posts: 127
Got the alignment done and the camber is fixed again. Took the sway bar off and seems to ride a little better. I guess i just need to give it more then a week and a half to settle in maybe. the truck does look good though.
Reply With Quote
  #33  
Old 02-28-2012
rangerrunner11's Avatar
Member
 
Join Date: Feb 2011
Location: .
Posts: 1,018
Quote:
Originally Posted by 2.3L turd View Post
Got the alignment done and the camber is fixed again. Took the sway bar off and seems to ride a little better. I guess i just need to give it more then a week and a half to settle in maybe. the truck does look good though.
wish we could see too........ (<-- that was a hint for pics)
Reply With Quote
  #34  
Old 02-28-2012
2.3L turd's Avatar
Member
Thread Starter
 
Join Date: Jul 2009
Location: Saukville,WI
Posts: 127
Here it is.
Attached Thumbnails
2wd lift sucks!-ranger.jpg   2wd lift sucks!-ranger1.jpg  
Reply With Quote
  #35  
Old 02-28-2012
06RangerXLT's Avatar
Member
iTrader: (2)
 
Join Date: Feb 2011
Location: Halton Hills, Ont
Posts: 1,685
where did ya get the FX2 offroad stickers?

Im not surprised it rides rough. the same kit if made for ext cabs that have a fair bit more weight. being so small shes gonna ride rough no matter what. (plus its fabtech, its cheap for a reason)
Reply With Quote
  #36  
Old 02-28-2012
rangerrunner11's Avatar
Member
 
Join Date: Feb 2011
Location: .
Posts: 1,018
its called fap-tech...thats all they seem to do is wack off
Reply With Quote
  #37  
Old 02-29-2012
2.3L turd's Avatar
Member
Thread Starter
 
Join Date: Jul 2009
Location: Saukville,WI
Posts: 127
Quote:
Originally Posted by 06RangerXLT View Post
where did ya get the FX2 offroad stickers?
Got them made up at a local decal shop.
Reply With Quote
  #38  
Old 02-29-2012
06RangerXLT's Avatar
Member
iTrader: (2)
 
Join Date: Feb 2011
Location: Halton Hills, Ont
Posts: 1,685
ah. they wanted $180 for em localy
Reply With Quote
  #39  
Old 03-01-2012
2.3L turd's Avatar
Member
Thread Starter
 
Join Date: Jul 2009
Location: Saukville,WI
Posts: 127
Quote:
Originally Posted by 06RangerXLT View Post
ah. they wanted $180 for em localy
$180 for two stickers?! I payed $20.
Reply With Quote
  #40  
Old 03-01-2012
06RangerXLT's Avatar
Member
iTrader: (2)
 
Join Date: Feb 2011
Location: Halton Hills, Ont
Posts: 1,685
yup. ive gota family in wisconsin, when im out there maybe i can get you to mail me some.
Reply With Quote
  #41  
Old 03-01-2012
2.3L turd's Avatar
Member
Thread Starter
 
Join Date: Jul 2009
Location: Saukville,WI
Posts: 127
Quote:
Originally Posted by 06RangerXLT View Post
yup. ive gota family in wisconsin, when im out there maybe i can get you to mail me some.
I have seen them on ebay too.
Reply With Quote
  #42  
Old 03-02-2012
2.3L turd's Avatar
Member
Thread Starter
 
Join Date: Jul 2009
Location: Saukville,WI
Posts: 127
Well got the latest news from Fabtech. They can't understand why my truck rides the way it does and why the truck springs haven't settled yet. They said that even though it's the lightest truck in that class it still shouldn't ride that way. The engineers and tech manager are afraid Im going to break something. So they are sending me another set of springs to swap out and try. If that doesn't work they said they are baffeled and have no clue. So we will see what happen's when they come and I get them in.
Reply With Quote
  #43  
Old 03-02-2012
06RangerXLT's Avatar
Member
iTrader: (2)
 
Join Date: Feb 2011
Location: Halton Hills, Ont
Posts: 1,685
NICE!
Reply With Quote
  #44  
Old 03-02-2012
2.3L turd's Avatar
Member
Thread Starter
 
Join Date: Jul 2009
Location: Saukville,WI
Posts: 127
So I will have an extra set of springs if anyone is interested?
Reply With Quote
  #45  
Old 03-02-2012
06RangerXLT's Avatar
Member
iTrader: (2)
 
Join Date: Feb 2011
Location: Halton Hills, Ont
Posts: 1,685
Quote:
Originally Posted by 2.3L turd View Post
So I will have an extra set of springs if anyone is interested?
i wouldnt count on it, they will more then likely want them back for testing.

are your front and rear shocks the same brand and type? if not, thats gonna be your rough ride reason. hard shocks on only one end will cause a bouncy ride.
Reply With Quote
  #46  
Old 03-02-2012
2.3L turd's Avatar
Member
Thread Starter
 
Join Date: Jul 2009
Location: Saukville,WI
Posts: 127
Quote:
Originally Posted by 06RangerXLT View Post
i wouldnt count on it, they will more then likely want them back for testing.

are your front and rear shocks the same brand and type? if not, thats gonna be your rough ride reason. hard shocks on only one end will cause a bouncy ride.
No the guy there told me to do what I want with them. I offered to ship them back but he doesn't want them. Also I replaced all 4 shocks at the same time with new Bilstein 5100's. The tech told me that wasn't the case, that Bilstein shocks are even better then theirs.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
dang 4 wheel parts sucks..... lifted97ranger General Ford Ranger Discussion 24 06-16-2006 02:43 PM
this sucks i_love_paintbal Suspension Tech 45 01-08-2006 07:06 PM
Sucks for this guy (pic) SanityAside General Ford Ranger Discussion 15 10-07-2005 02:23 AM
Desperation SUCKS.... John Moorehead Exterior Semi-Tech 13 12-27-2004 07:12 AM
3.0 SUCKS! TremorJon 2.9L & 3.0L V6 Tech 74 11-03-2004 01:17 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 12:07 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.