It doesn’t sound good - Ranger-Forums - The Ultimate Ford Ranger Resource


Suspension Tech General discussion of suspension for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-28-2007
Steve_O113's Avatar
Member
Thread Starter
 
Join Date: Apr 2007
Location: Albany, OR
Posts: 562
It doesn’t sound good (updated: found out what it was)

Ok Iv got a noise coming from my left front; its sounds like there’s extreme play in something (clanking sound kinda like what your hitch sounds like when you hit a bump at a higher speed) on the front end. After work today im going to take a better look and try and figure it out.

It happens when traveling down a gravel road or when I hit a small bump, when going over speed bumps or curbs it doesn’t happen (slow speeds) it also drives fine and still goes down the road as strait as it ever has.

Im thinking it’s the shock, I believe it happened when I hit a pot hole though. If you guys think its something else, ill check anything you guys suggest, and could you give a quick how to, to check the part you suggested.

Thanks a head of time

Last edited by Steve_O113; 08-30-2007 at 06:53 AM.
Reply With Quote
  #2  
Old 08-28-2007
HighRollerII's Avatar
RF Veteran
iTrader: (4)
 
Join Date: Jun 2004
Location: Charleston, SC
Posts: 10,066
how many miles are on the truck?
Reply With Quote
  #3  
Old 08-28-2007
Steve_O113's Avatar
Member
Thread Starter
 
Join Date: Apr 2007
Location: Albany, OR
Posts: 562
39,000
Reply With Quote
  #4  
Old 08-28-2007
Steve_O113's Avatar
Member
Thread Starter
 
Join Date: Apr 2007
Location: Albany, OR
Posts: 562
Id like to get this fixed today... any ideas
Reply With Quote
  #5  
Old 08-28-2007
HighRollerII's Avatar
RF Veteran
iTrader: (4)
 
Join Date: Jun 2004
Location: Charleston, SC
Posts: 10,066
get up under there and see if anything is loose or looks like it has moved..i dunno what it is. but something seems loose
Reply With Quote
  #6  
Old 08-28-2007
Steve_O113's Avatar
Member
Thread Starter
 
Join Date: Apr 2007
Location: Albany, OR
Posts: 562
it was dark when i started hearing it, and i drove the car to work so i just wanted to know if there where some parts to look for...

i grabed the shock, cv, and a couple of other things but nothing felt loose
Reply With Quote
  #7  
Old 08-29-2007
Member
 
Join Date: Aug 2005
Location: Haverhill, MA
Posts: 1,907
sway bar endlink get busted out?? thats what mine was
Reply With Quote
  #8  
Old 08-29-2007
Steve_O113's Avatar
Member
Thread Starter
 
Join Date: Apr 2007
Location: Albany, OR
Posts: 562
Quote:
Originally Posted by MonsterGuy
sway bar endlink get busted out?? thats what mine was
I just got under there and shook this **** out of everything… nothing moved, could it be the shock
Reply With Quote
  #9  
Old 08-30-2007
Steve_O113's Avatar
Member
Thread Starter
 
Join Date: Apr 2007
Location: Albany, OR
Posts: 562
So the final thing i checked, should have been one of the first...

a guy at word told be break pads have "rattlers" (those metal tabs to hold the pads tight so they don’t rattle) and they fall out (at least hes had a few do them) and he suggested I look at those. Well after checking everything else I figured what the hell.

Im embarrassed to say but one of my caliper bolts was backed out about a turn and the other was about half way out and you could turn it by hand. Now I put loc-tite on the bolts last time I messed with my pads so is there anyway to explain why the would come loose? I checked the other side and they where a b!tch to back out.
Reply With Quote
  #10  
Old 09-01-2007
Member
 
Join Date: Feb 2006
Location: Seattle, WA
Posts: 8
did it kinda click when you drove it??, mine does that, it clicks when i turn and even when i'm going straight. I can feel it in the wheel, and i have gotten under the thing but nothing looks outta ordinary.
Reply With Quote
  #11  
Old 09-02-2007
RockysFord's Avatar
Member
 
Join Date: May 2005
Location: Columbus Ohio
Posts: 2,782
sounds like your half shaft is done for ^^^^

Good call on the calipers.. make sure you lube them up good with silicone lube so your pads slide easily...

I had a noise like that, i replaced both front shocks, it ended up being my step bars...
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Does this sound to good to be true??? capz011 General Ford Ranger Discussion 6 11-13-2011 01:04 PM
bad sound, i mean- not good at all wolfman00 Drivetrain Tech 20 12-16-2008 09:07 PM
Does this sound like a good price? schatten789 Suspension Tech 8 04-22-2008 09:23 PM
Suggestions for a basic, but good sound system. pacodiablo Audio & Video Tech 6 10-02-2004 10:22 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 05:39 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.