New noise when front end flexes - Ranger-Forums - The Ultimate Ford Ranger Resource


Suspension Tech General discussion of suspension for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-24-2007
l2en's Avatar
Member
Thread Starter
 
Join Date: Dec 2005
Location: The Keystone State
Posts: 4,521
New noise when front end flexes

Ever since I got the truck back, it makes a clicking noise like something is rubbing whenever I climb over something with one side or the other. It's not prevelant when both front tires approach something evenly. It doesn't matter if the wheel is turned or dead on straight. I checked out the entire front end yesterday when I put the sway bar back on and nothing is coming in contact with anything. Maybe it has something to do with cutting down the front bump stops?? I cut them even with the ridge in the middle of the poly part. There's still a good 3/4" left. I'm gonna go out and see if any of the POR is being scratched off around the bump stops in the morning. If I can't figure it out then it's going back to Ford. There are a couple issues that need addressed post-engine swap. They didn't clip the fan shroud in correctly(too lazy to fix myself), the engine makes a ticking sound when idling, and there was something else they need to correct.

Any ideas?
Reply With Quote
  #2  
Old 04-24-2007
jrpro130's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Sep 2005
Location: Florida
Posts: 5,057
Quote:
Originally Posted by l2en
Ever since I got the truck back, it makes a clicking noise like something is rubbing whenever I climb over something with one side or the other. It's not prevelant when both front tires approach something evenly. It doesn't matter if the wheel is turned or dead on straight. I checked out the entire front end yesterday when I put the sway bar back on and nothing is coming in contact with anything. Maybe it has something to do with cutting down the front bump stops?? I cut them even with the ridge in the middle of the poly part. There's still a good 3/4" left. I'm gonna go out and see if any of the POR is being scratched off around the bump stops in the morning. If I can't figure it out then it's going back to Ford. There are a couple issues that need addressed post-engine swap. They didn't clip the fan shroud in correctly(too lazy to fix myself), the engine makes a ticking sound when idling, and there was something else they need to correct.

Any ideas?

FWIW my truck and kevins truck both make that noise when we are not on the pavement. It clicks. It's definetly the swaybar b/c when I had mine off it didn't do that.

Try taking the swaybar off.
Reply With Quote
  #3  
Old 04-24-2007
lifted97ranger's Avatar
Member
 
Join Date: Nov 2005
Location: Charlestown, IN
Posts: 1
it is your trucks way of telling you "Keep my *** on the road"...."next time you wont be able to repair me!"
Reply With Quote
  #4  
Old 04-24-2007
01xltranger4x4's Avatar
Member
iTrader: (3)
 
Join Date: May 2005
Location: MI
Posts: 3,200
Mine has a ticking at ide as well.

I think it is a small exhaust manifold leak.
Reply With Quote
  #5  
Old 04-24-2007
Member
 
Join Date: Sep 2005
Location: Charlotte, NC
Posts: 561
CV bind? Possible that your over extending something because of the cut bumpstops?
Reply With Quote
  #6  
Old 04-24-2007
l2en's Avatar
Member
Thread Starter
 
Join Date: Dec 2005
Location: The Keystone State
Posts: 4,521
^^^^That is entirely possible. I'll have to ask gumby as he didn't run bump stops for a period of time....might not even have them on yet. lol


The noise was there before the sway bar was put back on. When I did put it back on I checked clearances on everything.
Reply With Quote
  #7  
Old 04-24-2007
gumby's Avatar
Member
iTrader: (1)
 
Join Date: Nov 2005
Location: indy
Posts: 1,581
nope, no noise like that on mine. i have locker noise, and steering stop noise. i also have the pancake bumpstops on now, BTW.
is the clickin speed related?
Reply With Quote
  #8  
Old 04-24-2007
l2en's Avatar
Member
Thread Starter
 
Join Date: Dec 2005
Location: The Keystone State
Posts: 4,521
Quote:
Originally Posted by gumby
nope, no noise like that on mine. i have locker noise, and steering stop noise. i also have the pancake bumpstops on now, BTW.
is the clickin speed related?
I only seem to notice it at very low speeds. Like when I pull into my stone driveway to turn around, I drive over sidewalk that's about two inches higher than the stone b/c of washout. I hear it then. I dunno, it's hard to say as the flow40 and headers leave little room for judging the sound of anything once you hit 2500 rpms.
Reply With Quote
  #9  
Old 04-24-2007
ranger's Avatar
Member
 
Join Date: Jun 2006
Location: Imperial Beach, CA
Posts: 4,502
Quote:
Originally Posted by l2en
^^^^That is entirely possible. I'll have to ask gumby as he didn't run bump stops for a period of time....might not even have them on yet. lol


The noise was there before the sway bar was put back on. When I did put it back on I checked clearances on everything.
i dont have mine on either and i have no popping of clicking except when a rock gets stuck in the tire
Reply With Quote
  #10  
Old 04-25-2007
Member
 
Join Date: Apr 2007
Location: willoughby, oh
Posts: 36
my truck does the same thing...
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1999 front end conversion to a 2004 front end??? 01_Camaro_SS Exterior Semi-Tech 7 12-20-2016 06:00 PM
Nasty Noise from the rear end/ rear end acting weird stephen.g.fiddes Drivetrain Tech 30 05-02-2010 07:57 PM
Nasty Noise from the rear end/ rear end acting weird stephen.g.fiddes Drivetrain Tech 0 04-27-2010 06:33 PM
Front End Popping Noise FORZDA 2.9L & 3.0L V6 Tech 21 05-16-2005 02:47 AM
Front end noise... HELP!!!? TBarCYa Drivetrain Tech 9 02-01-2005 10:11 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 02:32 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.