Starting The BL Install - Ranger-Forums - The Ultimate Ford Ranger Resource


Suspension Tech General discussion of suspension for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-29-2005
Mason's Avatar
Member
Thread Starter
 
Join Date: May 2005
Location: New England
Posts: 95
Starting The BL Install

Got up this morning nice and early, to start the install. I had a buddy of mine come over to give me a hand. First thing we did was go through the parts list, and thats when **** hit the fan. I'm missing a good hand full of washers, nutz, and bolts. How crappy is that! So now I have to wait untill tomarrow afternoon to get a new kit. Guess I'll be starting friday morning.

~ Josh
Reply With Quote
  #2  
Old 06-29-2005
Shalafi49's Avatar
Member
 
Join Date: Jun 2004
Location: Altamonte Springs FL
Posts: 2,070
Poop
Reply With Quote
  #3  
Old 06-29-2005
gatorblue92's Avatar
RF Veteran
 
Join Date: Jun 2004
Location: Delaware
Posts: 8,238
sucks dude... hope you get it all soon
Reply With Quote
  #4  
Old 06-29-2005
zabeard's Avatar
who?
iTrader: (8)
 
Join Date: Nov 2004
Location: IN
Posts: 26,045
sorry to hear about that, i guess they do that alot.
Reply With Quote
  #5  
Old 06-29-2005
Member
 
Join Date: Nov 2004
Location: Danville, VA
Posts: 2,664
crappo

make sure to take pics, maybe u and someone else can make a great "how to" about this...i'd love to see it in action! i mite go with a BL, but i'm too nervous about unbolting everything.
Reply With Quote
  #6  
Old 06-29-2005
HighRollerII's Avatar
RF Veteran
iTrader: (4)
 
Join Date: Jun 2004
Location: Charleston, SC
Posts: 10,066
ouch that sucks..hope u get ur stuff straight and get some pics goin
Reply With Quote
  #7  
Old 06-29-2005
got-dirty's Avatar
Member
 
Join Date: May 2005
Location: Sliding in the skreets
Posts: 3,829
best HowTo ive found out there. very informative.
Reply With Quote
  #8  
Old 06-29-2005
a311fanam's Avatar
Member
 
Join Date: Dec 2004
Location: Westerly, RI
Posts: 2,006
Quote:
Originally Posted by Mason
Got up this morning nice and early, to start the install. I had a buddy of mine come over to give me a hand. First thing we did was go through the parts list, and thats when **** hit the fan. I'm missing a good hand full of washers, nutz, and bolts. How crappy is that! So now I have to wait untill tomarrow afternoon to get a new kit. Guess I'll be starting friday morning.

~ Josh
What kind of truck do u have? We are having a Meet on July 9th, and its gonna be a trail ride in CT. let me know if your trucks done, and if ya wanna join
Reply With Quote
  #9  
Old 06-29-2005
Member
iTrader: (1)
 
Join Date: Mar 2005
Location: Acworth, GA
Posts: 2,099
The how-to comes with the kit...it's called instructions...am i right?
Reply With Quote
  #10  
Old 06-29-2005
got-dirty's Avatar
Member
 
Join Date: May 2005
Location: Sliding in the skreets
Posts: 3,829
yea, but the only pictures on the instructions are in black and white, and its only of the brackets for the bumpers. Having the howto above, shows you were the lil things go, and some other things that are kinda tuff to work out.
Reply With Quote
  #11  
Old 06-29-2005
Member
iTrader: (1)
 
Join Date: Mar 2005
Location: Acworth, GA
Posts: 2,099
I like figuring things out i don't like being walked through things.
Reply With Quote
  #12  
Old 06-29-2005
rangererv's Avatar
Member
 
Join Date: Mar 2005
Location: Dearborn Michigan
Posts: 4,376
at least you didnt start then realize you are missing parts....There is always a good side to everything.

still sux tho
Reply With Quote
  #13  
Old 06-29-2005
Member
iTrader: (1)
 
Join Date: Mar 2005
Location: Acworth, GA
Posts: 2,099
Ya i did mine up at work, so if i was missing bolts i could walk 50 ft to parts and get some .
Reply With Quote
  #14  
Old 06-30-2005
Member
 
Join Date: Apr 2005
Location: Cleburne, Texas
Posts: 187
I just did mine tover the last three days by myself. What a B$#%@ . I didnt understand a couple things though. Like my gas tank filler didnt need to be extended???? It was long enough and isnt creased anywhere. THe only thing i have left to do is finish tightening the cab mounts. I cant figure out how to tighten the ones in the floor board. oh well i guess i'll figure it out tomrrow.
Reply With Quote
  #15  
Old 06-30-2005
Mason's Avatar
Member
Thread Starter
 
Join Date: May 2005
Location: New England
Posts: 95
True at least I wasn't half-way done with and then relize I was missing a **** load of parts. The instructions are pretty good, pics are a little small/fuzzy but I'll figure it out I think. I'll take a ton of pics.

Trail ride in CT on the 9th would be sweet but I'm going to New Hampshire that weekend. Where in CT are you going trail riding?

~Josh
Reply With Quote
  #16  
Old 06-30-2005
a311fanam's Avatar
Member
 
Join Date: Dec 2004
Location: Westerly, RI
Posts: 2,006
Quote:
Originally Posted by Mason
Trail ride in CT on the 9th would be sweet but I'm going to New Hampshire that weekend. Where in CT are you going trail riding?

~Josh
I dunno where the trails are, but they are somewhere in Voluntown CT, close to foxwoods casino
Reply With Quote
  #17  
Old 08-12-2005
RockysFord's Avatar
Member
 
Join Date: May 2005
Location: Columbus Ohio
Posts: 2,782
On my body lifted ranger, in the winter, when i pump my gas..sometimes it burps it back out....i thought it was the extension they put in for the BL, but its the same set up as in the how to picture....what else can it be??? It doesnt do it in the summer, but im still cautious and hold a rag around the pump...it ate the clearcoat off, not flaking or anything, but its not shiny anymore, i waxed it up so its not that bad now, but i dotn want it to happen this winter again...any suggestions?? The pump will shut off when it goes in to fast, like its full...but its not ....and it will spit it back out...

Rocky
Reply With Quote
  #18  
Old 08-12-2005
zabeard's Avatar
who?
iTrader: (8)
 
Join Date: Nov 2004
Location: IN
Posts: 26,045
i got no idea but you might get a better response if start a new thread...
Reply With Quote
  #19  
Old 08-12-2005
dangerranger's Avatar
Member
 
Join Date: Aug 2005
Location: muskego, wi
Posts: 536
what company did you buy your body lift through i dont want the same thing to happen when i get mine
Reply With Quote
  #20  
Old 08-12-2005
zabeard's Avatar
who?
iTrader: (8)
 
Join Date: Nov 2004
Location: IN
Posts: 26,045
if it happens, call them, they will send the right parts. it happens all the time with companies, if the company is a good one they will get you the parts and apoligize.

he is talking about the Performance Accesories Body lift. i got mine and all the parts were there, so its a hit and miss. beforeyou start make sure you have all the parts..
Reply With Quote
  #21  
Old 08-12-2005
Member
iTrader: (1)
 
Join Date: Mar 2005
Location: Acworth, GA
Posts: 2,099
My guess is the rubber extension hose is not on the metal pipe far enough so when you installed it the rubber pipe has almost a crimp in it from it being too long. That way when you fill it up with the pump wide open, the hose can't flow fast enough and the nozzle is getting too much pressure/fumes however they measure it and shutting off and the excess fuel going into the hose to fast is flowing out.
Reply With Quote
  #22  
Old 08-15-2005
RockysFord's Avatar
Member
 
Join Date: May 2005
Location: Columbus Ohio
Posts: 2,782
Thats the same thing i thought....but one day i dropped the tank, and had another hose, it ended up being the wrong size, but i messed around with the metal tube, and there isnt a kink in it, and it should flow through good, i moved the rubber some so there wasnt a way for the gas to hit that, and build up and come back out...but im not sure, i wanted to just get a new hose, that was long enough, to eliminate that extension...but i cant figure out what size it is...and no one carrys that big of a fuel hose....i bought my truck with the body lift, so im not sure who did it...but thats whats happening....it doesnt do it when its hott though...

PS , not stealing your thread, just figured since it had to do with BL problems i would get some help on mine...
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
horrible starting, revs up after starting. smokindmax SOHC - 2.3L & 2.5L Lima Engines 5 09-01-2009 11:33 AM
Flooding when starting k.blakeley 4.0L OHV & SOHC V6 Tech 4 02-22-2009 04:14 PM
starting to plan out my next box... Strider0O0 Audio & Video Tech 38 04-08-2005 01:15 PM
2004 Not starting Tyrant924 General Technical & Electrical 32 12-07-2004 10:02 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 08:21 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.