Got a wee bit of a problem. - Ranger-Forums - The Ultimate Ford Ranger Resource


Wheels & Tires Semi-Tech General discussion of wheels and tires for the Ford Ranger.
Sponsored by:
Sponsored by:

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 09-24-2010
Nckdula's Avatar
Member
Thread Starter
 
Join Date: Sep 2010
Location: West Jordan UT
Posts: 178
Got a wee bit of a problem.

Ok here it goes
I was taking lug nuts off 1 by 1 to clean them with chrome cleaner, which by the way they now look like a chrome mirror, AWESOME!!!
But one lug nut on the rear pass side, well it seized up on me, as i was taking it off, so now it's stuck half way off and won't move anymore, and i afraid to put to much strength into to it, as it could bust the peg off.
So anyone here have the knowledge of what to do?

Thanks.
Reply With Quote
  #2  
Old 09-24-2010
fourliter dan's Avatar
Member
 
Join Date: Dec 2007
Location: Lebanon, OR
Posts: 2,229
try soaking it in pb blaster and let it sit over night or for a few hours. if it still isnt becoming easier, just keep going on it, if it breaks it breaks, wheel studs are cheap
Reply With Quote
  #3  
Old 09-24-2010
darangerdanger's Avatar
Member
iTrader: (1)
 
Join Date: Aug 2010
Location: scappoose.oregon
Posts: 1,169
hate to tell ya but the damage is already done most likely. safety wise you're still ok but you will need to replace the entire stud and get a new lugnut

you can try wd-40/plp/or any other penetrant oil you MIGHT get lucky. if you are that lucky make sure you use some brake clean to get all the oil off or the lugnut will work itself off after you put it back on
Reply With Quote
  #4  
Old 09-24-2010
Fx4wannabe01's Avatar
RF Veteran
iTrader: (23)
 
Join Date: May 2005
Location: Boring, Oregon
Posts: 21,721
use a powertool like an air or electric impact wrench and get the lug off. The damage is already done. The wheel stud likely needs replaced anyhow. Plus it's not doing anything being half way threaded on. Running with 4 lugs is a no biggie....good to go til you can get a new wheel stud or new lug tossed on.
Reply With Quote
  #5  
Old 09-25-2010
Nckdula's Avatar
Member
Thread Starter
 
Join Date: Sep 2010
Location: West Jordan UT
Posts: 178
Well thanks for all the help people.
I used PB blaster, but the issue was they were cross threaded, so i just have to by a new lug nut and a new peg and I'm good.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
just a bit of the stuff ive got finished pics! 03RangerInROC Snapshots 16 07-29-2009 04:03 PM
Got bit by the full size bug! rangerboy101 Snapshots 26 06-05-2009 11:36 PM
A little bit of This, And A little bit of That Crein2009 General Ford Ranger Discussion 6 05-24-2009 11:42 PM
bit of problem with shock mounting seth556 Suspension Tech 11 04-22-2009 03:42 PM
done a wee bit-o-smokin today trucks423 Exterior Semi-Tech 24 02-19-2009 06:00 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 11:27 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.