Very strange loss of low end power... - Ranger-Forums - The Ultimate Ford Ranger Resource
Ford Ranger Forum - Forums for Ford Ranger enthusiast!

Go Back   Ranger-Forums - The Ultimate Ford Ranger Resource Arrow Ranger-Forums Technical Engine Forum Arrow 4.0L OHV & SOHC V6 Tech

4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

LinkBack Thread Tools Search this Thread
Old 06-25-2012
Thread Starter

I am: Jackson Nuggs
Join Date: May 2010
Location: Madison
Vehicle: 2004 Ford ranger
Posts: 347
Total Props: 6
Very strange loss of low end power...

Last week, I was cruising on the highway, probably close to 80 mph. While merging into another lane, right as I was accelerating at pretty high rpm's, some chick from another lane turned into my lane like a foot in front of me. I had to pull some evasive manuevers to avoid a bloody demise for me and my ranger, very scary.

Now to the point:

Within seconds of that near accident, I noticed all my lowend power was gone, I had to punch it to get up to speed. I actually thought my truck was broke for a second! After parking/turning off the truck a few times it got better.

A few days ago I had my battery unplugged while I was installing my amp and sub. After plugging it back in, I noticed my truck had all its power back...i was like "Holy **** thats how she used to be....thats more like it " lol.

So what could cause this strange behavoir in my truck???? Is it possible for a code to get thrown in the ECU that robs the engine of power??

Please any suggestions are helpful...and thanks for reading.

2004 4x4, ex-fleet vehicle. 4.0 v6 with 110 k, 4.10 gears.
Modifications: Whelan hidden strobes, Ion 174 alloys, yokohama geolander at 235s, billet grille, airbox mod, Dynomax exhaust. slight torsion crank. More to come!!
Reply With Quote
+ 0 -
Old 06-26-2012
I am: Jon Silv
Join Date: Jun 2012
Location: Rhode Island
Vehicle: 96 Ford Ranger Splash 32s
Posts: 34
Total Props: -3
might sound dumb but maybe the battery isn't giving it enough power or maybe the alternator
Reply With Quote
+ 0 -

Similar Threads
Thread Thread Starter Forum Replies Last Post
2000 Ranger, Very Poor Mileage, Low Power, Dies Constantly, HELP! Scott586 SOHC - 2.3L & 2.5L Lima Engines 5 12-14-2012 02:19 PM
Strange intermittent electrical power loss Dangerranger01 General Technical & Electrical 3 06-08-2012 10:54 PM
LOW LOW LOW RPMS JRacer 4.0L OHV & SOHC V6 Tech 23 05-06-2009 11:25 PM
HELP - tranny problems! Strange rattling and very HOT to touch aweiss2k Drivetrain Tech 13 04-21-2006 08:28 AM
Very Strange Light Picture 0RangerEdge2 General Technical & Electrical 13 07-05-2005 03:28 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -6. The time now is 04:57 PM.