ENGINE sputtering sometimes stalls. - Ranger-Forums - The Ultimate Ford Ranger Resource


2.3L & 2.5L I4 Tech General discussion of 2.3L and 2.5L I4 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-02-2010
Member
Thread Starter
 
Join Date: Jan 2007
Location: GRANADA HILLS
Posts: 52
ENGINE sputtering sometimes stalls.

I have a 2001 2.3L 5 speed. My truck has been sputtering at low rpms.(u know, like at 1st gear mainly) every other week it will stall at a red light. I had a check engine and my mechanic said it was a misfire in cylinder 3.
So i changed the wires, and the plus.
He said the injector was bad, and replaced it.
But that didnt change ****. Im pissed. Im thinking a fuel filter or fuel pump sice my car dies out occasionally. (??) He friggin thinks i need a new valve in cylinder 3 which would cost $1200.

please help.
Reply With Quote
  #2  
Old 06-03-2010
Member
Thread Starter
 
Join Date: Jan 2007
Location: GRANADA HILLS
Posts: 52
BUMP.?
EDIT. It only stalls like once every other week. any help would be appreciated
Reply With Quote
  #3  
Old 06-03-2010
Black1987's Avatar
Member
 
Join Date: Jan 2010
Location: clinton twp, michigan
Posts: 352
U have a seated valve. That's wat just happened to my 2.3 with the same exact symptoms. And I only have 125,000 miles. And the only way to fix it is rebulid the head or get a new head.
Reply With Quote
  #4  
Old 06-03-2010
Member
Thread Starter
 
Join Date: Jan 2007
Location: GRANADA HILLS
Posts: 52
not good. how much did u pay?
Reply With Quote
  #5  
Old 06-03-2010
Black1987's Avatar
Member
 
Join Date: Jan 2010
Location: clinton twp, michigan
Posts: 352
I was quoted $700 for all the gaskets and new head by my dads friend who works on exotics for a living. I'm just going to baby my truck till it blows up
Reply With Quote
  #6  
Old 06-03-2010
Member
Thread Starter
 
Join Date: Jan 2007
Location: GRANADA HILLS
Posts: 52
thats a really good price. How long have u been driving it messed up for? cause im going on 2 months. it runs strong minus a lil sputtering.
Reply With Quote
  #7  
Old 06-03-2010
Black1987's Avatar
Member
 
Join Date: Jan 2010
Location: clinton twp, michigan
Posts: 352
3 weeks to a month. But mine does it mostly when I'm at crusing speed and then it starts to missfire the on the rare occasion a backfire. And when it first starts it wants to stall out
Reply With Quote
  #8  
Old 06-03-2010
Member
Thread Starter
 
Join Date: Jan 2007
Location: GRANADA HILLS
Posts: 52
IM trying to make sure it is my valve. cause if its a fuel pump or something else, id save a bunch of money. Its funny cause sometimes it runs good for like a few minutes. Like yesterday when the mechanic changed the fuel injectorit ran perfect. I parked the car then went to the store and it started jumping agin . arrghh
Reply With Quote
  #9  
Old 06-03-2010
Black1987's Avatar
Member
 
Join Date: Jan 2010
Location: clinton twp, michigan
Posts: 352
That's the same with me. It ran perfect to school this morning but when I went yo drive home it ran terrible
Reply With Quote
  #10  
Old 06-03-2010
Black1987's Avatar
Member
 
Join Date: Jan 2010
Location: clinton twp, michigan
Posts: 352
I was told by 3 of the 5 ford mechanics I asked, and they all think that it's my valve.
Reply With Quote
  #11  
Old 06-06-2010
Member
Thread Starter
 
Join Date: Jan 2007
Location: GRANADA HILLS
Posts: 52
UPDATE

So today my dad stopped by to try to figure out whats wrong with my truck. I told him it was sputtering mailnly at low rpms. So we went to the coil and unplugged each wire one by one. Ech one was firing till we got to the wire that leads to cylinder 1. NO SPARK. ( got damn mechanics tryin to rip me off :))
so i need a new coil?
Reply With Quote
  #12  
Old 06-11-2010
Member
Thread Starter
 
Join Date: Jan 2007
Location: GRANADA HILLS
Posts: 52
GOOD NEWS

Hey black 1987, i figured out the problem myself. it turned out to be a bad coil. it was not firing out of 1 cylinder. Got A new one for $25 shipped the next day off ebay. Works perfect!!!!

Head up for any who may be reading this. Cause i trusted my mechanic as i have been going to him for years. He said it was the valve and would cost $1200. I said, "i went to a ford ranger forum, and everyone was telling me to check the coil, plugs, wire, ignition." He said it wasnt my coil but didnt even check it for spraks.

BOTTOM LINE: iTS good to have a site like this.
Reply With Quote
  #13  
Old 06-14-2010
Member
 
Join Date: Dec 2009
Location: Kirkland, WA
Posts: 71
Nice!
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1995 E350 stalls while idling... this truck NEVER stalls. Ever..??? FMD General Ford Discussion 1 10-31-2016 02:53 AM
Engine Sputtering. (I know, Another thread...) Hellion SOHC - 2.3L & 2.5L Lima Engines 67 06-20-2014 03:44 PM
Sputtering engine problems rickydanger 4.0L OHV & SOHC V6 Tech 10 06-14-2011 10:36 PM
Engine sputtering i_love_paintbal 2.9L & 3.0L V6 Tech 1 04-16-2009 08:39 PM
Engine Stalls JKFTerry 4.0L OHV & SOHC V6 Tech 4 11-17-2006 09:20 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 05:53 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.