03 RANGER-Air Cond Not Working - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-12-2010
Member
Thread Starter
 
Join Date: Mar 2008
Location: Reno
Posts: 14
03 RANGER-Air Cond Not Working

Hi guys:

As the 03 Ranger (6 cyl) isn't that old and is kept up pretty well, I was just wondering if there is a simple, easy reason that our air conditioning isn't working. It was fine last Summer, then Winter, now it's no-go. Is there something easy I can check? Just want to avoid getting nailed by a shop.

Thanks!
Reply With Quote
  #2  
Old 04-12-2010
filmont's Avatar
Member
 
Join Date: Dec 2008
Location: Bellbrook, OH
Posts: 205
Check your fuses? Loose belts? Possible a/c leak? Could also check the HVAC controls. That's about all I've got for a/c work.
Reply With Quote
  #3  
Old 04-12-2010
dbp02's Avatar
Member
 
Join Date: Feb 2010
Location: Pittsburgh
Posts: 147
First and easiest thing would be to check if there is refrigerant in the system. You can use a gauge to do that or just open up the cap on the AC line and stick a pen on the schrader valve for a brief instant and see if you have pressure blowing out. Note that discharging R134-A into the atmosphere is probably illegal and you could be subject to fines if you decide to do it that way (not that it is actually any more harmful than hairspray, just saying).

If it does have pressure, then you need to check to make sure it's getting power and all that to the compressor, etc.
Reply With Quote
  #4  
Old 04-13-2010
blueranger789's Avatar
Member
 
Join Date: Mar 2009
Location: Boiling Springs, SC
Posts: 619
if none of the above suggestions work, check your relay, thats what happened on mine, switch the relay with one from another position, if the ac works, go buy another relay
Reply With Quote
  #5  
Old 04-14-2010
Member
Thread Starter
 
Join Date: Mar 2008
Location: Reno
Posts: 14
The solve was the relay (fuse 47A). Switched it with 47B (Wiper pump) and the A/C came back on.
Thanks for the help guys.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Ranger not charging and chime not working jfoster2505 General Technical & Electrical 3 02-14-2012 08:23 PM
1996 air conditioner not working right! branmala1986 SOHC - 2.3L & 2.5L Lima Engines 1 05-08-2010 06:37 AM
For Sale: 2005 Honda trx450r in exc. cond. $3,650 (PA.) RANGER1974 Miscellaneous Items 0 08-17-2009 06:16 PM
air/fuel gauge not working wckdfx4 General Technical & Electrical 17 12-31-2007 05:20 PM
Air-Cond clicks on and off - ALOT tj2245wz General Ford Ranger Discussion 2 09-10-2007 12:48 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 05:47 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.