1994 Mazda B3000 4x4 SE knocking noise - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-28-2007
Member
Thread Starter
 
Join Date: Aug 2007
Location: Trenotn
Posts: 10
1994 Mazda B3000 4x4 SE knocking noise

Hello guys, I'm a new member just joined and have a problem with my recently bought truck.

Its a 1994 Mazda B3000 4x4 SE manual. When I first bought it couple weeks ago I had no problems what so ever, I thought with 260 000 kms a tune up would be good so I brought it into the local ford dealer and the did a front end aliment and trany flush. I got it back and after I noticed a leak in the water pump gasket and a knocking noise so I replaced the water pump and the noise continues. Now it takes awhile for the knocking to start maybe 5 - 10 mins from a cold motor to it warms up and will knock until I'm at a dead stop and continue knocking when I start to move again. It has new oil and oil filter, and everything looks right anyone have any idea as to what the problem is also is it normal for my oil pressure gauge to go all the way to the low point when I'm off the gas and back to normal when I'm on the gas

Thanks Jordan
Reply With Quote
  #2  
Old 08-28-2007
Level I Supporter
 
Join Date: Aug 2006
Location: Durham, NC
Posts: 3,657
The oil pressure gauge does not show actual oil pressure. The sending unit is a normally open switch, that closes with about 7PSI of oil pressure. When the switch closes, the gauge goes to about the middle, and drops to zero
when the switch opens. I would try a mechanical (or wet) guage to see what your oil pressure is actually doing. You didn't use a Fram oil filter by any chance did you?
Reply With Quote
  #3  
Old 08-28-2007
Member
Thread Starter
 
Join Date: Aug 2007
Location: Trenotn
Posts: 10
Yes i used a Fram oil filter from candian tire is this possible why my motor is knocking ??
Reply With Quote
  #4  
Old 08-28-2007
LowMaz's Avatar
Member
 
Join Date: Feb 2007
Location: Sterling/ Amherst, MA
Posts: 788
yea, dont use fram. use a motorcraft filter or a mobil 1
Reply With Quote
  #5  
Old 08-29-2007
Member
Thread Starter
 
Join Date: Aug 2007
Location: Trenotn
Posts: 10
Oh whats is the problem with Fram filters ? And what could it have possible done to my motor is it is the cause
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2002 mazda b3000 (ford ranger) tekin 2.9L & 3.0L V6 Tech 7 09-22-2011 08:36 PM
Mazda B3000 Lift. HELP!!!! whood91 Suspension Tech 1 08-25-2011 04:11 PM
1994 B3000 Steering Help!!!! Please 94B3000 Suspension Tech 0 04-04-2011 09:57 PM
94 mazda b3000 v8 swap tattooguy2308 Member Introductions 24 01-19-2010 08:37 PM
Mazda B3000 TrucksGetDirty Snapshots 23 06-05-2008 01:49 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 01:19 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.