2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

1999 4x4 shakes at 74+ mph on the highway, what gives???

  #1  
Old 04-07-2008
LuckyRanger13's Avatar
Member
Thread Starter
iTrader: (1)
Join Date: Nov 2007
Location: Santa Fe, TN
Posts: 554
1999 4x4 shakes at 74+ mph on the highway, what gives???

I drive a stock 4x4 1999 3.0L ext cab Ranger, I have stock rims with 16" Wrangler Silent Armors on them. Very nice tire btw, but anyhow, when on the highway my truck shakes at 74+. It's gets kinda bad and to the point where it's scary. When around 80 the vibrations ease off a litte bit.

Question is what gives? Why is the shake so bad? I know I have a good amount of weight on the front due to the 4x4 system, but should it be this bad? I just had new rotors put on not too long ago, so that's probably not it.

Any of ya'll got the same problem? I need help.
 
  #2  
Old 04-07-2008
My91Ranger's Avatar
Member
iTrader: (1)
Join Date: Apr 2007
Location: Roseville, Michigan
Posts: 2,254
Sounds like drive train vibrations. First thing I would check is your u-joints, see if there is any play in the drive shaft, they are one of the most common parts to wear and cause a vibration like that.
 
  #3  
Old 04-07-2008
Level III Supporter
iTrader: (2)
Join Date: Jun 2004
Location: usa
Posts: 24,936
u-joints, also get the tires balanced.
 
  #4  
Old 04-07-2008
n3elz's Avatar
RF Veteran
Join Date: Jun 2004
Location: Kennett Square, PA
Posts: 10,623
It means your truck is scared to go that fast. Find out what it knows that you don't!
 
  #5  
Old 04-14-2008
LuckyRanger13's Avatar
Member
Thread Starter
iTrader: (1)
Join Date: Nov 2007
Location: Santa Fe, TN
Posts: 554
I had the strange feeling it didn't like that speed either.....prolly scares the poor guy.

I do know one thing, I have to have a lower-end overhaul done. Something about something is causing it to wear in an oval shape causing it to cause the rear main seal to leak. I've gotta have the tranny pulled and all that and the seal replaced after you take off the flywheel and all that fun stuff. The brass bearings or something is being eat up as you can see fine glitter flakes in the oil when you let the oil filter drain. That and my valve sleeve(s)? is also worn out. You can here it chatter when it idles.
As you can see my dad told me all this fun stuff, I just don't remember his exact words. But hey, I'm a learning.

When all this is being done, I'll also have him check the U joints.
 

Last edited by LuckyRanger13; 04-14-2008 at 10:00 AM. Reason: misnamed the rear seal
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
joedyflakes
General Technical & Electrical
27
01-04-2014 12:59 AM
Tys 4x4 FTW
General Ford Ranger Discussion
19
10-28-2008 02:35 PM
Urandaman
Auto Detailing 101
9
03-28-2008 05:10 AM
Roach2004
Suspension Tech
59
08-31-2005 01:21 AM


Thread Tools
Search this Thread
Quick Reply: 1999 4x4 shakes at 74+ mph on the highway, what gives???


Contact Us - Sitemap - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.