2006 3.0 Ranger runs bad after shutting off then re-starting - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-08-2014
Member
Thread Starter
 
Join Date: Jul 2014
Location: DELPHI
Posts: 2
2006 3.0 Ranger runs bad after shutting off then re-starting

Hello,
I have a 2006 Ranger with a 3.0 engine. It starts up fine when the engine is cold, but if i shut it off then restart it, the engine runs rough, wont produce hardly any power and the check engine light blinks. The check engine light has been on for a few months now and no one can seem to pull any codes from it. Might be shorted out somewhere. The guys at the local Ford dealership thought it might be bad spark plugs so I replaced them along with the wires. It didn't fix the problem. I have replaced the temperature sender as well. I checked the coil using the method from this video
and it checks out fine. Any suggestions?
Thank you.
Reply With Quote
  #2  
Old 07-09-2014
Member
 
Join Date: May 2014
Location: MCKENZIE
Posts: 33
Pull and clean your IAC valve
Reply With Quote
  #3  
Old 07-13-2014
Member
Thread Starter
 
Join Date: Jul 2014
Location: DELPHI
Posts: 2
Quote:
Originally Posted by jdbeck38201 View Post
Pull and clean your IAC valve
I pulled it and cleaned it. It did seem to improve the idle. Time will tell if this is what was wrong. Thank you jdbeck38201 for the suggestion.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
'88 Ranger runs 2-5 seconds then stalls JBilly 2.9L & 3.0L V6 Tech 2 12-19-2014 10:14 AM
Loud clunking noise after shutting the truck off littlered General Ford Ranger Discussion 1 08-29-2013 11:06 AM
sparks and fire after shutting off littlered General Technical & Electrical 5 11-05-2012 06:29 PM
Speakers shutting off Shaklakan Audio & Video Tech 3 07-25-2008 10:45 AM
Thumpimg sound when at a stop or after shutting truck off jtfoxman 4.0L OHV & SOHC V6 Tech 2 12-13-2007 08:54 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 05:39 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.