3.0 guys need your help - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 05-15-2007
Member
Thread Starter
 
Join Date: Apr 2007
Location: Grafton, Va
Posts: 10
3.0 guys need your help

I honestly wish i had never bought this truck a month ago. Its a 1999 ranger 3.0l v6 with a 5 speed. I have a few questions and I hope you can help me. Ive already put well over 1k into this pos.

1) I have a bad Idle, the truck shakes including the motor and shift ***. Ive replaced the wires and plugs, but It seems to actually have gotten a little worse. Any suggestions on stuff that goes bad? IAC or MA Sensor?

2) When i left off the clutch in 1st or 2nd, there is a really bad rattle. The ******* that sold me the truck said it was the heat shield and all rangers do this.. Somehow im doubting him.. Its a very rapid rattle, and it will continue after i let off the clutch until i bring up the rpms.

3) The truck has some terrible vibrations, and they get worse as the rpms climb..you can feel it in the clutch and gas pedal, as well as the shifter. Im at a loss on this one.

Ive replaced so far : Shocks, Wheel bearings, Serpantine belt, Ball joints, Plugs and wires, Breaks all within this month, and im living under the poverty line lol. YOu have no idea how depressed this truck makes me, cuz I took a loan out to get it, so im stuck with it. I really appreciate any help you guys can throw my way. Thanks!
Reply With Quote
  #2  
Old 05-15-2007
bwester04's Avatar
Member
 
Join Date: Mar 2006
Location: Round Rock, Tx
Posts: 2,641
does your truck have a tachometer? mine would make a "rattle" noise when/if the rpms got too low, and did it a lot when I let off the clutch into 1st and into 2nd gear sometimes.. have you changed the oil and air filter lately? those usually cause the engine to run a little rough, simple fix as well. I remember the 3.0L not being the smoothest of all engines but it would shake the shifter a bit and I assumed it to be normal.. so i dont think you have much in regards to that one.. just the nature of the 3.0L OHV.
Reply With Quote
  #3  
Old 05-15-2007
Member
 
Join Date: Feb 2007
Location: Midlothian, TX
Posts: 58
for the rattle i would check the u-joints on the drive shaft, or it may not be balanced. just a thought.
Reply With Quote
  #4  
Old 05-15-2007
Member
 
Join Date: Dec 2005
Location: Raleigh, NC
Posts: 248
i have a buddy with a 98, manual, 4 cyl ranger and his heat shield does rattle. and the rattle does get pretty darn loud. but i dont know about the shaking.
Reply With Quote
  #5  
Old 05-16-2007
krumm's Avatar
Member
 
Join Date: Jan 2006
Location: Wylie, TX/Raleigh, NC
Posts: 225
what is the mileage on the truck? Do a search on the forum for a product called Seafoam, it worked good on my 02 3.0 to get rid of the rough idle.
Reply With Quote
  #6  
Old 05-16-2007
Member
Thread Starter
 
Join Date: Apr 2007
Location: Grafton, Va
Posts: 10
Thanks for the responses guys. I do need to change the filter its pretty filthy, but i dont think it would cause it to be this bad. Those are some good tips for the rattle, and my mechanic is going to be looking at the U-Joints tomorrow. Hopefully everything will work out, and I guess for now ill just driver her till she dies, which wont be too long =)
Reply With Quote
  #7  
Old 05-16-2007
Member
Thread Starter
 
Join Date: Apr 2007
Location: Grafton, Va
Posts: 10
Also, My mechanic said they hate to use seafoam, because it may actually make things worse. But everyone on here seams to be using it with great results, It may be an option for me.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
HEY GUYS I NEED YOUR HELP PLEASE!!! TxRanger99 General Technical & Electrical 10 02-27-2015 02:06 PM
Need your guys help quick!!! Grumpy Drivetrain Tech 0 05-28-2011 05:25 PM
I need your guys help pronto tmilllz Exterior Semi-Tech 45 09-07-2010 09:34 PM
Guys With Expo 8.8 Need Your Help! RangerJacoby99 Suspension Tech 3 09-03-2009 07:42 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 11:02 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.