3.0L idling, then died. - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 01-07-2010
gbchilds's Avatar
Member
Thread Starter
 
Join Date: May 2008
Location: Pickens,SC
Posts: 4
3.0L idling, then died.

1992 3.0L Ford Ranger 2WD w/110,000mi.

Hey Folks!
My son's truck had died on him a couple of times over the last month, but it would always restart after a minute or so and then run perfectly. Last night, he was sitting at an intersection waiting to turn and the engine just cut off. This time it won't restart. It will turn over normally but won't fire. I checked all of the obvious stuff (gas?, oil?) and the coil module on top of the engine was replaced last year. Do these modules ever fail in this manner (cut off, restart, cut off, restart, cut off, death) or wouldn't they fail without warning? Last year, there was no warning, it just didn't start one day. Based on MOST electronic devices, it's usually GO or NO GO. No in-between. Has anyone had similar problems or symptoms in this area?

Any input, suggestions, help, or just plain 'ole wisecracks would be appreciated! The laughter would be a treat!

Thanks!
Reply With Quote
  #2  
Old 01-07-2010
My91Ranger's Avatar
Member
iTrader: (1)
 
Join Date: Apr 2007
Location: Roseville, Michigan
Posts: 2,252
I have had sporatic issues with a couple of ford ignition modules. They would cause problems randomly and not all the times. It is possible your are having a similar problem. If you suspect the ignition module you can test it with an Ohm meter. You could also pull a spark plug, ground it and crank to see if they are firing.
Reply With Quote
  #3  
Old 01-07-2010
gbchilds's Avatar
Member
Thread Starter
 
Join Date: May 2008
Location: Pickens,SC
Posts: 4
Thanks Rob. Where is the ignition module located on this particular engine? I had to pay someone to replace it the last time because I was out of town. I would like to have an idea of where I'm going so I'll know when I get there, if you know what I mean! Is it mounted on the firewall or distributor like some others? Thanks in advance!
Reply With Quote
  #4  
Old 01-25-2010
RedRanger91XLT's Avatar
Member
 
Join Date: May 2009
Location: Woodbridge, VA
Posts: 316
should be on the top of the engine near the firewall.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
New battery, then new alternator, then found broken wire... psvines General Technical & Electrical 1 01-01-2010 07:15 PM
Idling Rough and Rich Exhaust DefyBass SOHC - 2.3L & 2.5L Lima Engines 1 04-03-2007 02:18 PM
Engine overheated while idling!! bwester04 2.9L & 3.0L V6 Tech 20 10-17-2006 02:16 PM
Stumble when idling 2002 3.0 V6 jax 2.9L & 3.0L V6 Tech 7 05-02-2006 05:03 PM
Weird Idling HighRollerII 4.0L OHV & SOHC V6 Tech 18 10-28-2005 06:04 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 04:30 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.