Code 118, 157, and 176 - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-12-2012
Member
Thread Starter
 
Join Date: Mar 2012
Location: lancaster, wi
Posts: 10
Code 118, 157, and 176

HI. I just got my engine back together, new timing chain and gears, and new heads. It had a head gasket leak. Now it runs great, way more power than it is has since I have owned it. After driving it a couple of miles today the check engine light came on and I pulled the codes. I got 118, 157, and 176. Engine coolant temp sensor above max voltage, mass air flow sensor fault, low voltage, and HEGO sensor fault/always lean. Can the mass air flow sensor cause these other codes, or is there something I should be looking for. The oxygen sensors were both replaced about 2 years ago. The truck seems to be running fine. Thanks for any help.
Reply With Quote
  #2  
Old 04-12-2012
Member
Thread Starter
 
Join Date: Mar 2012
Location: lancaster, wi
Posts: 10
I cleaned the MAF sensor and cleared the codes then ran it again and now only the 176 code for the O2 sensor is coming up. I wouldn't think the sensor is bad, it is only a few years old and was fine before I did all the work to it.
Reply With Quote
  #3  
Old 04-13-2012
Member
iTrader: (1)
 
Join Date: Mar 2010
Location: Moreno Valley CA
Posts: 46
if the coolant was leaking for a while it will damage the o2 sensors fast
I would swap the sensor out
Reply With Quote
  #4  
Old 04-13-2012
Member
Thread Starter
 
Join Date: Mar 2012
Location: lancaster, wi
Posts: 10
It was losing a good bit of fluid before the head gasket replacement. I will try swapping the two sensors and see if the code is still there. I didn't think about water getting on it. Thanks for the advice.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Codes 172,173,176,177 shleeve 4.0L OHV & SOHC V6 Tech 6 07-10-2015 05:38 PM
Code 157 won't go away 93Pepe General Technical & Electrical 0 05-08-2012 06:33 PM
eBay / Craigslist Find: odd ranger seats EBAY 176 current bid dixie_boysles eBay & Craigslist Finds 7 08-05-2010 01:36 PM
check engine codes 173,176 graff104 2.9L & 3.0L V6 Tech 1 06-02-2009 12:44 PM
code 176 retrieved......HEGO (HO2S) SENSOR FAULT/RICH Jeremy102579 General Technical & Electrical 1 11-12-2006 01:52 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 06:42 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.