coincedence?? - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-12-2008
Member
Thread Starter
 
Join Date: Jun 2005
Location: Havertown,PA
Posts: 467
coincedence??

Hi guys/
I replaced my plugs today and gave an oil chavge.Went for test drive and temp gage went almost all the way hot then back to normal.
I dont think i could have done anything to cause that:just replacing plugs.It does this when starting cold.if engine is warm then just stays normal.Anyone else experince this?
Truck runs fine and no check engine.Used auto lite double platnums.
Reply With Quote
  #2  
Old 07-13-2008
Member
Thread Starter
 
Join Date: Jun 2005
Location: Havertown,PA
Posts: 467
any one??? was thinking changing tstat.But could it be fan clutch?
Reply With Quote
  #3  
Old 07-13-2008
Fx4wannabe01's Avatar
RF Veteran
iTrader: (23)
 
Join Date: May 2005
Location: Boring, Oregon
Posts: 21,721
your thermostat stickin?
Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 07:15 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.