electrical question - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-21-2009
Member
Thread Starter
 
Join Date: Mar 2007
Location: Hollywood,FL
Posts: 5
electrical question

just a quick few questions
2 weeks ago i but a new battery in my truck. i let it set for 2 weeks and when i go to start my truck its completly dead, not even my idiot lights came on, no sound no nothing. so i jump the car and get it running, and as soon as i remove the jumper cables my truck dies. so my questions are:

A: does this indicate that my alternator has taken a dump?(by little batttery looking idiot light is now on whereas it wasent before)
B: would that fact that my alternator has died prevent my truck from shifitng?(its an auto)

ANy input would be awsome. thanks for your time

98 Ranger 3.0 Auto
Reply With Quote
  #2  
Old 03-21-2009
Gallo75's Avatar
Member
 
Join Date: Sep 2008
Location: Mexicali Baja California,
Posts: 456
if you remove the jumper cables and the engine dies, then you got a bad alternator
jump start it, and get a reading with a voltmeter, you should be getting 13-14ish volts
Reply With Quote
  #3  
Old 03-21-2009
strakill's Avatar
Member
iTrader: (1)
 
Join Date: Jan 2009
Location: santa maria, Ca
Posts: 430
Replace the alt. And yes the auto trannys are electrical but that could be a whole other issue I would def start with the alt.
Reply With Quote
  #4  
Old 03-22-2009
Member
Thread Starter
 
Join Date: Mar 2007
Location: Hollywood,FL
Posts: 5
thanks for the replys yall. and yea, before my alt died i did have problems with my tranny. however i think it is a computer issue because it stoped shifting instantly, not over time.
Reply With Quote
  #5  
Old 03-22-2009
FireRanger's Avatar  
Join Date: May 2004
Location: CT
Posts: 0
I think the problem is the new battery. I think it is defective.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Electrical Question...... 281Thunder General Technical & Electrical 0 05-31-2009 12:31 AM
Electrical Question hammerjoe General Technical & Electrical 2 05-29-2009 07:53 PM
stupid electrical question... crawly1025 Exterior Semi-Tech 3 04-16-2009 12:59 PM
General electrical system question onebluemcm General Technical & Electrical 7 12-01-2007 08:12 PM
Electrical problem/question... HELP! Bob, anybody! rngprerunner General Technical & Electrical 11 09-25-2005 07:57 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 04:28 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.