Engine stumble and strange noise - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-08-2008
98WARanger's Avatar
Member
Thread Starter
 
Join Date: Jan 2008
Location: Washington State
Posts: 87
Engine stumble and strange noise

I started my truck a 1998 V6 3.0 Ranger up today and the engine stumbled a bit differently than normal. During my five to six mile drive to work it seemed less powerful and less responsive while adding throttle and seemed to make a funny whining or moaning sound that seemed to connect with how much the pedal is pushed. As I add more gas the noise seems to whine higher. Does this make sense to anyone? Can anyone help me?

When I drove home from work the same thing happened with the whining and the lack of power, but the engine didn't stumble when first started up.

Please help me!

Thanks,

Cory
Reply With Quote
  #2  
Old 10-08-2008
pacodiablo's Avatar
Member
 
Join Date: Jun 2004
Location: Charlotte, NC
Posts: 1,126
Does the oil pressure gauge do anything? Is there a check engine light?

Poor performance and rough idle can be an indicator of the cam syncronizer taking a dump. It will often set off a CEL too. A chirping noise can sometimes be heard when they start to go bad.
Reply With Quote
  #3  
Old 10-08-2008
98WARanger's Avatar
Member
Thread Starter
 
Join Date: Jan 2008
Location: Washington State
Posts: 87
There isn't a check engine light on, and the oil pressure (on the stock indicator) doesn't show any difference than usually. The noise isn't a chirp it's more of a whirl or a whine. Not as high pitch or loud as a chirp would be. Almost sounds like it's blowing or sucking air.
Anyone else have any suggestions. How can I check the Cam snychronizer just in case?

Thanks!
Reply With Quote
  #4  
Old 10-12-2009
Member
 
Join Date: Oct 2009
Location: Beaufort, NC
Posts: 4
i have a 2004 edge that makes the same whirling noise when you accelrate mine has 41,000 miles on it, I replaced the idler pulley, and tuned it up, same noise. it quites down when your driving down the road, just hear the whirling noise when I accelarate
Reply With Quote
  #5  
Old 10-15-2009
RedRanger91XLT's Avatar
Member
 
Join Date: May 2009
Location: Woodbridge, VA
Posts: 316
Does it have an electronic EGR?
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
stumble at startup staracaster 2.9L & 3.0L V6 Tech 0 06-10-2014 07:28 AM
Stumble at idle Primer88 SOHC - 2.3L & 2.5L Lima Engines 7 08-22-2011 09:24 PM
Engine stumble when in park or neutral JK1022 4.0L OHV & SOHC V6 Tech 8 04-25-2008 08:27 PM
Low rpm stumble NVR2FST 4.0L OHV & SOHC V6 Tech 4 12-19-2007 12:59 AM
Stumble when idling 2002 3.0 V6 jax 2.9L & 3.0L V6 Tech 7 05-02-2006 05:03 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 01:27 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.