Having trouble starting my truck - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-20-2007
volcompro11's Avatar
Member
Thread Starter
 
Join Date: Jul 2006
Location: Portland, OR
Posts: 70
Having trouble starting my truck

About a month ago my truck starting having trouble starting.... whats been happening is It'll crank over for about 10-20 seconds before fireing. When it finally does it'll idle between 100 & 500 rmp for about 5 seconds & feels like it just wants to die. It's pretty freakin annoying.... I've changed the plugs & wires, could it be the coil? I'm guessing it's somewhere in the ignition system, but I just don't know where to go next..
Reply With Quote
  #2  
Old 10-20-2007
SouthernMudSlinger's Avatar
Member
 
Join Date: Aug 2006
Location: Demorest,Ga
Posts: 1,724
It may not be getting enough gas. Have you ever replaced the fuel filter? If you are getting spark at the plug during the time it wont start, its most likely a fuel related problem. You also may not be getting enough fuel pressure.

Last edited by SouthernMudSlinger; 10-20-2007 at 11:55 AM.
Reply With Quote
  #3  
Old 10-20-2007
pushdeck's Avatar
Member
 
Join Date: Oct 2005
Location: Melbourne, FL
Posts: 217
Change the fuel filter, under 10 bucks from wally world, if that does not work it is probably your fuel pump, which you can get a tool to test before going to the hassle of putting a new pump in.......
Reply With Quote
  #4  
Old 10-21-2007
volcompro11's Avatar
Member
Thread Starter
 
Join Date: Jul 2006
Location: Portland, OR
Posts: 70
cool, i'll change out the filter tomorrow, I checked it out today & it looks like the original's still in there. So i'll do that, fuel filters are pretty cheap anyway
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Help having trouble starting pdanowski SOHC - 2.3L & 2.5L Lima Engines 3 01-03-2014 07:57 AM
Having trouble starting Auto 2.9L & 3.0L V6 Tech 2 01-24-2010 01:39 PM
Having trouble starting my truck redlinerick86 2.3L & 2.5L I4 Tech 9 03-18-2008 03:41 PM
Level II Bilsteins... having trouble installing ThatGuy Suspension Tech 6 06-16-2005 10:01 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 05:19 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.