HELP - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 05-03-2010
kiss's Avatar
Member
Thread Starter
 
Join Date: Nov 2005
Location: canada
Posts: 42
HELP

hi. i am having trouble with my 2003 3.0 starting. it happened all of a sudden. it wont start on first crank unless i let it crank a few times. but if i cycle the key to let the fuel pump a few times then crank it it will start. i replaced the fuel filter and checked the fuel pressure. i am getting 43 lbs on key turned to run and 57-60 lbs on run. checking it on the schrader valve. i have recentley replaced the coil pack. but other then that nothing. what do you think could be the problem. a few people have said it's the fuel pump but i would like to know why i have enough pressure but still could be pump. also i have changed the fuel pump relay just to see if that is the issue. please help.
Reply With Quote
  #2  
Old 05-03-2010
d0sitmatr's Avatar
Member
iTrader: (2)
 
Join Date: Jan 2010
Location: SFL
Posts: 706
did you also change the plugs n wires ?
Reply With Quote
  #3  
Old 05-03-2010
kiss's Avatar
Member
Thread Starter
 
Join Date: Nov 2005
Location: canada
Posts: 42
the plugs were replaced about 20k ago but i pulled them all and checked them. and wires were replaced about 50k ago. how i get it to start right is by letting the fuel pump turn on and cut out 3 times then it starts no prob. has anyone ever had a fuel pump take a dump.
Reply With Quote
  #4  
Old 05-03-2010
d0sitmatr's Avatar
Member
iTrader: (2)
 
Join Date: Jan 2010
Location: SFL
Posts: 706
Im not sure, but I think I remember reading there are 2 pumps, one on the tank itself as well as one inline of the fuel delivery system.
if so, then its possible the pump on the tank itself is bad which is why the 3crank.
Reply With Quote
  #5  
Old 05-04-2010
Robin Hood's Avatar
Member
iTrader: (2)
 
Join Date: Aug 2008
Location: AZ
Posts: 789
when you check the fuel pressure. did you start it and then shut it off and see if pressure instantly dropped? if it instantly drops you need a new pump because its not holding the pressure.

will it start right away after it was running for a while?
Reply With Quote
  #6  
Old 05-04-2010
kiss's Avatar
Member
Thread Starter
 
Join Date: Nov 2005
Location: canada
Posts: 42
No it will not start after running. I still have to turn the key ahead a couple of times to let the fuel pump cut in for it to start properly. Even if I just shut it off and try to start it again. Do you think this could be the pump?
Reply With Quote
  #7  
Old 05-04-2010
d0sitmatr's Avatar
Member
iTrader: (2)
 
Join Date: Jan 2010
Location: SFL
Posts: 706
sounds like it.
Reply With Quote
  #8  
Old 05-04-2010
--weezl--'s Avatar
Member
iTrader: (1)
 
Join Date: Sep 2009
Location: Calgary AB, Canada
Posts: 3,139
youo don't have enough pressure in your lines to spray fuel through the injectors, because it's dropping to 0 on key off, this could be from the regulator, which is supposed to be a 1 way valve also (on some vehicles) or it could be one of your fuel pumps, i don't remember if there is 2 on your truck or not

on the one hand, it's not a serious issue, as it is putting out the pressure, it's just not holding it... but the downside is, if it is your pump that is supposed to hold the pressure, it could be a warning sign that it's going to **** the bed right quick
Reply With Quote
  #9  
Old 05-05-2010
Robin Hood's Avatar
Member
iTrader: (2)
 
Join Date: Aug 2008
Location: AZ
Posts: 789
sounds like a pump to me.
Reply With Quote
  #10  
Old 05-05-2010
Member
 
Join Date: Apr 2010
Location: Clarksville Tn.
Posts: 24
I had similar problems with my old dodge ram (in tank pump) anyway i replaced the pump and it fixed it...it was a faulty regulator like stated above... if you end up doing the pump its easier to lift the bed up IMO....if you have the a few friends or lift its works great i swapped mine in my dodge in like 40 mins (had a bay with a lift)
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
HELP !HELP! HELP! 3.0 V6 Driving me insane Hunter74 2.9L & 3.0L V6 Tech 21 03-06-2016 12:08 PM
Help Help Help!!!!!!! EdgeGOBoom 2.9L & 3.0L V6 Tech 6 09-16-2007 01:01 AM
Help Help Help Gear Indicator Stuck BananaEdge General Technical & Electrical 5 06-16-2005 12:05 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 11:06 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.