help!! engine running too rich - Page 2 - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #26  
Old 09-13-2013
Member
 
Join Date: Aug 2013
Location: huntingdon quebec, canada
Posts: 1
let me know if you find your problem I have a friend with the same problem He's replaced all three oxygen sensors tried a good known maf sensor. fuel pressure in in specs when running long term fuel trim is always at -25 should be 10 plus or minus plus 5 would be ideal . also checked coolant sensor
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
CHICK NEEDS HELP- I'm running WAY TOO RICH! Alie 2.9L & 3.0L V6 Tech 54 01-21-2017 10:21 AM
still running too rich,low idle, smoking because of it bsan84 4.0L OHV & SOHC V6 Tech 1 03-04-2015 05:00 PM
O2 Sensor / System too Rich Fault Codes, Seems to be running fine?? metallicamaster3 2.9L & 3.0L V6 Tech 1 12-23-2012 08:20 PM
OBDII Code PO175 Running too rich bank 2 67yankee 2.9L & 3.0L V6 Tech 4 11-01-2010 10:54 PM
HELP!! 87 Ranger running too rich. HELP!!!!!!! Snow Wolf SOHC - 2.3L & 2.5L Lima Engines 20 09-04-2007 10:44 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 09:05 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.