need help! - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 11-05-2014
Member
Thread Starter
 
Join Date: Nov 2013
Location: Sherman, ME
Posts: 44
need help!

does anyone no why all my pumps might go at the same time. power steering pump turns hard almost like the bearings are getting ready to seize. the water pump was replaced 6 months ago and the bearings are so loose your can pick it up by the fan blade and move it up and down, side to side. the alternator also has loud screeching bearings but no play at the moment. the fan clutch seems to be solid and isnt loud so im assuming its not the cause of the water pump failure. i just replaced the belt because it was soaked in fluids and slipping. the power steering pump pushes out fluid nonstop and has sprayed down everything under the hood. before i start replacing these pumps is there anything that might have caused them all to go at once or is it just a coincidence that they all went together?
Reply With Quote
  #2  
Old 11-05-2014
Member
iTrader: (2)
 
Join Date: May 2014
Location: Lake Mary, Florida
Posts: 349
The clutch fan will be stiff when cold; the fluid within it is supposed to make it stiff so the fan spins at idle speeds to draw air, and spin freely at higher RPMS, as it assumes you are at highway type speeds and do not require the fan to be drawing in air when moving forward at these speeds.

My guess is that your power steering pump is seizing, causing drag on the belt, and this is "dragging" on all the other accessories that that belt spins. Get it replaced, and you may now need to replace that water pump again.

I'd also check the idler pulley/belt tensioner as well.

Last edited by bucko; 11-07-2014 at 04:35 AM.
Reply With Quote
  #3  
Old 11-06-2014
Member
 
Join Date: Oct 2014
Location: yarmouth mass
Posts: 231
help

Replace belt tensioner
Reply With Quote
  #4  
Old 11-08-2014
Member
Thread Starter
 
Join Date: Nov 2013
Location: Sherman, ME
Posts: 44
Quote:
Originally Posted by bucko View Post
The clutch fan will be stiff when cold; the fluid within it is supposed to make it stiff so the fan spins at idle speeds to draw air, and spin freely at higher RPMS, as it assumes you are at highway type speeds and do not require the fan to be drawing in air when moving forward at these speeds.

My guess is that your power steering pump is seizing, causing drag on the belt, and this is "dragging" on all the other accessories that that belt spins. Get it replaced, and you may now need to replace that water pump again.

I'd also check the idler pulley/belt tensioner as well.
so i replaced the tensioner assembly , water pump, and power steering pump.
runs like a champ now. thank you for your help :)
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Need help figuring out what shocks I need Slow94 Suspension Tech 0 06-20-2010 05:51 PM
I need new shocks and i need some help 2007BlackFX4 Suspension Tech 3 06-03-2010 08:36 PM
so i need a sub but i need help finding one... DeMar17 Audio & Video Tech 8 06-10-2009 07:45 AM
NEED HELP!!! need to install new Cd player 01edgeMan Audio & Video Tech 6 01-11-2009 07:28 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 09:12 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.