NEED HELP ASAP! throttle sticking - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 01-13-2010
edgerider2002's Avatar
Member
Thread Starter
iTrader: (9)
 
Join Date: Aug 2008
Location: Fresno, CA
Posts: 1,584
NEED HELP ASAP! throttle sticking

okay so i took my throttle body apart today to clean it and when i start my truck it idles fine. give it gas or rev it then it wont go below 1500 rpms. it only goes back to normal when i go into the engine bay and push the throttle all the way back to idle position. im stumped and need help fast.
Reply With Quote
  #2  
Old 01-13-2010
korey89's Avatar
Member
iTrader: (2)
 
Join Date: Mar 2008
Location: South, FL
Posts: 4,672
Isn't there supposed to be a return spring? Maybe you forgot to put it back on
Reply With Quote
  #3  
Old 01-13-2010
edgerider2002's Avatar
Member
Thread Starter
iTrader: (9)
 
Join Date: Aug 2008
Location: Fresno, CA
Posts: 1,584
its back on. that is put back on, cruise control, and throttle cable
Reply With Quote
  #4  
Old 01-13-2010
edgerider2002's Avatar
Member
Thread Starter
iTrader: (9)
 
Join Date: Aug 2008
Location: Fresno, CA
Posts: 1,584
im just hoping that spring didnt get stretched out or something
Reply With Quote
  #5  
Old 01-13-2010
edgerider2002's Avatar
Member
Thread Starter
iTrader: (9)
 
Join Date: Aug 2008
Location: Fresno, CA
Posts: 1,584
what if i tighten up that spring to make it so it returns all the way?
Reply With Quote
  #6  
Old 01-13-2010
edgerider2002's Avatar
Member
Thread Starter
iTrader: (9)
 
Join Date: Aug 2008
Location: Fresno, CA
Posts: 1,584
so in think it might have something to do with the cruis control cable not returning all the way
Reply With Quote
  #7  
Old 01-13-2010
btm757's Avatar
Member
iTrader: (5)
 
Join Date: Jun 2009
Location: Norfolk / Chesapeake, VA
Posts: 3,980
Lube it up, my 93 the throttle stuck open on it and i lubed it up and it closed just fine
Reply With Quote
  #8  
Old 01-13-2010
edgerider2002's Avatar
Member
Thread Starter
iTrader: (9)
 
Join Date: Aug 2008
Location: Fresno, CA
Posts: 1,584
Quote:
Originally Posted by btm757 View Post
Lube it up, my 93 the throttle stuck open on it and i lubed it up and it closed just fine
with what and exactly where?
Reply With Quote
  #9  
Old 01-13-2010
edgerider2002's Avatar
Member
Thread Starter
iTrader: (9)
 
Join Date: Aug 2008
Location: Fresno, CA
Posts: 1,584
alright so i have confirmed it is the cruis control cable thats not letting it return all the way. i disconnected it and then rev it and it goes down to the normal 750. anyway of tightening that up?
Reply With Quote
  #10  
Old 01-13-2010
edgerider2002's Avatar
Member
Thread Starter
iTrader: (9)
 
Join Date: Aug 2008
Location: Fresno, CA
Posts: 1,584
excuse me not tighten it up but allow for just a bit more slack so that it can return all the way?
Reply With Quote
  #11  
Old 01-14-2010
edgerider2002's Avatar
Member
Thread Starter
iTrader: (9)
 
Join Date: Aug 2008
Location: Fresno, CA
Posts: 1,584
so now im running my truck without the cruise control cable hooked up... safe?
Reply With Quote
  #12  
Old 01-14-2010
edgerider2002's Avatar
Member
Thread Starter
iTrader: (9)
 
Join Date: Aug 2008
Location: Fresno, CA
Posts: 1,584
anyone?
Reply With Quote
  #13  
Old 01-14-2010
--weezl--'s Avatar
Member
iTrader: (1)
 
Join Date: Sep 2009
Location: Calgary AB, Canada
Posts: 3,139
holy **** man! you don't need to put 5 posts in a row asking the same damn question! yes you are fine, unless you plan on using your cruise control...

figure out where the problem on your cruise control is, and fix it... you saying "it's my cruise control" isn't going to get you a detailed fix... more details are needed, cruise control is a multi part system...

also try using the *edit* button
Reply With Quote
  #14  
Old 01-14-2010
edgerider2002's Avatar
Member
Thread Starter
iTrader: (9)
 
Join Date: Aug 2008
Location: Fresno, CA
Posts: 1,584
haha its just easier lol

and the problem is the cable needs to be pulled out like a few millimeters so that it can allow the throttle to go back to normal
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2004 Ranger throttle lightly sticking noahfrye 2.9L & 3.0L V6 Tech 1 08-19-2015 08:51 PM
2.9L intermittent throttle sticking fox44 2.9L & 3.0L V6 Tech 0 10-22-2012 02:24 AM
Need help E-Brake sticking bad. cchsbuzz19 General Ford Ranger Discussion 1 11-02-2009 09:32 PM
throttle sticking ClubFoot General Technical & Electrical 4 08-16-2009 11:39 PM
Throttle body/ Throttle Body Spacer??? dangelj316 4.0L OHV & SOHC V6 Tech 34 11-17-2007 01:41 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 09:15 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.