new air filter and wont run right - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-01-2009
4x4RangerOffroad's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Jan 2009
Location: Barrington, NH
Posts: 434
new air filter and wont run right

I got a cone filter from advanced and now my truck runs like hell if it will even start until I unplug the MAF. I didnt oil the new filter could that be the problem? Any ideas on the subject would be awesome.

Thanks
Justin
Reply With Quote
  #2  
Old 08-01-2009
Grot's Avatar
Member
 
Join Date: May 2009
Location: Knox, Tennessee
Posts: 122
Details!

What is it doing?

What EXACTALLY did you change?

Try putting if back to stock and see of it runs fine.

Also i may have an idea what is happening, can i get a pic of your engine bay?
Reply With Quote
  #3  
Old 08-01-2009
4x4RangerOffroad's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Jan 2009
Location: Barrington, NH
Posts: 434
I got it, Using some diagnostics I found that there was a gap at the maf, I still need to oil the filter. runs a lil better but not great hoping the oil will fix.
Reply With Quote
  #4  
Old 08-01-2009
4x4RangerOffroad's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Jan 2009
Location: Barrington, NH
Posts: 434
Quote:
Originally Posted by Grot View Post
Details!

What is it doing?

What EXACTALLY did you change?

Try putting if back to stock and see of it runs fine.

Also i may have an idea what is happening, can i get a pic of your engine bay?
What was your idea?
Reply With Quote
  #5  
Old 08-01-2009
Grot's Avatar
Member
 
Join Date: May 2009
Location: Knox, Tennessee
Posts: 122
MAF gap.

Thats what mine did.

The clips that hold the MAF plate are weak, and eventually wont hold the maf into the Top section of the stock airbox.

I had the exact same problem, i had to go back to stock, as the filter is the only thing that will hold the MAF in the correct place for the truck to run.
Reply With Quote
  #6  
Old 08-02-2009
BB2's Avatar
BB2 BB2 is offline
Member
 
Join Date: Mar 2007
Location: PA
Posts: 333
Quote:
Originally Posted by 4x4RangerOffroad View Post
I got it, Using some diagnostics I found that there was a gap at the maf, I still need to oil the filter. runs a lil better but not great hoping the oil will fix.
Oiled filters on a MAF equipped truck is a bad and sometimes expensive idea. Thats the reason I run mine stock. The oil gets on the MAF senor and causes it to fail. A new MAF isn't the cheapest thing in the world either. Just a heads up.
Reply With Quote
  #7  
Old 08-03-2009
Member
 
Join Date: Mar 2009
Location: Plantation,fl
Posts: 46
I had a K+N filter removed it last week because the MAF died. Cost $216. i put in a paper filter. Anyone want a K+N?
Reply With Quote
  #8  
Old 08-03-2009
dakota772's Avatar
Member
 
Join Date: May 2008
Location: Tucson
Posts: 230
Quote:
Originally Posted by GER42 View Post
I had a K+N filter removed it last week because the MAF died. Cost $216. i put in a paper filter. Anyone want a K+N?
Quote:
Originally Posted by BB2 View Post
Oiled filters on a MAF equipped truck is a bad and sometimes expensive idea. Thats the reason I run mine stock. The oil gets on the MAF senor and causes it to fail. A new MAF isn't the cheapest thing in the world either. Just a heads up.
We have had so many threads about the oil on the ari filters causing MAF to fail. I have been running a K&N drop-in filter for 2 years in my '00 Ranger and I had it in my '99 for almost 2 years before it was totalled. I have re-oild the filter at the appropriate time, and I have not had any problems with performance or MAF fail.
Reply With Quote
  #9  
Old 08-03-2009
joshtank's Avatar
Member
 
Join Date: Jun 2009
Location: Winston GA
Posts: 1,240
Quote:
Originally Posted by GER42 View Post
I had a K+N filter removed it last week because the MAF died. Cost $216. i put in a paper filter. Anyone want a K+N?
go all back to stock . drill some holes on the bottom side of your airbox facing away from the engine, and drop in a k&n airfilter ...FTW
Reply With Quote
  #10  
Old 08-08-2009
Daily Driver's Avatar
Member
 
Join Date: Oct 2007
Location: NH
Posts: 191
I have about 80,000 miles with no prob from the oil on my filter. I do clean the MAF a little while after I clean the filter though.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
4.0 SOHC wont run right after timing chain rebuild caribeanbound 4.0L OHV & SOHC V6 Tech 13 06-19-2015 05:30 PM
Rebuilt motor, wont run right jeep34e5 2.9L & 3.0L V6 Tech 0 12-28-2014 05:11 PM
Rebuilt motor, wont run right jeep34e5 2.9L & 3.0L V6 Tech 0 12-28-2014 04:49 PM
Air intake, air cooler, sealed filter??? Taylor_Patrick General Ford Ranger Discussion 0 09-16-2012 11:07 PM
Help!! windows wont roll up and deck wont come one dantheman General Technical & Electrical 4 08-26-2010 07:33 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 03:50 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.