O2 sensor plug kit's? - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 09-13-2009
gotmud?'s Avatar
Member
Thread Starter
 
Join Date: Sep 2008
Location: avon park florida
Posts: 401
O2 sensor plug kit's?

iv heard mustang owners when they run true duals or custom exhaust they eliminate the o2 sensors and they plug in some sort or connection which reads a constant..... do they make these for our rangers?



thanks.
Reply With Quote
  #2  
Old 09-13-2009
whippersnapper02's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Sep 2006
Location: Earth, Milky Way Galaxy
Posts: 7,415
What you are probably talking about is rear o2 simulators. They use them when they remove the cats so they don't get a check engine light. I'm not sure if they make them for Rangers but trust me you don't need them. Our engine don't move enough air to run without cats so taking them off will not gain you any power and may reduce low end power.

Last edited by whippersnapper02; 09-13-2009 at 06:47 PM.
Reply With Quote
  #3  
Old 09-13-2009
gotmud?'s Avatar
Member
Thread Starter
 
Join Date: Sep 2008
Location: avon park florida
Posts: 401
well now u see what my problem is the idiot i bought my truck from stock cut off the last cat long with the last o2 sensor so sense then i welded onto that and ran 45's out the back but i ran with out the last o2 for a while and its always stayed on closed loop and i always ran 19-20 mpg average....now its stayin on open loop and im gettin som seriously ****ty mileage.... any ideas? maybe weld in a o2 port?
Reply With Quote
  #4  
Old 09-13-2009
whippersnapper02's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Sep 2006
Location: Earth, Milky Way Galaxy
Posts: 7,415
Ah. I thought you were looking for performance. Well the last sensor monitors the efficiency of the cats. The only way to turn the light off is to install the sensor again or to get that simulator. I would personally install the sensor again. As far as staying in open loop that may be caused by something else but I'm not 100% sure. I'm assuming you got the code read? If not go ahead and do that.

Last edited by whippersnapper02; 09-13-2009 at 08:49 PM.
Reply With Quote
  #5  
Old 09-13-2009
gotmud?'s Avatar
Member
Thread Starter
 
Join Date: Sep 2008
Location: avon park florida
Posts: 401
alright ill throw the scanner on tommorow at work ......
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Ranger 2.3 Engine swap 8 plug to 4 plug, help! rangerdanger9419 SOHC - 2.3L & 2.5L Lima Engines 0 08-11-2015 04:02 PM
How do the plug wires go? - 1991 2.3 8 plug yamahondarider SOHC - 2.3L & 2.5L Lima Engines 1 04-29-2013 04:51 PM
Plug and Plug Wires Recommendations? brow_tines 4.0L OHV & SOHC V6 Tech 2 04-06-2011 03:09 PM
O2 Sensor plug trouble...need quick advise Barry Tolson General Technical & Electrical 6 10-31-2010 02:36 PM
h20 sensor plug loction 1dustinlthomas 4.0L OHV & SOHC V6 Tech 1 05-06-2010 03:17 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 03:44 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.