oil leak? - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-29-2009
99offroadrngr's Avatar
TOYOTA
Thread Starter
iTrader: (37)
 
Join Date: Jul 2007
Location: Massachusetts
Posts: 11,728
oil leak?

Ok, i know i haev an oil leak but i have no clue where it is coming from. i just checked the dipstick and the oil level seems to be at about half....closer to the minimum side. i noticed when i left work that my drivers side "thing" (can't think of name) was darker than the pass. side and i touched the small puddle that came from that part onto my tire and onto ground and it smelled like oil. i can't seem to see where its coming from and when i drive it, it doesn't smell like burnt oil or anything so i assume its not a gasket? i only got one pic cuz its raining and don't want to mess up my new camera...any ideas?


Name:  IMG_0047.jpg
Views: 2
Size:  183.8 KB

^^^you can see where the oil is in this pic cuz the little bubbles
it comes from up top somewhere but can't really narrow it down
Reply With Quote
  #2  
Old 03-29-2009
03edge's Avatar
Member
iTrader: (1)
 
Join Date: Feb 2009
Location: Akron, OH
Posts: 1,031
check your powersteering, if you overfill it or if you turn the wheels with the engine off it will come out of the cap and shoot down the side of the engine. thats the only thing i have seen that could get down to the control arm.
Reply With Quote
  #3  
Old 03-29-2009
99offroadrngr's Avatar
TOYOTA
Thread Starter
iTrader: (37)
 
Join Date: Jul 2007
Location: Massachusetts
Posts: 11,728
powersteering looks full but there is a bunch of crap around it but i dunno why it keeps happening. its happened like 3 times already i dunno
Reply With Quote
  #4  
Old 03-29-2009
Member
 
Join Date: Jun 2005
Location: Havertown,PA
Posts: 467
Are you sure it is not antifreeze?From the picture it looks like coolant to me.
Reply With Quote
  #5  
Old 03-29-2009
99offroadrngr's Avatar
TOYOTA
Thread Starter
iTrader: (37)
 
Join Date: Jul 2007
Location: Massachusetts
Posts: 11,728
nah...i touched it when it left a puddle on the ground and it was brownish and smelled/felt like oil. im bringing it in tomorrow to put on a lift and get a good look at it...hope for the best... i really can't afford to have something major be messed since im in school and don't work too much
Reply With Quote
  #6  
Old 03-29-2009
t0x1k's Avatar
Member
 
Join Date: Aug 2008
Location: Somerdale, NJ
Posts: 290
That tie rod end looks like you need to replace it.
Pretty nasty looking.
Reply With Quote
  #7  
Old 03-30-2009
99offroadrngr's Avatar
TOYOTA
Thread Starter
iTrader: (37)
 
Join Date: Jul 2007
Location: Massachusetts
Posts: 11,728
haha i know about that but the thing im worried bout is that leak....looks like its coming from up top somewhere...ill find out today hopefully
Reply With Quote
  #8  
Old 03-30-2009
Crunchy's Avatar
Member
 
Join Date: Oct 2007
Location: Hull, Quebec
Posts: 486
So much is oily/dirty/wet down there its gonna be hard. Clean it all off and see where it starts getting oily again.

And that is one funky tie rod end you got there.
Reply With Quote
  #9  
Old 03-30-2009
FordRangerXLT's Avatar
Member
 
Join Date: Sep 2007
Location: Fitchburg,MA
Posts: 137
O ok, it looks like it is coming from your oil filter. Check to make sure your oil filter is screwed on tight enough or that the seal is in there properly.
Reply With Quote
  #10  
Old 03-30-2009
titanbball2345's Avatar
Member
 
Join Date: Jul 2007
Location: Toledo, Ohio
Posts: 309
Quote:
Originally Posted by FordRangerXLT View Post
O ok, it looks like it is coming from your oil filter. Check to make sure your oil filter is screwed on tight enough or that the seal is in there properly.
That would be my guess. I had oil leaking last weekend. Come to find out the Ford dealership that did my oil change 2 months ago didnt tighten the filter enough....
Reply With Quote
  #11  
Old 03-30-2009
03edge's Avatar
Member
iTrader: (1)
 
Join Date: Feb 2009
Location: Akron, OH
Posts: 1,031
yea i put big tires on my truck and as soon as i did i turned the wheel with the power off and it shot out powersteering fluid from the cap (there is a little hole in the top) i dont know if theres something wrong with it but it seems fine now. it shot it towards the battery and it ran down the side down the engine. i dont know if its the same case for you but it sounds similar. check the fluid on your finger if its a reddish consistency its powersteering. Most fords take ATF in the powersteering....any squeeking when you turn? otherwise those guys are right too, the oil filter is on the driver side and may be loose... just check the color of the fluid
Reply With Quote
  #12  
Old 03-30-2009
99offroadrngr's Avatar
TOYOTA
Thread Starter
iTrader: (37)
 
Join Date: Jul 2007
Location: Massachusetts
Posts: 11,728
fluid is brown and smells and feels like oil...what sucks is its pouring right now and hard to see anything haha
Reply With Quote
  #13  
Old 03-30-2009
cchsbuzz19's Avatar
Member
iTrader: (5)
 
Join Date: Jul 2007
Location: North Canton, Ohio
Posts: 2,417
Quote:
Originally Posted by FordRangerXLT View Post
O ok, it looks like it is coming from your oil filter. Check to make sure your oil filter is screwed on tight enough or that the seal is in there properly.
it can't be the oil filter that picture is of the left front the oil filter is on the right of the truck.

Now the power steering could be it because I've also been noticing fluid on top of my PS cap and I found some going down the side of the tube. My power steering fluid is brown, I definitly could mistaken it as oil since there the same color.
Reply With Quote
  #14  
Old 03-30-2009
4x4RangerOffroad's Avatar
Member
iTrader: (1)
 
Join Date: Jan 2009
Location: Barrington, NH
Posts: 434
Quote:
Originally Posted by cchsbuzz19 View Post
it can't be the oil filter that picture is of the left front the oil filter is on the right of the truck.

Now the power steering could be it because I've also been noticing fluid on top of my PS cap and I found some going down the side of the tube. My power steering fluid is brown, I definitly could mistaken it as oil since there the same color.
WRONG...99 3.0 filter is on the left...the hose that catches the spilt oil from the filter when doing and oil change actually runs right down along the control arms on the inside of the frame...It is possible for the filter to be leaking for...The "O" ring may be messed up.
Reply With Quote
  #15  
Old 03-30-2009
99offroadrngr's Avatar
TOYOTA
Thread Starter
iTrader: (37)
 
Join Date: Jul 2007
Location: Massachusetts
Posts: 11,728
all around the filter is dry... i jus checked it. hopefully wednesday i can see where the leak is really coming from the lifts were all being used today which sucks
Reply With Quote
  #16  
Old 03-30-2009
03edge's Avatar
Member
iTrader: (1)
 
Join Date: Feb 2009
Location: Akron, OH
Posts: 1,031
that stinks, hmmmm....it still could be really dirty power steering fluid.....not sure other than that
Reply With Quote
  #17  
Old 03-31-2009
4x4RangerOffroad's Avatar
Member
iTrader: (1)
 
Join Date: Jan 2009
Location: Barrington, NH
Posts: 434
well it is a ford...my ps fluid is gross and always was...even after flushing it its gross 2 days later...
Reply With Quote
  #18  
Old 03-31-2009
cchsbuzz19's Avatar
Member
iTrader: (5)
 
Join Date: Jul 2007
Location: North Canton, Ohio
Posts: 2,417
Sorry, didn't know you you had a 3.0L.
Reply With Quote
  #19  
Old 04-02-2009
99offroadrngr's Avatar
TOYOTA
Thread Starter
iTrader: (37)
 
Join Date: Jul 2007
Location: Massachusetts
Posts: 11,728
it was really dirty power steering fluid. really helps putting the thing on a lift haha. its the steering rack! BOO
now i just gotta cough up some money for a new one plus labor, alignment and a camber kit lol
Reply With Quote
  #20  
Old 04-02-2009
Member
 
Join Date: Feb 2009
Location: Chelsea,AL
Posts: 562
hey let me know how much it all costs, i have to do the same thing on my mustang i just want to get a general idea cause yours will probably be fixed before i even check to see.
Reply With Quote
  #21  
Old 04-02-2009
99offroadrngr's Avatar
TOYOTA
Thread Starter
iTrader: (37)
 
Join Date: Jul 2007
Location: Massachusetts
Posts: 11,728
well, i know that the rack itself is 220. i didn't find out the labor haha i forgot to. ill call and get an estimate on it in a few min and edit haha
ok im waiting on a call back...im getting an estimate on the rack, camber kit, alignment, and labor.
Reply With Quote
  #22  
Old 04-02-2009
LuckyRanger13's Avatar
Member
iTrader: (1)
 
Join Date: Nov 2007
Location: Santa Fe, TN
Posts: 554
Get that tie rod replaced while your at it if you got the money. Looks like rusty heaven. Glad you found out it was your PS and not nothing major.
Reply With Quote
  #23  
Old 04-02-2009
FordRangerXLT's Avatar
Member
 
Join Date: Sep 2007
Location: Fitchburg,MA
Posts: 137
I went to go get an alignment on my ranger once and the mechanic told me I needed new camber bolts and said it would be $300. I do everything on my truck myself (excluding tires and alignment) but I put the camber bolts in myself and it was a piece of cake. I only cost me $40?? in parts....well some where around there. What part of Mass you from btw?
Reply With Quote
  #24  
Old 04-05-2009
99offroadrngr's Avatar
TOYOTA
Thread Starter
iTrader: (37)
 
Join Date: Jul 2007
Location: Massachusetts
Posts: 11,728
haha yeha its 40 for the camber kit. im about 30-40 min from worcester.
your truck wouldn't happen to be gray would it? i just read your profile says u have a sub and stuff i see one in fitchburg all the time with a sub bumpin haha a gray extended cab.
Reply With Quote
  #25  
Old 04-05-2009
FordRangerXLT's Avatar
Member
 
Join Date: Sep 2007
Location: Fitchburg,MA
Posts: 137
O man, I forgot I still had that on there. I got rid of the system a year ago lol. The only thing I listen to is rock and your really don't need the subs for that. I need to get a pic up of my truck. It is black and it's a single cab. From what I see in your Avater, your truck looks pretty sick! Do you have wheel spacers?
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
oil pressure and small oil leak yaro1996 Oil & Lubrication 4 07-07-2017 03:29 PM
Odd coolant leak / Starter oil leak?? iplayloudly 2.9L & 3.0L V6 Tech 2 12-12-2011 05:04 PM
oil leak, timing chain cover/oil pan? DillonT 2.9L & 3.0L V6 Tech 17 09-16-2011 08:01 PM
3.0 V6- Oil Pan Leak + Trans Leak = Ouch. . . Fenech627 2.9L & 3.0L V6 Tech 5 10-04-2010 06:22 PM
Leak, leak, drip, drip oh what a headache it is! SonicRanger001 Drivetrain Tech 6 12-22-2005 02:04 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 08:35 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.