stumbling - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 05-20-2014
Member
Thread Starter
 
Join Date: Nov 2013
Location: Sherman, ME
Posts: 44
stumbling

got a quick question. my 01 ranger stumbles for a few minutes after its started. once its warmed up the idle smooths out. the only code that comes up is that bank 1 Sensor 2 is malfunctioning. i no that a bad downstream sensor wont affect how the vehicle runs. could this mean that the passengers side catalytic converter is bad? i do get a soft rattling noise from the exhaust. the truck also struggles going up hill. feels like im loosing torque. the sparks plugs and wires have been replaced, both upstream 02 sensors, MAF, and fuel filter. any ideas?
Reply With Quote
  #2  
Old 05-20-2014
Member
Thread Starter
 
Join Date: Nov 2013
Location: Sherman, ME
Posts: 44
i now have 3 codes instead of one. P0301 Cylinder 1 misfire. P0136 Bank 1 sensor 2, and P0141 Heater circuit malfunction. any info at all will be appreciated thank you :)
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Shutter and Stumbling issue StratGT 4.0L OHV & SOHC V6 Tech 1 08-13-2010 05:36 AM
Engine stumbling problem 98WARanger 2.9L & 3.0L V6 Tech 9 11-20-2008 10:39 AM
Engine stumbling SouthernMudSlinger General Technical & Electrical 21 09-20-2007 10:02 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 09:06 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.