vacuum problem - Ranger-Forums - The Ultimate Ford Ranger Resource


2.9L & 3.0L V6 Tech General discussion of 2.9L and 3.0L V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 05-12-2010
coleary15's Avatar
Member
Thread Starter
 
Join Date: Jul 2009
Location: Cincinnati, Ohio
Posts: 343
vacuum problem

ok my egr isnt getting vacuum, what could it be?

i checked the lines, i checked the egr valve itself and cleaned it, and everything else needed.

i have the 3.0L v6, and im thinkin its the small vacuum solenoid whish isnt turning on

Last edited by coleary15; 05-13-2010 at 07:47 PM.
Reply With Quote
  #2  
Old 05-14-2010
coleary15's Avatar
Member
Thread Starter
 
Join Date: Jul 2009
Location: Cincinnati, Ohio
Posts: 343
does anyone know?
Reply With Quote
  #3  
Old 05-14-2010
fordrangerperformance's Avatar
Member
 
Join Date: May 2006
Location: cookeville, Tn
Posts: 59
Could be the vacuum regulator solenoid or could also be the EGR Time delay switch i know i replaced one on a friends truck an he was having a similar problem as you an it fixed it but other then that I don't have a clue right off bud.
Reply With Quote
  #4  
Old 06-15-2010
coleary15's Avatar
Member
Thread Starter
 
Join Date: Jul 2009
Location: Cincinnati, Ohio
Posts: 343
replaced the dpfe and i dont think it changed anything, egr is fine and so is the solenoid
Reply With Quote
  #5  
Old 12-12-2010
Member
 
Join Date: Dec 2010
Location: hampton, va
Posts: 1
DPFE

I have been trying to locate the DPFE on my 03 and can not find it for the life of me. If anyone could point me in a direction it would be great. thanks

Nathan
Reply With Quote
  #6  
Old 01-05-2011
davethepear's Avatar
Member
 
Join Date: Jan 2011
Location: Mound City
Posts: 49
I don't know about yours, but mine is on the upper intake, right by the throttle body
Reply With Quote
  #7  
Old 01-08-2011
coleary15's Avatar
Member
Thread Starter
 
Join Date: Jul 2009
Location: Cincinnati, Ohio
Posts: 343
Right by the the two coolant hoses going into you're intake plenum. It's black/gray plastic and bolts onto the front of your intake
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
How To: Pulse Vacuum Hub Fix rngprerunner Engine & Drivetrain 7 12-13-2016 05:20 PM
2006 Ranger 4.0 SOHC Lean problem - likely vacuum leak freddie 4.0L OHV & SOHC V6 Tech 8 12-03-2013 07:19 PM
difficult vacuum problem kirk3000 General Technical & Electrical 6 09-25-2010 09:26 AM
what is the name of the black vacuum ball? wdstone General Technical & Electrical 3 07-12-2005 09:02 PM
vacuum gauge mounting options SVT01RANGER New Ideas 0 04-13-2005 11:10 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 06:42 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.