engine issues - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-26-2011
Member
Thread Starter
 
Join Date: Jan 2011
Location: somerset
Posts: 15
engine issues

My engine has had a knock ever since i got it, and ive been hearing a loud buzzing sound coming from the maf sensor so about three weeks ago i replaced the maf with a used one, ran the same for about a day. then it started to bog down really bad, and the truck would shake really bad on the highway, it just lost all of its power, so i put the old maf back in. the problem still didnt go away, so after talking to numerous mechanics i was under the assumption that my engine had died ( lost a cylinder).

I already had a used engine ready to go in so i decided to replace the engine. after replacing the engine everything seemed fine until i went down the road and realized that it has a very similar problem as far as the no power issue goes almost like its stuttering, so i ran the codes and got p0304 (misfire cylinder 4) and p1132 which i believe is a running rich problem. the exhaust definitely smells like its running rich. could this be an o2 sensor problem that still exists, its def not the new eng (i had it running before it was removed from the old truck and it ran great) im assuming that it has to be something to do with the comp or maybe along those lines. any help or suggestions would be greatly appreciated
Reply With Quote
  #2  
Old 04-26-2011
rangerrunner11's Avatar
Member
 
Join Date: Feb 2011
Location: .
Posts: 1,018
buzzing sounds like a short but replacing didnt work? hmmm
Clean the MAF?
Timing off? I know those 4.0's are notorious for that misfire crap.
You could check the O2 by borrowing a friends just to see.
If you got no code for 02 and its plugged in then its fine.
get it flashed at your local ford dealer
Reply With Quote
  #3  
Old 04-27-2011
Member
Thread Starter
 
Join Date: Jan 2011
Location: somerset
Posts: 15
I have cleaned the maf, What's the best way to check the timing? And I'm assuming that getting it flashed also means scanned
Reply With Quote
  #4  
Old 04-27-2011
rangerrunner11's Avatar
Member
 
Join Date: Feb 2011
Location: .
Posts: 1,018
No flashed as in 80$ (last time my security system messed up) and they plug in your dash and set all defaults for engine back to factory. so in essence clearing any faults and starting the ECU over
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Gauge issues/heating issues/high oil pressure Fw87 General Ford Ranger Discussion 2 04-26-2015 12:08 AM
Bad engine issues please help XanderMcK 4.0L OHV & SOHC V6 Tech 3 04-23-2014 10:38 AM
Tachacardic Speedometer and Engine issues ghaskins General Technical & Electrical 0 10-05-2013 06:52 PM
1994 XLT engine issues dontke 4.0L OHV & SOHC V6 Tech 1 05-03-2013 07:30 PM
plagued with engine issues 94greenmachine SOHC - 2.3L & 2.5L Lima Engines 4 11-24-2006 10:13 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 06:49 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.