Error Codes/MAS issue? - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 12-09-2008
Member
Thread Starter
 
Join Date: Jan 2008
Location: Reading, PA
Posts: 22
Error Codes/MAS issue?

Okay, I posted this elsewhere and I wanted to try here as well, here is what I have so far. My vehicle is a 2002 Ranger 4.0 6 Cyl, 75,000 miles.

Code 1:

P0171-Fuel trim bank one condition. Rich or lean condition detected by the oxygen sensor.

Code 2:

P0174-Fuel trim bank two condition. Rich or lean condition detected by the oxygen sensor.

If bank one and bank 2 are set together, suspect a fuel condition or MAF sensor fault

Other reasons say:

Failed H02521
Ingnition misfire condition
Fuel injectior problem
engine mechanical; condition
Oxygen sensor defective

So, likely since they both are in error, what is going on?

I did notice a stall yesterday, no light. Attributed it to the cold weather. Also, added fuel this morning and tightened cap later on today. Light still on after 15 miles, codes as above. It has been cold and the fuel was low, could I have a bad plug from water or something?

Ideas? Never replaced plugs but fuel filter and oxygen sensor at 30-40,000 from what I recall.


Additionally:

The truck had been in Buffalo for 5 years, which you know is cold. I am in PA now, but the temp with the windchill was 10F. Has been in colder conditions and not done this.

I know the fuel was real low on Sunday. Monday I got it filled up, no light until maybe lunchtime after I had driven it 20 or so miles from when I first got gas. I had the fuel filter replaced about 40,000 or so miles back. Could I have drawn in water and destroyed a plug or two? I have never replaced the plugs.

There is no acceleration issue that I can feel, no rough idle, no hesitation now.

So, what do I do now? Where would anyone here start?
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Error codes 158,159,173,177,185/4.0L zeeranger 4.0L OHV & SOHC V6 Tech 5 04-13-2015 12:40 PM
CODES CODES- IDLE issue supraboatguy General Technical & Electrical 1 11-08-2011 02:17 AM
Multiple Error Codes RiverDog 4.0L OHV & SOHC V6 Tech 3 12-02-2009 10:37 AM
Check engine error codes ClubFoot 2.3L & 2.5L I4 Tech 3 01-26-2009 08:36 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 03:37 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.