gettin bogged down... - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-16-2005
ranger024x4's Avatar
RF Veteran
Thread Starter
iTrader: (6)
 
Join Date: Aug 2004
Location: nova
Posts: 5,061
gettin bogged down...

I got a K&N cone filer and a V-Force exaust... basically, if i gun it, it sorta gets bogged down, like sorta like its not gettin enough or too much gas. it doesnt back fire, just seems like its not running 100%

I know (or at least think) that my idle air controller is bad or going but will this effect it? or is it in the computer? Like a bama chip may fix it...

Last edited by ranger024x4; 07-16-2005 at 10:24 PM.
Reply With Quote
  #2  
Old 07-16-2005
Draimen's Avatar
Member
 
Join Date: Feb 2005
Location: Fort Morgan, CO
Posts: 402
Not sure about the other stuff. But I do know a k&n filter that is not oiled properly will hamper the performance alot, just a thought
Reply With Quote
  #3  
Old 07-16-2005
ranger024x4's Avatar
RF Veteran
Thread Starter
iTrader: (6)
 
Join Date: Aug 2004
Location: nova
Posts: 5,061
thats worth a shot.. ill try that tomarrow
Reply With Quote
  #4  
Old 07-16-2005
Bigwill41's Avatar
Member
 
Join Date: Jun 2004
Location: Navasota, Texas
Posts: 4,659
Mine feels like that to...

To much air in and less out...
Reply With Quote
  #5  
Old 07-17-2005
Member
 
Join Date: Jul 2005
Location: Newton, NC
Posts: 35
The iac (idle air control) will not affect performance. if you had a problem with the iac your truck would have problems idling. The iac is a valve that allows air to bypass the throttle plate while closed keeping the engine at a specific rpm, look elsewhere for your diagnosis. maybe MAF, is the MIL illuminated how many miles do you have on your truck....has it always done that with the intake and exaust mod?
Reply With Quote
  #6  
Old 07-17-2005
ranger024x4's Avatar
RF Veteran
Thread Starter
iTrader: (6)
 
Join Date: Aug 2004
Location: nova
Posts: 5,061
my trucks got 40,500 miles. I checked the MAF and it was fine... Im gonna drive a friends truck with the same mods and see if it does the same
Reply With Quote
  #7  
Old 07-17-2005
Member
 
Join Date: Jul 2005
Location: Newton, NC
Posts: 35
How did you check it?
Reply With Quote
  #8  
Old 07-17-2005
ranger024x4's Avatar
RF Veteran
Thread Starter
iTrader: (6)
 
Join Date: Aug 2004
Location: nova
Posts: 5,061
i pulled it out and made sure it was clean
Reply With Quote
  #9  
Old 07-17-2005
Member
 
Join Date: Jul 2005
Location: Newton, NC
Posts: 35
Is your MIL illuminated? Oh and describe the sound your exaust has im shopping around and want some opinions. I want something loud and throaty, some guys said a flowmaster 40 series but I was just wondering what the opinion was across the panel.
Reply With Quote
  #10  
Old 07-17-2005
Member
 
Join Date: Nov 2004
Location: Danville, VA
Posts: 2,664
i went back to my stock airbox for rootin...

if u wanna new setup for cone filters, lemme know, i got one for ya...

hope u get u're stuff fixed
Reply With Quote
  #11  
Old 07-17-2005
ranger024x4's Avatar
RF Veteran
Thread Starter
iTrader: (6)
 
Join Date: Aug 2004
Location: nova
Posts: 5,061
MIL? lol

I like the sound... its the lighting style (custom)... describe... umm idk
Reply With Quote
  #12  
Old 07-17-2005
ranger024x4's Avatar
RF Veteran
Thread Starter
iTrader: (6)
 
Join Date: Aug 2004
Location: nova
Posts: 5,061
here ya go...
Reply With Quote
  #13  
Old 07-17-2005
FoMoCoFiddy's Avatar
Member
 
Join Date: May 2004
Location: Smackdownville Tx
Posts: 4,508
Clean the MAF sensor. I doubt you'd be able to just look at it. And notice if it was clean.

Is it bogging, or is it skipping, and missing on acceleration? If thats it, its your spark plugs.

I'd bet that its your MAF is dirty, clean it just to be sure, and get the IAC fixed, it does have to do with idling, but try taking it out, and cleaning the hole that becomes visible when you take it off.
Reply With Quote
  #14  
Old 07-17-2005
Member
 
Join Date: Jul 2005
Location: Newton, NC
Posts: 35
Damn thats nifty exaust. when you clean your MAF use aerosol brake cleaner and be sure not to touch the receptor wire with your finger or you will ruin it.
Reply With Quote
  #15  
Old 07-17-2005
ranger024x4's Avatar
RF Veteran
Thread Starter
iTrader: (6)
 
Join Date: Aug 2004
Location: nova
Posts: 5,061
is this the magical thing
Reply With Quote
  #16  
Old 07-17-2005
ranger024x4's Avatar
RF Veteran
Thread Starter
iTrader: (6)
 
Join Date: Aug 2004
Location: nova
Posts: 5,061
Quote:
Originally Posted by ToyoTech
Damn thats nifty exaust. when you clean your MAF use aerosol brake cleaner and be sure not to touch the receptor wire with your finger or you will ruin it.


daym too late
Reply With Quote
  #17  
Old 07-17-2005
Member
 
Join Date: Jul 2005
Location: Newton, NC
Posts: 35
That looks like an IAC.
Reply With Quote
  #18  
Old 07-17-2005
ranger024x4's Avatar
RF Veteran
Thread Starter
iTrader: (6)
 
Join Date: Aug 2004
Location: nova
Posts: 5,061
sweet... how should i clean it... i dont wanna **** it up



i normally dont have alot of Q's but im being carfull
Reply With Quote
  #19  
Old 07-17-2005
Member
 
Join Date: Jul 2005
Location: Newton, NC
Posts: 35
With the Idle Air Control valve you just need to take some carb or throttle plate cleaner and an old tooth brush or similar device and scrub the black carbon off the air flow area. dont submerge it or anything, and you may as well clean the throttle body while you are this deep. na-mean......
Reply With Quote
  #20  
Old 07-17-2005
ranger024x4's Avatar
RF Veteran
Thread Starter
iTrader: (6)
 
Join Date: Aug 2004
Location: nova
Posts: 5,061
ok....


thanks for da help
Reply With Quote
  #21  
Old 07-17-2005
Member
 
Join Date: Jul 2005
Location: Newton, NC
Posts: 35
Anything to help dude....
Reply With Quote
  #22  
Old 07-17-2005
FoMoCoFiddy's Avatar
Member
 
Join Date: May 2004
Location: Smackdownville Tx
Posts: 4,508
that'll be 25.46, pm me for my paypal adress...







Kidding.
Reply With Quote
  #23  
Old 07-17-2005
Member
 
Join Date: Nov 2004
Location: Danville, VA
Posts: 2,664
why was u're bed off?
Reply With Quote
  #24  
Old 07-17-2005
ranger024x4's Avatar
RF Veteran
Thread Starter
iTrader: (6)
 
Join Date: Aug 2004
Location: nova
Posts: 5,061
it lives!!!!

no more of that noise...

thanks!!!!
Reply With Quote
  #25  
Old 07-17-2005
ranger024x4's Avatar
RF Veteran
Thread Starter
iTrader: (6)
 
Join Date: Aug 2004
Location: nova
Posts: 5,061
Bed off... i was just messin around...(it was a while ago)
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Ranger Down! Ranger Down! kirbo7106 SOHC - 2.3L & 2.5L Lima Engines 11 01-06-2012 09:11 PM
Down Under, On Top, Down South :) Scrat01 Member Introductions 9 09-13-2010 08:14 AM
slowing down... down hills... does yours do this? nross General Ford Ranger Discussion 26 12-09-2009 01:25 PM
Im gettin Bags Ride n'low Suspension Tech 23 01-11-2005 07:49 PM
GETTIN A FLOW spRkyKd 2.9L & 3.0L V6 Tech 3 10-13-2004 02:55 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 09:59 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.