High Rev's at startup? 4.0 OHV - Ranger-Forums - The Ultimate Ford Ranger Resource

4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

High Rev's at startup? 4.0 OHV

Reply

 
 
 
  #1  
Old 09-30-2007
HAZZARDJOHN's Avatar
Member
Thread Starter
Join Date: Dec 2005
Location: Wyoming MN
Posts: 2,400
High Rev's at startup? 4.0 OHV

Ok I give up, when I start he Xploder it rev's up to 3K rpm's and holds it and slowly lets it back down to Idle. I have done fuel injector treatment, I have cleaned the Throttle body and cleaned the IAC. I can't think of what else might cause this. It is more of an annoyance than anything else. It runs awesome otherwise. Anyone got some new ideas?

~HJ
 
Reply With Quote
  #2  
Old 09-30-2007
Red_Ak_Ranger's Avatar
RF Veteran
iTrader: (1)
Join Date: Oct 2004
Posts: 17,221
I guess 3k is a lil high but....most trucks always start up at a high rev and then calm down.


When your vehicle starts, the ten seconds it runs "closed loop"(i believe its closed as compared to open) which means it is running on preprogrammed startup data. This is because your sensors don't immediatelly start working so it just runs in a safe manner.


Other than that explanation which didn't offer any real helpful advice, I blame corn.
 
Reply With Quote
  #3  
Old 09-30-2007
Ace's Avatar
Ace
Ace is offline
Member
iTrader: (4)
Join Date: Aug 2007
Location: Central, Illinois
Posts: 3,450
I have this problem to with my 2002 ranger except it doesn't go up to 3k it sit's at about 1,500 which normally would make me think its fine but it only does it every once in awhile like this morning when i first started my truck up it did it then tonight when i got off work it didn't do it. so i dont know
 
Reply With Quote
  #4  
Old 09-30-2007
06fx4 L2's Avatar
Member
Join Date: Mar 2007
Location: SO CAL
Posts: 430
open loop is when cold cause the loop is not complete (think of an on/off symbol I 0 )
and you may have a vacuume leak and once the computer goes into closed loope it figures it out and ajusted the idle..


JOSH
 
Reply With Quote
  #5  
Old 10-01-2007
wydopnthrtl's Avatar
Member
iTrader: (2)
Join Date: Dec 2005
Location: Ohio
Posts: 2,454
My 06 FX4 revs to about 2000rpms then settles down pretty quick.

3000 is too high. I'd look for a vacuum leak first.

Rich
 
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
buzz7453
2.9L & 3.0L V6 Tech
0
03-22-2015 09:44 AM
MissMechanic34601
2.9L & 3.0L V6 Tech
1
11-27-2014 11:08 AM
RangerXtreme
4.0L OHV & SOHC V6 Tech
16
01-06-2012 12:49 PM
Hillyard
2.9L & 3.0L V6 Tech
1
09-07-2011 04:50 AM
andddrew says
2.9L & 3.0L V6 Tech
1
01-18-2011 12:12 AM


Thread Tools
Search this Thread
Quick Reply: High Rev's at startup? 4.0 OHV


Contact Us Sitemap Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.