Lean 1 and 2 reading for emissions - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-27-2010
fx4wannabe's Avatar
Member
Thread Starter
 
Join Date: Nov 2009
Location: Woodbridge,Va
Posts: 357
Icon5 Lean 1 and 2 reading for emissions

Okay so my truck failed emisions twice and its coming back ot a lean 1 and lean 2 reading ... i replace the MAF and it didnt fix it ... is therre anything you guys can think of that can fix this problem ... the mechanics said that it was the intake manifold gasket ... but there the dumbasses that said if was the MAF ... i trust you guys more than them so yeha i need help
Reply With Quote
  #2  
Old 03-27-2010
01_ranger_4x4's Avatar
Member
iTrader: (4)
 
Join Date: Mar 2009
Location: Muskegon, Michigan
Posts: 3,585
i would look for a vacuum leak. the SOHC 4.0's have a vacuum line elbow that likes to crack and will leak causing a lean condition in both banks. ill try and find a pic of the elbow.

edit: heres the elbow that usually goes bad. its located under the throttle body and runs along the upper intake plenum.


Last edited by 01_ranger_4x4; 03-27-2010 at 04:18 PM.
Reply With Quote
  #3  
Old 03-27-2010
fourliter dan's Avatar
Member
 
Join Date: Dec 2007
Location: Lebanon, OR
Posts: 2,229
i just had the same issue a couple weeks ago. its that elbow. its a really easy fix
Reply With Quote
  #4  
Old 03-27-2010
buckgnarly's Avatar
Member
iTrader: (11)
 
Join Date: Jan 2005
Location: West Topsham, VT
Posts: 1,709
Chalk up another to the cracked elbow....
Reply With Quote
  #5  
Old 03-27-2010
fx4wannabe's Avatar
Member
Thread Starter
 
Join Date: Nov 2009
Location: Woodbridge,Va
Posts: 357
hahah u guys are awsome ,,, stuopid machaniucs ... dont know a ranger better than a ranger boy themself ... thanks
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
PCM and Emissions pearlkid9988 Drivetrain Tech 3 08-28-2013 03:26 PM
speedometer and odometer not reading correctly Saberball General Technical & Electrical 0 06-15-2011 07:16 PM
Check gage light and no oil pressure reading Alon 4.0L OHV & SOHC V6 Tech 4 04-12-2007 02:24 PM
glasspack & emissions LowMaz 2.9L & 3.0L V6 Tech 10 02-06-2007 08:02 PM
lean bank 1 / lean bank 2 acxlt01ranger4x4 4.0L OHV & SOHC V6 Tech 4 06-24-2006 07:52 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 08:44 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.