need help ASAP - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-12-2008
dbking321's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Mar 2007
Location: Shippensburg/York PA
Posts: 636
need help ASAP

ok im gonna vent a lil in part one so if u want to know what the problem is go to part 2

1. so i had a freaking horrible day that abuncha **** when wrong most of it was family stuff but i got over that and was coming home form my gf house and my ****ing truck dies wtf so it try to restart it and nothing it just turns over. luckly it was near my house so my dad came and pulled me home. ahh i hate ford

2 ok now that thats out
i hit a puddle a frew day ago and it started squeeking horrible but went away then it jsut would squeek horribley when i started it when it was cold but then went away so i thought it was a wet belt
but tonight i was goning home and all of a sudden with out warning it just dies
now it turns over but nothing so whats the deal
and my battery oil and engine light are on. but the temp gauge was normal 2
any ideas i wanna go kayak in the morn
Reply With Quote
  #2  
Old 07-12-2008
bwester04's Avatar
Member
 
Join Date: Mar 2006
Location: Round Rock, Tx
Posts: 2,641
Sounds like you got some water in a connector somewhere, possible one of the big wire harness connectors in your engine bay. Good luck man
Reply With Quote
  #3  
Old 07-12-2008
03danger's Avatar
Member
 
Join Date: Feb 2008
Location: FTC, Colorado
Posts: 45
um... maybe far fetched , but try and disconnect ur ground on ur battery for 30 seconds. It will reset ur map, dont have a clue if it will for sure fix it, but i had a similar incident and I had mine disconnected working on the stereo and when i put it back on I tried to start it for the ****'s of it, and it fixed it , my mechanic said resetting the mapping may have fixed it's "hic-cup"
Reply With Quote
  #4  
Old 07-12-2008
dbking321's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Mar 2007
Location: Shippensburg/York PA
Posts: 636
ok ill try that in the morning any more ideas would be great i just dont understand y then cause i drove it for 15 min just fine then poof it dies
Reply With Quote
  #5  
Old 07-13-2008
dbking321's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Mar 2007
Location: Shippensburg/York PA
Posts: 636
so im calling the shop tommaro gonna have to have it towed in
Reply With Quote
  #6  
Old 07-13-2008
zabeard's Avatar
who?
iTrader: (8)
 
Join Date: Nov 2004
Location: IN
Posts: 26,045
check your air filter? belt? spark plugs? what about the battery? is the light still green? have atleast 12volts on it?

if it runs for 15 min its not going to over heat if the belt is trash. (depending on your driving style)
Reply With Quote
  #7  
Old 07-13-2008
redranger_02's Avatar
Member
 
Join Date: Oct 2006
Location: Evansville, Indiana
Posts: 641
did you check your alternator? sounds like maybe it could have fried itself.
Reply With Quote
  #8  
Old 07-14-2008
dbking321's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Mar 2007
Location: Shippensburg/York PA
Posts: 636
its at the shop but i just randomly died
it woudltn start in the mornign
it turn over and mabey start for 4 seconds then jsut keep turning. o well i just hope its done by wendsday i really need a truck for that day and know one i know has one
Reply With Quote
  #9  
Old 07-14-2008
dbking321's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Mar 2007
Location: Shippensburg/York PA
Posts: 636
and it has a 2 month old belt
Reply With Quote
  #10  
Old 07-14-2008
My05edge's Avatar
Member
 
Join Date: Dec 2006
Location: Midland, TX
Posts: 1,351
last time that happened to me i was still under warranty and took it to ford, turns out the fuel pump relay died, check the fuse panel under the hood.
Reply With Quote
  #11  
Old 07-18-2008
FireRanger235's Avatar
Member
 
Join Date: Jul 2007
Location: Dixon,MO
Posts: 52
I've had this happen before after I hit a deep pothole in the road and after almost giving up I was told to check the fuel pump inertia switch located just to the top of and behind the passenger side kick panel. Push it down and see if it resets. Not sure if they still use those and if they are in the same spot though.
Reply With Quote
  #12  
Old 07-18-2008
dbking321's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Mar 2007
Location: Shippensburg/York PA
Posts: 636
so i got it back today my underdrive pully broke causeing it to make a groof in my crank shaft so i had to get a new pully, bolt belt and crank sensor so that was about 250 then my 500 in labor so the stealer ship got 750 not tomention my car sat there for 3 day. so im never goin back i always never liked them much but least i got a car again
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
E-Brake help. Please help me out. Need to get done asap. rybread5520 General Technical & Electrical 2 01-02-2009 10:41 PM
need help asap RANGERLOVER General Ford Ranger Discussion 6 09-25-2008 01:02 PM
need help asap!!! Bad water leak!!! blkranger Interior Semi-Tech 3 07-07-2005 01:53 PM
Need Help Asap BananaEdge Exterior Semi-Tech 14 04-16-2005 08:47 PM
I NEED GAUGE HELP ASAP!! (this is different than my previous gauge post) please! TippnOver Interior Semi-Tech 7 02-02-2005 12:56 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 11:53 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.