ruff idle - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-19-2008
Member
Thread Starter
 
Join Date: Apr 2008
Location: Cumberland, MD
Posts: 8
ruff idle

a couple months ago my 2002 4.0L starting acting like it had a bad IAC .... dropping RPM"S at idle ... I had this happen to it once before ... it would idle fine then drop 100 rpm or so and back smooth ..... I cleaned it before and then cleared it up ... then it started again .... cleaned it and no help .... so I took it to a garage and he cleaned the MAF and IAC too ... then when I got it back it was idling different ... it was like it was loading up and surging ... so I take it back and he changes the fuel filter and spark plugs and said I had the wrong plugs in it ... they were too short and he puts in Autolites .... and he raised the idle ..... but it still was idling bad... so I put a new IAC in and still no help .... then I get some bosch plus's and put in (same as I had in it before and it ran fine for 25,000 miles) still no help ...... running out of ideas ... it has 112,000 miles ... gas mileage seems fine .... just ruff at idle .....

so does anyne have any idea's as where to look next ? Thanks
Reply With Quote
  #2  
Old 04-19-2008
rangerboy101's Avatar
RF Veteran
iTrader: (5)
 
Join Date: Aug 2007
Location: Winchester, Va
Posts: 8,187
v8 swap maybe! lol. jk. that sucks though.
Reply With Quote
  #3  
Old 04-19-2008
04 EDGE
Unregistered User
 
Posts: n/a
first, throw the bosch plugs in the garbage.
next get some motorcraft plugs and a good set of wires, install and retest.
Reply With Quote
  #4  
Old 04-20-2008
Member
Thread Starter
 
Join Date: Apr 2008
Location: Cumberland, MD
Posts: 8
doubt it's the plugs

the autolite plat. done the same thing so plugs are not the problem .... wires maybe ........
Reply With Quote
  #5  
Old 04-21-2008
Member
Thread Starter
 
Join Date: Apr 2008
Location: Cumberland, MD
Posts: 8
not the plugs

I put motorcraft plugs in today and it's still not right .... dug a little more and and the PVC was pretty much plugged ... renewed that and itstill doesn't idle right ...... Help


PS it's a damp rainy night and I started it up in the dark and I'm not seeing any sparks anywhere
Reply With Quote
  #6  
Old 04-22-2008
Member
iTrader: (1)
 
Join Date: Mar 2008
Location: Union City, PA
Posts: 170
check for vaccum leaks.
Reply With Quote
  #7  
Old 04-22-2008
mx98ranger's Avatar
Member
 
Join Date: Apr 2005
Location: GA
Posts: 1,493
Quote:
Originally Posted by surfchunker View Post
a couple months ago my 2002 4.0L starting acting like it had a bad IAC .... dropping RPM"S at idle ... I had this happen to it once before ... it would idle fine then drop 100 rpm or so and back smooth ..... I cleaned it before and then cleared it up ... then it started again .... cleaned it and no help .... so I took it to a garage and he cleaned the MAF and IAC too ... then when I got it back it was idling different ... it was like it was loading up and surging ... so I take it back and he changes the fuel filter and spark plugs and said I had the wrong plugs in it ... they were too short and he puts in Autolites .... and he raised the idle ..... but it still was idling bad... so I put a new IAC in and still no help .... then I get some bosch plus's and put in (same as I had in it before and it ran fine for 25,000 miles) still no help ...... running out of ideas ... it has 112,000 miles ... gas mileage seems fine .... just ruff at idle .....

so does anyne have any idea's as where to look next ? Thanks
when he said he raised the idle, what exactly did he mean? idle is computer controlled on your truck.. its not like he can just change it..
Reply With Quote
  #8  
Old 05-13-2008
Member
Thread Starter
 
Join Date: Apr 2008
Location: Cumberland, MD
Posts: 8
Fixed it today

it was the EGR vacuum regulator that was bad .... changed that and it idles as smooth as a baby's bottom ...
Reply With Quote
  #9  
Old 05-22-2008
4.0ltwins's Avatar
Member
 
Join Date: Apr 2008
Location: crawfordville, florida
Posts: 40
mine does it to

try looking for a vacuum leak in the upper intake. mine has done it for months and i cant find anything wrong. the feul trims are way high though. mine is a 99 with 214,00
Reply With Quote
  #10  
Old 05-29-2008
Member
Thread Starter
 
Join Date: Apr 2008
Location: Cumberland, MD
Posts: 8
read previous post

problem was solved
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
very very ruff idle hotrod6680 2.9L & 3.0L V6 Tech 1 01-05-2015 12:09 PM
1999 Ford ranger 3.0 V6 has a very Ruff Idle oldcarlover 2.9L & 3.0L V6 Tech 1 12-08-2014 12:15 AM
Ruff idle after Sea Foam, check engine light on russian 2.9L & 3.0L V6 Tech 11 02-26-2011 09:01 AM
Ruff Stuff Specialties... zabeard Ranger Products, Company, & Member Reviews 7 07-06-2008 05:24 PM
Very ruff idle at random schatten789 2.9L & 3.0L V6 Tech 13 03-02-2008 09:01 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 09:41 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.