truck stalls when put in park - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 09-19-2009
citytricker's Avatar
Member
Thread Starter
 
Join Date: Jul 2007
Location: Huntington,WV
Posts: 94
truck stalls when put in park

my 2002 LXT 4.0sohc truck dies when i go from D to R or P. starts fine. drives fine. and seems to idal fine. my history. changed PCV one year ago fuel filter last week. had a check engine light that turned out to be a vac leak. it was located on the Lt side of engine just under the coolent hose going into the intake man now fixed. other than that no real problems. any ideas? TX
Reply With Quote
  #2  
Old 09-19-2009
Demo1986's Avatar
Member
 
Join Date: Feb 2009
Location: Long Beach, CA
Posts: 423
i had the same issue. when it was on P it would turn off and from D to R and if i didnt switch fast and i kept it in N it would shut off. the issue, PCV. if u still have this issue it might be a blow head gasket, not sure.
Reply With Quote
  #3  
Old 09-19-2009
citytricker's Avatar
Member
Thread Starter
 
Join Date: Jul 2007
Location: Huntington,WV
Posts: 94
has this not happend to anyone
Reply With Quote
  #4  
Old 09-20-2009
ryan_88's Avatar
Member
 
Join Date: Nov 2007
Location: Somersworth, NH
Posts: 71
same things happening to me right now too. i am throwing code p0401 (insufficient egr flow) I've replaced the EGR and DPFE. going to try a new PCV valve this week.
Reply With Quote
  #5  
Old 09-20-2009
citytricker's Avatar
Member
Thread Starter
 
Join Date: Jul 2007
Location: Huntington,WV
Posts: 94
i have no check engine light on
Reply With Quote
  #6  
Old 09-21-2009
citytricker's Avatar
Member
Thread Starter
 
Join Date: Jul 2007
Location: Huntington,WV
Posts: 94
anyone have any honest ideas
Reply With Quote
  #7  
Old 09-21-2009
seed60's Avatar
RF Veteran
iTrader: (15)
 
Join Date: Jun 2008
Location: Mooresville, NC
Posts: 5,584
I had a similar problem. Not sure what it was or how I fixed it. I did plugs, fuel filter, and regular tune up stuff and it stopped.
Reply With Quote
  #8  
Old 09-21-2009
citytricker's Avatar
Member
Thread Starter
 
Join Date: Jul 2007
Location: Huntington,WV
Posts: 94
you didnt change anything else. just plugs and fuel filter
Reply With Quote
  #9  
Old 09-21-2009
seed60's Avatar
RF Veteran
iTrader: (15)
 
Join Date: Jun 2008
Location: Mooresville, NC
Posts: 5,584
Quote:
Originally Posted by citytricker View Post
you didnt change anything else. just plugs and fuel filter
I did wires too, oil, air filter, cleaned iac, maf, and tb. First time I had cleaned those last 3 and plugs hadn't been done in 70k or more. Made a noticable difference and stopped my idle/cutoff issues. I think I seafoamed it too.

It was all just regular maintenance things that I should have been doing anyway.
Reply With Quote
  #10  
Old 09-21-2009
citytricker's Avatar
Member
Thread Starter
 
Join Date: Jul 2007
Location: Huntington,WV
Posts: 94
sorry whats the iac, got the other two
Reply With Quote
  #11  
Old 10-04-2009
north44's Avatar
Member
 
Join Date: Dec 2008
Location: Toronto, Ontario, Canada
Posts: 174
IAC = Idle Air Control
Reply With Quote
  #12  
Old 10-05-2009
Member
 
Join Date: Sep 2007
Location: North Liberty, Iowa
Posts: 35
Might check the switch that prevents starting in any gear other than Park or Neutral. If it is bad or has shifted position it could cut the engine off when the selector is put into park.
Reply With Quote
  #13  
Old 10-23-2009
jtfoxman's Avatar
Member
 
Join Date: Jun 2005
Location: The Poconos
Posts: 891
Didn't happen to the Ranger but my wife's car did the same thing, especially when you go from drive to park or reverse really quick.. I discovered it had a tranny leak and was low on fluid. Fixed that and no more problem. Does it hesitate around turns?
Reply With Quote
  #14  
Old 10-23-2009
Crunchy's Avatar
Member
 
Join Date: Oct 2007
Location: Hull, Quebec
Posts: 486
I paid Ford $300 to find the source of this exact problem. My airbox lid wasn't sealing properly cause one of the clips broke. Zip tie fixed it.
Reply With Quote
  #15  
Old 10-24-2009
Jazz921's Avatar
Member
iTrader: (2)
 
Join Date: Sep 2007
Location: Evansville, IN
Posts: 997
Check the rubber elbow on the front side of the intake, its the hose that comes from the PCV valve to the front of the intake, they go bad on the 4.0 and cause this issue, also take your throttle body off and clean it, the build up around the butterfly inside can cause this as well.
Reply With Quote
  #16  
Old 04-27-2016
Member
 
Join Date: Apr 2016
Location: Niantic, CT
Posts: 2
Same prob

Im having the same issue, and im thinking its the neutral safety switch starting to fail. It feels more like a shut down than an engine stalling. Anyone agree?
Reply With Quote
  #17  
Old 04-27-2016
Member
 
Join Date: Apr 2016
Location: Niantic, CT
Posts: 2
Stalling and idle drop

4.0 litre explorer drops rpms and sometimes stalls when put in park or neutral. I also noticed that the oil pressure guage will pop up and down a couple times as well. Could this be the pcv valve?

Last edited by Kal52; 04-27-2016 at 05:33 PM. Reason: Adding info
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1995 E350 stalls while idling... this truck NEVER stalls. Ever..??? FMD General Ford Discussion 1 10-31-2016 02:53 AM
Stalls when put into park or neutral from drive? AGAVLAK 4.0L OHV & SOHC V6 Tech 13 05-11-2016 07:47 PM
Truck dips below 500 rpms when put into park even after replacing IAC Liquidswords32 General Technical & Electrical 14 05-17-2011 05:28 PM
Truck dies when put in Park Liquidswords32 General Technical & Electrical 1 05-07-2011 03:31 PM
Stalls when shifting to park redbaron General Technical & Electrical 12 05-07-2011 12:47 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 10:15 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.